aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-09-06 17:16:38 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-09-06 19:28:28 +0000
commitb1670e2c3d42a2aeacff843ef0ccea21c0929d03 (patch)
treeec01615cd0e0f43e4defe8feaf95d24a9983444e /lang/rust/Makefile
parentb7fe3caf7f6c269458d86cdf77cc59568b6d5041 (diff)
downloadports-b1670e2c3d42a2aeacff843ef0ccea21c0929d03.tar.gz
ports-b1670e2c3d42a2aeacff843ef0ccea21c0929d03.zip
lang/rust*: Mk/Uses/cargo.mk: Move TMPDIR to WRKDIR
rustc stashes intermediary files in TMPDIR (default /tmp) which might cause issues for users that for some reason space limit their /tmp. WRKDIR should have plenty of space. Other ports that use rustc might be affected too, but set it only in USES=cargo and lang/rust* ports for now. PR: 258126 With hat: rust
Diffstat (limited to 'lang/rust/Makefile')
-rw-r--r--lang/rust/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 26185e9697df..25ba0b104626 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -44,6 +44,12 @@ TEST_ENV= ${MAKE_ENV} \
CONFLICTS_INSTALL?= rust-nightly
+# rustc stashes intermediary files in TMPDIR (default /tmp) which
+# might cause issues for users that for some reason space limit
+# their /tmp. WRKDIR should have plenty of space.
+# ?= to allow users to still overwrite it in make.conf.
+TMPDIR?= ${WRKDIR}
+
OPTIONS_DEFINE= DOCS GDB SOURCES WASM
OPTIONS_DEFAULT= SOURCES WASM
OPTIONS_EXCLUDE_armv6= DOCS