aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/Makefile
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2020-10-13 08:36:35 +0000
committerMikael Urankar <mikael@FreeBSD.org>2020-10-13 08:36:35 +0000
commitd9b97de179c9fd40d60ae2a5bfd88345c24224a6 (patch)
tree18466482208f0156b3fbf6da4b2d4af87fe469fd /lang/rust/Makefile
parent08812e658283f35fada5819db71cbcf0f6cc91e5 (diff)
downloadports-d9b97de179c9fd40d60ae2a5bfd88345c24224a6.tar.gz
ports-d9b97de179c9fd40d60ae2a5bfd88345c24224a6.zip
lang/rust: Update to 1.47.0
- Add powerpc64le arch (submitted by bdragon in D26711) - Disable DOCS, same problem fixed in r546048 - Update devel/racer to 2.1.36 - Import upstream patch to fix www/firefox (https://hg.mozilla.org/integration/autoland/rev/e2cede25c027) - Import gentoo patches to fix www/firefox-esr, www/cliqz and mail/thunderbird (https://dev.gentoo.org/~whissi/mozilla/patchsets/firefox-esr-78-patches-03.tar.xz : 0036, 0037 and 0038) - Force rebuild all consumers to catch regressions Changelog: https://github.com/rust-lang/rust/releases/tag/1.47.0 Differential Revision: https://reviews.freebsd.org/D26721
Notes
Notes: svn path=/head/; revision=552221
Diffstat (limited to 'lang/rust/Makefile')
-rw-r--r--lang/rust/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 1fef1c50e68a..0e21e60c097c 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -2,11 +2,13 @@
# $FreeBSD$
PORTNAME= rust
-PORTVERSION?= 1.46.0
+PORTVERSION?= 1.47.0
PORTREVISION?= 0
CATEGORIES= lang
MASTER_SITES= https://static.rust-lang.org/dist/:src \
https://dev-static.rust-lang.org/dist/:src \
+ LOCAL/bdragon/rust:bootstrap \
+ LOCAL/mikael/rust:bootstrap \
LOCAL/tobik/rust:bootstrap \
https://static.rust-lang.org/dist/:bootstrap
DISTNAME?= ${PORTNAME}c-${PORTVERSION}-src
@@ -25,7 +27,7 @@ LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE-APACHE
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
IGNORE_FreeBSD_11_powerpc64= is missing a bootstrap for FreeBSD 11.x powerpc64
-ONLY_FOR_ARCHS?= aarch64 amd64 armv6 armv7 i386 powerpc64
+ONLY_FOR_ARCHS?= aarch64 amd64 armv6 armv7 i386 powerpc64 powerpc64le
ONLY_FOR_ARCHS_REASON?= requires prebuilt bootstrap compiler
BUILD_DEPENDS= cmake:devel/cmake \
@@ -49,6 +51,7 @@ CONFLICTS_INSTALL?= rust-nightly
OPTIONS_DEFINE= DOCS GDB SOURCES WASM
OPTIONS_DEFAULT= SOURCES WASM
+OPTIONS_EXCLUDE= DOCS # https://github.com/rust-lang/rust/issues/76526
GDB_DESC= Install ports gdb (necessary for debugging rust programs)
SOURCES_DESC= Install source files
@@ -63,9 +66,9 @@ WASM_VARS= _RUST_BUILD_WASM=true \
WASM_VARS_OFF= _RUST_BUILD_WASM=false
# See WRKSRC/src/stage0.txt for the date and version values.
-BOOTSTRAPS_DATE?= 2020-08-03
-RUST_BOOTSTRAP_VERSION?= 1.45.2
-CARGO_BOOTSTRAP_VERSION?= 0.46.1
+BOOTSTRAPS_DATE?= 2020-08-27
+RUST_BOOTSTRAP_VERSION?= 1.46.0
+CARGO_BOOTSTRAP_VERSION?= 0.47.0
BOOTSTRAPS_SUFFIX?= ${BOOTSTRAPS_SUFFIX_${ARCH}}
BOOTSTRAPS_SUFFIX_powerpc64?= -${PPC_ABI:tl}