aboutsummaryrefslogtreecommitdiff
path: root/lang/spidermonkey78/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-12-28 15:57:34 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-12-28 15:57:34 +0000
commit71ffba14a6d099c2dc25ece21ec523b9f0d499a6 (patch)
tree2a6e76fd36c5031860fddd594ae6993dd4351eec /lang/spidermonkey78/Makefile
parent83d703a2a7163626b723934766b33f69b10e849b (diff)
downloadports-71ffba14a6d099c2dc25ece21ec523b9f0d499a6.tar.gz
ports-71ffba14a6d099c2dc25ece21ec523b9f0d499a6.zip
lang/spidermonkey78: fix build on GCC architectures
GCC architectures need LLVM too for llvm-objdump.
Notes
Notes: svn path=/head/; revision=559496
Diffstat (limited to 'lang/spidermonkey78/Makefile')
-rw-r--r--lang/spidermonkey78/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/spidermonkey78/Makefile b/lang/spidermonkey78/Makefile
index 871d74e161f7..1a52d04ad2fd 100644
--- a/lang/spidermonkey78/Makefile
+++ b/lang/spidermonkey78/Makefile
@@ -62,6 +62,9 @@ CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
# Require newer Clang than what's in base system unless user opted out
# or the base system is new enough.
.if ${CHOSEN_COMPILER_TYPE} == gcc
+CONFIGURE_ENV+= LLVM_CONFIG=llvm-config${LLVM_DEFAULT} \
+ LLVM_OBJDUMP=llvm-objdump${LLVM_DEFAULT}
+BUILD_DEPENDS+= ${LOCALBASE}/bin/llvm-objdump${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
USE_GCC= yes
.elif ${CC} == cc && ${CXX} == c++ && exists(/usr/lib/libc++.so) && \
${COMPILER_VERSION} < 80