aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2020-03-13 09:27:15 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2020-03-13 09:27:15 +0000
commit036eb6b6fab9454c554ae0500de55b3f0f7ac614 (patch)
treebc6f09895cdb962ddc732986c8ceabac1b0c9d42 /lang
parente47344f5d6f6f62a9da0f0135d5863fa6ff4e481 (diff)
downloadports-036eb6b6fab9454c554ae0500de55b3f0f7ac614.tar.gz
ports-036eb6b6fab9454c554ae0500de55b3f0f7ac614.zip
lang/ruby27: throw out irb, ri, rdoc from lang/ruby27
because they're provided as "default gem" since Ruby 2.6. We provide "default gem"s as gem ports rather than a part of lang/ruby* port. files/patch-tool_rbinstall.rb makes not to install such default gems however hollow wrapper scripts bin/{irb,ri,rdoc} and their manpages were still left. This commit intend to move out such wrapper scripts and manpages to gem ports completely. PR: 243888 Submitted by: Yasuhiro KIMURA <yasu@utahime.org> (initial revision) meta (myself) Differential Revision: https://reviews.freebsd.org/D23514
Notes
Notes: svn path=/head/; revision=528339
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby27/Makefile8
-rw-r--r--lang/ruby27/pkg-message9
-rw-r--r--lang/ruby27/pkg-plist10
3 files changed, 10 insertions, 17 deletions
diff --git a/lang/ruby27/Makefile b/lang/ruby27/Makefile
index abc05113b839..fed65a02db40 100644
--- a/lang/ruby27/Makefile
+++ b/lang/ruby27/Makefile
@@ -118,8 +118,8 @@ PKGNAMESUFFIX= ${RUBY_VER:C/\.//}
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-INSTALLED_SCRIPTS= erb irb rdoc ri ruby
-INSTALLED_MANUALS= erb irb ri ruby
+INSTALLED_SCRIPTS= erb ruby
+INSTALLED_MANUALS= erb ruby
EXTSAMPLES= bigdecimal/sample/*.rb
@@ -133,7 +133,9 @@ RB_SET_CONF_VAR=${SH} -c '${REINPLACE_CMD} -E -e "s,(CONFIG\[\"$$0\"\][[:space:]
post-patch:
# We get these from other ports
-.for d in bin/bundle* bin/*racc* lib/bundler* libexec/bundler* man/bundle* bin/gem man/gemfile* \
+.for d in bin/bundle* bin/gem bin/*racc* bin/irb bin/rdoc bin/ri \
+ lib/bundler* libexec/bundler* \
+ man/bundle* man/gemfile* man/irb.1 man/ri.1 \
ext/dbm ext/gdbm ext/win32ole
@${RM} -r ${BUILD_WRKSRC}/${d}
.endfor
diff --git a/lang/ruby27/pkg-message b/lang/ruby27/pkg-message
index a35ee1279372..f17727bf3fcb 100644
--- a/lang/ruby27/pkg-message
+++ b/lang/ruby27/pkg-message
@@ -4,10 +4,11 @@
Some of the standard commands are provided as separate ports for ease
of upgrading:
- devel/ruby-gems: gem - RubyGems package manager
- devel/rubygem-irb: irb - Interactive Ruby
- devel/rubygem-rake: rake - Ruby Make
- devel/rubygem-rdoc: rdoc - Ruby Documentation System
+ devel/ruby-gems: gem - RubyGems package manager
+ devel/rubygem-irb: irb - Interactive Ruby
+ devel/rubygem-rake: rake - Ruby Make
+ devel/rubygem-rdoc: rdoc - Ruby Documentation System
+ sysutils/rubygem-bundler: bundler - Tool that manages gem dependencies for ruby applications
And some of the standard libraries are provided as separate ports
since they require extra dependencies:
diff --git a/lang/ruby27/pkg-plist b/lang/ruby27/pkg-plist
index 734b338d35c0..7879a660d1ec 100644
--- a/lang/ruby27/pkg-plist
+++ b/lang/ruby27/pkg-plist
@@ -1,11 +1,5 @@
%%IF_DEFAULT%%bin/erb
bin/erb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/irb
-bin/irb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/rdoc
-bin/rdoc%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/ri
-bin/ri%%RUBY_SUFFIX%%
%%IF_DEFAULT%%bin/ruby
bin/ruby%%RUBY_SUFFIX%%
include/ruby-%%RUBY_VER%%/%%RUBY_ARCH%%/rb_mjit_min_header-%%RUBY_VERSION%%.h
@@ -960,10 +954,6 @@ lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
libdata/pkgconfig/ruby-%%RUBY_VER%%.pc
%%IF_DEFAULT%%man/man1/erb.1.gz
man/man1/erb%%RUBY_SUFFIX%%.1.gz
-%%IF_DEFAULT%%man/man1/irb.1.gz
-man/man1/irb%%RUBY_SUFFIX%%.1.gz
-%%IF_DEFAULT%%man/man1/ri.1.gz
-man/man1/ri%%RUBY_SUFFIX%%.1.gz
%%IF_DEFAULT%%man/man1/ruby.1.gz
man/man1/%%RUBY_NAME%%.1.gz
%%DOCS%%%%RUBY_DOCDIR%%/COPYING