aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-19 19:03:34 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-19 19:03:34 +0000
commit2656e56db82db4b8375e92858e6989a7ded1e681 (patch)
tree1ab7893643956eda228189ccd9ad3176d55bcd4f /lang
parent46045898ae4adf7563733caa5c1cbb99dc661be9 (diff)
downloadports-2656e56db82db4b8375e92858e6989a7ded1e681.tar.gz
ports-2656e56db82db4b8375e92858e6989a7ded1e681.zip
upgrade to 2.25.1
PR: 27373 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=42747
Diffstat (limited to 'lang')
-rw-r--r--lang/clisp/Makefile43
-rw-r--r--lang/clisp/distinfo2
-rw-r--r--lang/clisp/files/patch-aa2
-rw-r--r--lang/clisp/files/patch-ab33
-rw-r--r--lang/clisp/pkg-plist8
5 files changed, 46 insertions, 42 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index eb874b2c9027..522ed3122efb 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -6,30 +6,42 @@
#
PORTNAME= clisp
-PORTVERSION= 2000.03.06
+PORTVERSION= 2.25.1
CATEGORIES= lang
-MASTER_SITES= ftp://ftp2.cons.org/pub/lisp/clisp/source/ \
- ftp://ftp.freesoftware.com/pub/lisp/clisp/source/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
+MASTER_SITES= ftp://clisp.cons.org/pub/lisp/clisp/source/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= jabrown@caida.org
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+# The build uses INSTALL_* to copy files around, but since the Ports
+# INSTALL_* try to set file permissions, using them breaks non-root builds.
+# Instead, we'll just fix up permissions in the post-install target, after we
+# install the files.
+CONFIGURE_ENV+= INSTALL=${CP} INSTALL_DATA=${CP} INSTALL_PROGRAM=${CP} \
+ INSTALL_SCRIPT=${CP} INSTALL_MAN=${CP}
# Build subdirectory
-BUILD_DIRNAME=obj
+BUILD_DIRNAME=${CONFIGURE_TARGET}
-# These came from clisp's "configure" on my system.
+# These came from clisp-2.25.1's "configure" on my 4.1.1-R system.
MAKEMAKE_ARGS=--prefix=${PREFIX} --with-readline --with-gettext \
--with-dynamic-ffi
# The post-install target uses these to fix permissions.
DATA_PATHS=${PREFIX}/lib/clisp ${PREFIX}/share/doc/clisp \
${PREFIX}/share/locale/de/LC_MESSAGES/clisp.mo \
+ ${PREFIX}/share/locale/de/LC_MESSAGES/clisplow.mo \
${PREFIX}/share/locale/en/LC_MESSAGES/clisp.mo \
+ ${PREFIX}/share/locale/en/LC_MESSAGES/clisplow.mo \
${PREFIX}/share/locale/es/LC_MESSAGES/clisp.mo \
+ ${PREFIX}/share/locale/es/LC_MESSAGES/clisplow.mo \
${PREFIX}/share/locale/fr/LC_MESSAGES/clisp.mo \
- ${PREFIX}/share/locale/nl/LC_MESSAGES/clisp.mo
+ ${PREFIX}/share/locale/fr/LC_MESSAGES/clisplow.mo \
+ ${PREFIX}/share/locale/nl/LC_MESSAGES/clisp.mo \
+ ${PREFIX}/share/locale/nl/LC_MESSAGES/clisplow.mo
PROG_PATHS=${PREFIX}/bin/clisp
MAN_PATHS=${PREFIX}/man/man1/clisp.1 ${PREFIX}/man/man3/clreadline.3
@@ -38,27 +50,12 @@ post-extract:
@cd ${WRKSRC} && \
printf "all install:\n\t@cd ${WRKSRC}/${BUILD_DIRNAME} && \$${MAKE} \$${MAKEFLAGS} \$$@\n" > ${WRKSRC}/Makefile
-# It looks like the 'configure' script in the source gets seriously confused
-# by the environment it gets from GNU_CONFIGURE=YES, so we'll call it here.
-#
-# The 'configure' wants the CC environment variable to include CFLAGS; but
-# I'll edit it since if CFLAGS includes "-pipe", configure gets stuck reading
-# from stdin, using the assembler in gcc 2.7.2.3
-pre-configure:
- @cd ${WRKSRC} && \
- ${RM} -rf ${BUILD_DIRNAME} && \
- ${SETENV} CC="${CC} `echo ${CFLAGS} | ${SED} s/-pipe//`" \
- ./configure --prefix=${PREFIX} ${BUILD_DIRNAME}
-
# The 'configure' script stops short of doing this for us.
post-configure:
@cd ${WRKSRC}/${BUILD_DIRNAME} && \
./makemake ${MAKEMAKE_ARGS} > Makefile && \
- make config.lsp
+ make config.lisp
-# The build uses INSTALL_* to copy files around, but since the Ports
-# INSTALL_* try to set file permissions, using them breaks non-root builds.
-# Instead, we'll just fix up permissions after we install the files.
post-install:
${CHOWN} -R ${BINOWN}.${BINGRP} ${PROG_PATHS}
${CHMOD} -R ugo+rX,ugo-w ${PROG_PATHS}
diff --git a/lang/clisp/distinfo b/lang/clisp/distinfo
index 18f8cecfe729..e4217dbcf73b 100644
--- a/lang/clisp/distinfo
+++ b/lang/clisp/distinfo
@@ -1 +1 @@
-MD5 (clisp-2000-03-06.tar.bz2) = 1eaf0cd4e3818ff75dd4e4d277a3c010
+MD5 (clisp-2.25.1.tar.bz2) = 3806df44a0e77c63788ad0bb9186f1f6
diff --git a/lang/clisp/files/patch-aa b/lang/clisp/files/patch-aa
index b3f793c1f85c..ad18cfa10c4a 100644
--- a/lang/clisp/files/patch-aa
+++ b/lang/clisp/files/patch-aa
@@ -1,6 +1,6 @@
--- src/makemake.in.orig Tue Jul 20 12:03:11 1999
+++ src/makemake.in Sun Feb 6 11:12:23 2000
-@@ -1593,7 +1593,14 @@
+@@ -1619,7 +1619,14 @@
echol "mandir = \$(exec_prefix)${NEXT_}man"
echol "htmldir = \$(exec_prefix)${NEXT_}share${NEXT_}html"
echol "dvidir = \$(exec_prefix)${NEXT_}share${NEXT_}dvi"
diff --git a/lang/clisp/files/patch-ab b/lang/clisp/files/patch-ab
index 2755d092561d..6b3ea1d74f24 100644
--- a/lang/clisp/files/patch-ab
+++ b/lang/clisp/files/patch-ab
@@ -1,19 +1,20 @@
---- src/socket.d.orig Fri Jan 14 07:06:05 2000
-+++ src/socket.d Tue Apr 3 03:07:32 2001
-@@ -299,14 +299,14 @@
- {
+--- src/socket.d.orig Mon Mar 19 11:13:09 2001
++++ src/socket.d Tue May 15 13:35:22 2001
+@@ -304,7 +304,7 @@
#ifdef HAVE_INET_PTON
#ifdef HAVE_IPV6
-- { var struct sockaddr_in6 inaddr;
-+ { var struct sockaddr_in6 inaddr = {0};
- if (inet_pton(AF_INET6,host,&inaddr.sin6_addr) > 0)
- { inaddr.sin6_family = AF_INET6;
- inaddr.sin6_port = htons(port);
- return connector((struct sockaddr *) &inaddr, sizeof(struct sockaddr_in6));
- } }
+ {
+- var struct sockaddr_in6 inaddr;
++ var struct sockaddr_in6 inaddr = {0};
+ if (inet_pton(AF_INET6,host,&inaddr.sin6_addr) > 0) {
+ inaddr.sin6_family = AF_INET6;
+ inaddr.sin6_port = htons(port);
+@@ -313,7 +313,7 @@
+ }
#endif
-- { var struct sockaddr_in inaddr;
-+ { var struct sockaddr_in inaddr = {0};
- if (inet_pton(AF_INET,host,&inaddr.sin_addr) > 0)
- { inaddr.sin_family = AF_INET;
- inaddr.sin_port = htons(port);
+ {
+- var struct sockaddr_in inaddr;
++ var struct sockaddr_in inaddr = {0};
+ if (inet_pton(AF_INET,host,&inaddr.sin_addr) > 0) {
+ inaddr.sin_family = AF_INET;
+ inaddr.sin_port = htons(port);
diff --git a/lang/clisp/pkg-plist b/lang/clisp/pkg-plist
index fbc0a462849c..770041bf5a8f 100644
--- a/lang/clisp/pkg-plist
+++ b/lang/clisp/pkg-plist
@@ -1,5 +1,4 @@
bin/clisp
-lib/clisp/clisp-link
lib/clisp/base/libavcall.a
lib/clisp/base/libcallback.a
lib/clisp/base/libiconv.a
@@ -13,7 +12,9 @@ lib/clisp/base/lispinit.mem
lib/clisp/base/makevars
lib/clisp/base/modules.h
lib/clisp/base/modules.o
+lib/clisp/clisp-link
lib/clisp/data/UnicodeData.txt
+lib/clisp/data/clhs.txt
lib/clisp/full/libavcall.a
lib/clisp/full/libcallback.a
lib/clisp/full/libiconv.a
@@ -52,10 +53,15 @@ share/doc/clisp/doc/editors.txt
share/doc/clisp/doc/impnotes.html
share/doc/clisp/doc/readline.dvi
share/locale/de/LC_MESSAGES/clisp.mo
+share/locale/de/LC_MESSAGES/clisplow.mo
share/locale/en/LC_MESSAGES/clisp.mo
+share/locale/en/LC_MESSAGES/clisplow.mo
share/locale/es/LC_MESSAGES/clisp.mo
+share/locale/es/LC_MESSAGES/clisplow.mo
share/locale/fr/LC_MESSAGES/clisp.mo
+share/locale/fr/LC_MESSAGES/clisplow.mo
share/locale/nl/LC_MESSAGES/clisp.mo
+share/locale/nl/LC_MESSAGES/clisplow.mo
@dirrm share/doc/clisp/doc
@dirrm share/doc/clisp
@dirrm lib/clisp/base