aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-04-08 00:10:27 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-04-08 23:33:31 +0000
commit69d24a727d44d398f7357cb844386f3ec4750a4f (patch)
tree0b0452bfbadbdda563ecf812b3fe126b31a29148 /lang
parent2ac2c33875a4fcb11d6d2fb445fb55888ec25051 (diff)
downloadports-69d24a727d44d398f7357cb844386f3ec4750a4f.tar.gz
ports-69d24a727d44d398f7357cb844386f3ec4750a4f.zip
devel/icu: update to 69.1
Changes: https://github.com/unicode-org/icu/releases/tag/release-69-1 Reported by: GitHub (watch releases)
Diffstat (limited to 'lang')
-rw-r--r--lang/gnustep-base/Makefile1
-rw-r--r--lang/hermes/Makefile1
-rw-r--r--lang/parrot/Makefile2
-rw-r--r--lang/spidermonkey60/Makefile2
-rw-r--r--lang/spidermonkey78/Makefile2
-rw-r--r--lang/v8/Makefile1
-rw-r--r--lang/v8/files/patch-src_objects_js-list-format.cc83
7 files changed, 89 insertions, 3 deletions
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index accd1579a572..cce41c595c40 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gnustep-base
DISTVERSIONPREFIX= base-
DISTVERSION= 1_27_0
+PORTREVISION= 1
CATEGORIES= lang devel gnustep
MAINTAINER= ports@FreeBSD.org
diff --git a/lang/hermes/Makefile b/lang/hermes/Makefile
index 7c3ba2ded1be..a7bd16162a2f 100644
--- a/lang/hermes/Makefile
+++ b/lang/hermes/Makefile
@@ -1,6 +1,7 @@
PORTNAME= hermes
DISTVERSIONPREFIX= v
DISTVERSION= 0.7.2.20210322
+PORTREVISION= 1
CATEGORIES= lang
PKGNAMESUFFIX= -javascript-engine
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index f9a3efcead17..e7bc3ba90987 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -2,7 +2,7 @@
PORTNAME= parrot
PORTVERSION= 8.1.0
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= lang
MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/supported/${PORTVERSION}/ \
LOCAL/sunpoet
diff --git a/lang/spidermonkey60/Makefile b/lang/spidermonkey60/Makefile
index afcf46c819df..b560c6d73d3b 100644
--- a/lang/spidermonkey60/Makefile
+++ b/lang/spidermonkey60/Makefile
@@ -1,6 +1,6 @@
PORTNAME= spidermonkey
DISTVERSION= 60.9.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source
PKGNAMESUFFIX= ${SP_VER}
diff --git a/lang/spidermonkey78/Makefile b/lang/spidermonkey78/Makefile
index d19e31c9a22b..b052522e4fc3 100644
--- a/lang/spidermonkey78/Makefile
+++ b/lang/spidermonkey78/Makefile
@@ -1,6 +1,6 @@
PORTNAME= spidermonkey
DISTVERSION= 78.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source
PKGNAMESUFFIX= ${SP_VER}
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index 950fb3e2e93d..3ea8ebea7240 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -16,6 +16,7 @@
PORTNAME= v8
DISTVERSION= 8.7.220.23
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= LOCAL/mikael/v8/:build \
LOCAL/mikael/v8/:buildtools \
diff --git a/lang/v8/files/patch-src_objects_js-list-format.cc b/lang/v8/files/patch-src_objects_js-list-format.cc
new file mode 100644
index 000000000000..6b78534db47e
--- /dev/null
+++ b/lang/v8/files/patch-src_objects_js-list-format.cc
@@ -0,0 +1,83 @@
+https://github.com/v8/v8/commit/035c305ce7761f51328b45f1bd83e26aef267c9d
+
+../../src/objects/js-list-format.cc:145:55: error: 'createInstance' is a private member of 'icu::ListFormatter'
+ icu::ListFormatter* formatter = icu::ListFormatter::createInstance(
+ ~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~
+/usr/local/include/unicode/listformatter.h:267:27: note: declared private here
+ static ListFormatter* createInstance(const Locale& locale, const char* style, UErrorCode& errorCode);
+ ^
+
+--- src/objects/js-list-format.cc.orig 2020-11-11 06:36:03 UTC
++++ src/objects/js-list-format.cc
+@@ -29,46 +29,27 @@ namespace v8 {
+ namespace internal {
+
+ namespace {
+-const char* kStandard = "standard";
+-const char* kOr = "or";
+-const char* kUnit = "unit";
+-const char* kStandardShort = "standard-short";
+-const char* kOrShort = "or-short";
+-const char* kUnitShort = "unit-short";
+-const char* kStandardNarrow = "standard-narrow";
+-const char* kOrNarrow = "or-narrow";
+-const char* kUnitNarrow = "unit-narrow";
+
+-const char* GetIcuStyleString(JSListFormat::Style style,
+- JSListFormat::Type type) {
++UListFormatterWidth GetIcuWidth(JSListFormat::Style style) {
++ switch (style) {
++ case JSListFormat::Style::LONG:
++ return ULISTFMT_WIDTH_WIDE;
++ case JSListFormat::Style::SHORT:
++ return ULISTFMT_WIDTH_SHORT;
++ case JSListFormat::Style::NARROW:
++ return ULISTFMT_WIDTH_NARROW;
++ }
++ UNREACHABLE();
++}
++
++UListFormatterType GetIcuType(JSListFormat::Type type) {
+ switch (type) {
+ case JSListFormat::Type::CONJUNCTION:
+- switch (style) {
+- case JSListFormat::Style::LONG:
+- return kStandard;
+- case JSListFormat::Style::SHORT:
+- return kStandardShort;
+- case JSListFormat::Style::NARROW:
+- return kStandardNarrow;
+- }
++ return ULISTFMT_TYPE_AND;
+ case JSListFormat::Type::DISJUNCTION:
+- switch (style) {
+- case JSListFormat::Style::LONG:
+- return kOr;
+- case JSListFormat::Style::SHORT:
+- return kOrShort;
+- case JSListFormat::Style::NARROW:
+- return kOrNarrow;
+- }
++ return ULISTFMT_TYPE_OR;
+ case JSListFormat::Type::UNIT:
+- switch (style) {
+- case JSListFormat::Style::LONG:
+- return kUnit;
+- case JSListFormat::Style::SHORT:
+- return kUnitShort;
+- case JSListFormat::Style::NARROW:
+- return kUnitNarrow;
+- }
++ return ULISTFMT_TYPE_UNITS;
+ }
+ UNREACHABLE();
+ }
+@@ -143,7 +124,7 @@ MaybeHandle<JSListFormat> JSListFormat::New(Isolate* i
+ icu::Locale icu_locale = r.icu_locale;
+ UErrorCode status = U_ZERO_ERROR;
+ icu::ListFormatter* formatter = icu::ListFormatter::createInstance(
+- icu_locale, GetIcuStyleString(style_enum, type_enum), status);
++ icu_locale, GetIcuType(type_enum), GetIcuWidth(style_enum), status);
+ if (U_FAILURE(status) || formatter == nullptr) {
+ delete formatter;
+ THROW_NEW_ERROR(isolate, NewRangeError(MessageTemplate::kIcuError),