aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-02-01 12:42:53 +0000
committerRene Ladan <rene@FreeBSD.org>2021-02-01 12:42:53 +0000
commita7d2ae454e62240f7349c94e02e45b5982e74204 (patch)
tree4682e9c4fd9a88e5031274827a9b5c373e363f38 /lang
parent2d9527944f116748b1e9605788b85df76a6c6d01 (diff)
downloadports-a7d2ae454e62240f7349c94e02e45b5982e74204.tar.gz
ports-a7d2ae454e62240f7349c94e02e45b5982e74204.zip
Remove support for FreeBSD 12.1 from various ports.
FreeBSD 12.1 reached end-of-life today. Adjust the message for the wine ports while here, since stable/13 has branched. Submitted by: rene Reviewed by: jbeich, mandree, mat, osa Approved by: portmgr (mat) Differential Revision: https://reviews.freebsd.org/D28406
Notes
Notes: svn path=/head/; revision=563570
Diffstat (limited to 'lang')
-rw-r--r--lang/luajit/Makefile13
-rw-r--r--lang/v8/Makefile11
2 files changed, 0 insertions, 24 deletions
diff --git a/lang/luajit/Makefile b/lang/luajit/Makefile
index ce572e6ae722..329e24b05004 100644
--- a/lang/luajit/Makefile
+++ b/lang/luajit/Makefile
@@ -32,19 +32,6 @@ PLIST_SUB+= VERSION=${DISTVERSION}
.if ${ARCH:Mpowerpc*} || ${ARCH:Mmips*} || ${ARCH:Msparc*}
USE_GCC=yes
-.elif ${ARCH} == amd64
-# FreeBSD 12.1 shipped LLVM 8.0.1, which links libluajit with a TLS phdr that
-# requests a 16-byte alignment but an offset that's 8 mod 16. This results in
-# hilarity when an error is raised, as luajit raises an exception (stored in a
-# static TLS variable) via libunwind. libunwind assumes proper alignment of
-# the exception and uses a movaps instruction, which throws a SIGBUS when it
-# encounters this misaligned TLS data. While the linker problem doesn't seem
-# to be specific to amd64, the effect on luajit does seem to be.
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1201000 && ${OSVERSION} < 1202000
-LLVM_MINIMUM= 10
-BUILD_DEPENDS+= llvm${LLVM_MINIMUM}>=10.0:devel/llvm${LLVM_MINIMUM}
-CC= clang10
-.endif
.endif
post-install:
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index d19911156c26..11c5b0afec36 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -47,13 +47,6 @@ BUILD_DEPENDS= binutils>0:devel/binutils \
libunwind>0:devel/libunwind
LIB_DEPENDS= libicudata.so:devel/icu
-.include <bsd.port.options.mk>
-
-# clang10+ is required, this conditionnal can be dropped when 12.1 is EOL
-.if ${OSVERSION} >= 1200000 && ${OSVERSION} < 1201515
-BUILD_DEPENDS+= llvm10>0:devel/llvm10
-.endif
-
USES= pkgconfig ninja python:3.5+,build tar:xz
USE_GITHUB= yes
USE_LDCONFIG= yes
@@ -143,10 +136,6 @@ post-patch:
${REINPLACE_CMD} "s|%%LOCALBASE%%|${LOCALBASE}|" \
${WRKSRC}/build/toolchain/gcc_toolchain.gni \
${WRKSRC}/buildtools/third_party/libc++/BUILD.gn
-# clang10+ is required, this conditionnal can be dropped when 12.1 is EOL
-.if ${OSVERSION} >= 1200000 && ${OSVERSION} < 1201515
- @${PATCH} -d ${PATCH_WRKSRC} ${PATCH_ARGS} < ${FILESDIR}/extrapatch-clang10
-.endif
# google sucks, this file is needed but absent in the build* archive
# https://github.com/klzgrad/naiveproxy/blob/master/src/build/config/gclient_args.gni