aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-10-16 14:43:04 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-10-16 14:49:33 +0000
commitc79dab622beae6b77b2d48e7a76a13aadf0d7e50 (patch)
tree98ea8dbd03c8406ddc04664e12cbe812ffd3919f /lang
parent05be1fb60422f5a9ee1d1a2ae382f6f0ac180f17 (diff)
downloadports-c79dab622beae6b77b2d48e7a76a13aadf0d7e50.tar.gz
ports-c79dab622beae6b77b2d48e7a76a13aadf0d7e50.zip
lang/gcc12-devel: Update to the 20211010 snapshot of GCC 12.0.0
libsanitizer brought in improved support for FreeBSD, alas in conflict with one of GCC's headers file (md5.h); add a temporary hack via files/patch-libsanitzer-buildfix .
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc12-devel/Makefile2
-rw-r--r--lang/gcc12-devel/distinfo6
-rw-r--r--lang/gcc12-devel/files/patch-libsanitzer-buildfix20
3 files changed, 24 insertions, 4 deletions
diff --git a/lang/gcc12-devel/Makefile b/lang/gcc12-devel/Makefile
index 4340c3d4fd6c..d6652efe4023 100644
--- a/lang/gcc12-devel/Makefile
+++ b/lang/gcc12-devel/Makefile
@@ -1,7 +1,7 @@
# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
PORTNAME= gcc
-PORTVERSION= 12.0.0.s20211003
+PORTVERSION= 12.0.0.s20211010
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
diff --git a/lang/gcc12-devel/distinfo b/lang/gcc12-devel/distinfo
index cff5f568d406..91fe8636db99 100644
--- a/lang/gcc12-devel/distinfo
+++ b/lang/gcc12-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1633589712
-SHA256 (gcc-12-20211003.tar.xz) = b9744f87e18a8c66119cffa8bdda1e91f7241f5387981939ae415b0bf7d743ed
-SIZE (gcc-12-20211003.tar.xz) = 77099384
+TIMESTAMP = 1634382602
+SHA256 (gcc-12-20211010.tar.xz) = 8020b83d443834a924f056d6758c3f6ab3327edd87e5d6bc1e2fe17ba931d9aa
+SIZE (gcc-12-20211010.tar.xz) = 77142520
diff --git a/lang/gcc12-devel/files/patch-libsanitzer-buildfix b/lang/gcc12-devel/files/patch-libsanitzer-buildfix
new file mode 100644
index 000000000000..9446200b6c73
--- /dev/null
+++ b/lang/gcc12-devel/files/patch-libsanitzer-buildfix
@@ -0,0 +1,20 @@
+This is a temporary hack to restore bootstrap.
+
+The latest libsanitizer update added specific support for FreeBSD
+which includes <md5.h>. Alas GCC features it's own <md5.h> which
+is picked up, but does not provide everything necessary - boom.
+
+Upstream bug: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=102675
+
+--- UTC
+--- libsanitizer/sanitizer_common/sanitizer_platform_limits_freebsd.cpp
++++ libsanitizer/sanitizer_common/sanitizer_platform_limits_freebsd.cpp
+@@ -69,7 +69,7 @@
+ #include <semaphore.h>
+ #include <signal.h>
+ #include <stddef.h>
+-#include <md5.h>
++#include "/usr/include/md5.h"
+ #include <sha224.h>
+ #include <sha256.h>
+ #include <sha384.h>