aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-10-01 16:31:56 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-10-08 15:48:05 +0000
commitf9cd27d1f4c23c7fbb1d9d5b995691873e0a2e48 (patch)
treed51244e4f4497a0977ff26ff60ae49b3942d0a53 /lang
parent31c3987ca885317be8ef65800ed411fd2e260e83 (diff)
downloadports-f9cd27d1f4c23c7fbb1d9d5b995691873e0a2e48.tar.gz
ports-f9cd27d1f4c23c7fbb1d9d5b995691873e0a2e48.zip
lang/intel-compute-runtime: update to 21.40.21182
Diffstat (limited to 'lang')
-rw-r--r--lang/intel-compute-runtime/Makefile2
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-no-perf10
3 files changed, 9 insertions, 9 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index 80a51ead864d..ebe0140beec8 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,5 +1,5 @@
PORTNAME= compute-runtime
-DISTVERSION= 21.39.21127
+DISTVERSION= 21.40.21182
CATEGORIES= lang
PKGNAMEPREFIX= intel-
PKGNAMESUFFIX= -${FLAVOR}
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index 261e7986800d..80350cfc5f25 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1632493414
-SHA256 (intel-compute-runtime-21.39.21127_GH0.tar.gz) = 914623adc6a37cae3c84393dcf7ee6f6b5e23425c823398f446e9c15e7fd28fe
-SIZE (intel-compute-runtime-21.39.21127_GH0.tar.gz) = 4666632
+TIMESTAMP = 1633105916
+SHA256 (intel-compute-runtime-21.40.21182_GH0.tar.gz) = a983ba8d48273425a208d5d1916d73faf439be2268137b212b45ad0250886de7
+SIZE (intel-compute-runtime-21.40.21182_GH0.tar.gz) = 4678271
SHA256 (aa5a39a2db79.patch) = fc2290d950fed2bcde8fd6ce13cefb64d90ca348ae364a46a480c1d2509f67f9
SIZE (aa5a39a2db79.patch) = 1691
diff --git a/lang/intel-compute-runtime/files/patch-no-perf b/lang/intel-compute-runtime/files/patch-no-perf
index 94690df93378..b41ffa6c4826 100644
--- a/lang/intel-compute-runtime/files/patch-no-perf
+++ b/lang/intel-compute-runtime/files/patch-no-perf
@@ -32,20 +32,20 @@ level_zero/tools/source/sysman/linux/pmu/pmu_imp.h:12:10: fatal error: 'linux/pe
}
LinuxEngineImp::LinuxEngineImp(OsSysman *pOsSysman, zes_engine_group_t type, uint32_t engineInstance) : engineGroup(type), engineInstance(engineInstance) {
---- level_zero/tools/source/sysman/linux/os_sysman_imp.cpp.orig 2021-02-08 19:32:47 UTC
+--- level_zero/tools/source/sysman/linux/os_sysman_imp.cpp.orig 2021-10-01 16:31:56 UTC
+++ level_zero/tools/source/sysman/linux/os_sysman_imp.cpp
-@@ -42,8 +42,10 @@ ze_result_t LinuxSysmanImp::init() {
+@@ -45,8 +45,10 @@ ze_result_t LinuxSysmanImp::init() {
auto rootPciPathOfGpuDevice = getPciRootPortDirectoryPath(realRootPath);
PlatformMonitoringTech::create(pParentSysmanDeviceImp->deviceHandles, pFsAccess, rootPciPathOfGpuDevice, mapOfSubDeviceIdToPmtObject);
+#ifdef __linux__
pPmuInterface = PmuInterface::create(this);
- UNRECOVERABLE_IF(nullptr == pPmuInterface);
+ DEBUG_BREAK_IF(nullptr == pPmuInterface);
+#endif
return ZE_RESULT_SUCCESS;
}
---- level_zero/tools/source/sysman/linux/os_sysman_imp.h.orig 2021-02-08 19:32:47 UTC
+--- level_zero/tools/source/sysman/linux/os_sysman_imp.h.orig 2021-10-01 16:31:56 UTC
+++ level_zero/tools/source/sysman/linux/os_sysman_imp.h
@@ -14,7 +14,9 @@
#include "level_zero/tools/source/sysman/linux/firmware_util/firmware_util.h"
@@ -54,9 +54,9 @@ level_zero/tools/source/sysman/linux/pmu/pmu_imp.h:12:10: fatal error: 'linux/pe
+#ifdef __linux__
#include "level_zero/tools/source/sysman/linux/pmu/pmu_imp.h"
+#endif
- #include "level_zero/tools/source/sysman/linux/xml_parser/xml_parser.h"
#include "level_zero/tools/source/sysman/sysman_imp.h"
+ #include <map>
--- level_zero/tools/source/sysman/linux/pmu/CMakeLists.txt.orig 2020-09-11 07:53:58 UTC
+++ level_zero/tools/source/sysman/linux/pmu/CMakeLists.txt
@@ -9,7 +9,7 @@ set(L0_SRCS_TOOLS_SYSMAN_LINUX_PMU