aboutsummaryrefslogtreecommitdiff
path: root/mail/dspam-devel
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-10-10 11:28:49 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-10-10 11:28:49 +0000
commitc5b78cda39353b275030cb0e5193aa921bb9d22a (patch)
tree19bd4c5927da8f4a8b377a37e54bf661b3b571fd /mail/dspam-devel
parentddfe9750f7ee5798f6c4328ecf71bdf76488b118 (diff)
downloadports-c5b78cda39353b275030cb0e5193aa921bb9d22a.tar.gz
ports-c5b78cda39353b275030cb0e5193aa921bb9d22a.zip
Update to 3.6.8 20061010.1118 cvs snap:
Mark BROKEN on HEAD because it fails to configure with PGSQL, a fix it's on the way, but I want to update the port for 6.2 release and the freeze it's comming. Port changes: - fix longtime standing bug regarding CLAMAV: if "WITHOUT_CLAMAV_LOCAL=true" clamav support wasn't compiled in - added Cyrus's 2.3 deliver as LDA OPTION Change features: - removed oracle driver (unmaintained, didn't work on FreeBSD anyway) New features: - ability to add tagline to messages based on their classification; see tagSpam and tagNonspam preferences in README Bug fixes: - fixed bugs from last release causing pgsql to fail on connection + other fixes - bugfix for segfault on mysql fail and null strlen calls for username
Notes
Notes: svn path=/head/; revision=175193
Diffstat (limited to 'mail/dspam-devel')
-rw-r--r--mail/dspam-devel/Makefile62
-rw-r--r--mail/dspam-devel/distinfo6
-rw-r--r--mail/dspam-devel/files/UPDATING24
-rw-r--r--mail/dspam-devel/files/patch-src_dspam.conf.in4
-rw-r--r--mail/dspam-devel/pkg-plist2
5 files changed, 59 insertions, 39 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index d5eba15aa346..38818bf8bcc8 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -19,9 +19,9 @@ MASTER_SITES= # set later
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Bayesian spam filter - development version
-PORTVER_MAJ= 3.6.7
-SNAP_DATE= .20060604.1555
-_UPD_LINE_NO= 36
+PORTVER_MAJ= 3.6.8
+SNAP_DATE= .20061010.1118
+_UPD_LINE_NO= 23
MIN_OPTIONS_VER= ${PORTNAME}-3.6.6
@@ -62,7 +62,6 @@ OPTIONS+= MYSQL_COMPRESS "Compress dspam <--> MySQL" off
OPTIONS+= MYSQL_LOCAL "RUN_DEPEND on selected MySQL server ver." off
OPTIONS+= POSTGRESQL "Use PostgreSQL as back-end" on
OPTIONS+= POSTGRESQL_LOCAL "RUN_DEPEND on PostgreSQL server" off
-OPTIONS+= ORACLE "Use Oracle as back-end (BROKEN)" off
OPTIONS+= SQLITE2 "Use SQLite v2.x as back-end" off
OPTIONS+= SQLITE3 "Use SQLite v3.x as back-end" on
OPTIONS+= HASH "Use hash driver" on
@@ -80,6 +79,7 @@ OPTIONS+= DOMAIN_SCALE "File structure for multiple domains" off
## MTA and LDA
OPTIONS+= CYRUS21_LDA "Use Cyrus's 2.1 deliver as LDA" off
OPTIONS+= CYRUS22_LDA "Use Cyrus's 2.2 deliver as LDA" off
+OPTIONS+= CYRUS23_LDA "Use Cyrus's 2.3 deliver as LDA" off
OPTIONS+= EXIM_LDA "Use Exim as local delivery agent" off
OPTIONS+= MAILDROP_LDA "Use Maildrop as local delivery agent" off
OPTIONS+= PROCMAIL_LDA "Use Procmail as local delivery agent" off
@@ -132,6 +132,10 @@ DSPAM_HOME_MODE?= 0770
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 699999
+BROKEN= for now dspam doesn't build on HEAD with PGSQL DB driver; it should be OK with any other driver
+.endif
+
CONFIGURE_ARGS+= --with-logdir=${LOG_DIR}
PLIST_SUB+= LOG_DIR=${LOG_DIR}
@@ -185,24 +189,27 @@ SUB_LIST+= DSPAM_HOME=${DSPAM_HOME}
_SED_SCRIPT+= -e '/%%DAEMON%%/D'
.endif
-.ifndef(WITHOUT_CLAMAV) && !defined(WITHOUT_CLAMAV_LOCAL)
+.ifndef(WITHOUT_CLAMAV)
CONFIGURE_ARGS+= --enable-clamav
+. ifndef(WITHOUT_CLAMAV_LOCAL)
RUN_DEPENDS+= clamav>=0:${PORTSDIR}/security/clamav
SUB_LIST+= CLAMD=clamd
+. else
+SUB_LIST+= CLAMD=
+. endif
.endif
-.ifdef(WITH_CLAMAV_DEVEL) && !defined(WITHOUT_CLAMAV_LOCAL)
+.ifdef(WITH_CLAMAV_DEVEL)
CONFIGURE_ARGS+= --enable-clamav
+. ifndef(WITHOUT_CLAMAV_LOCAL)
RUN_DEPENDS+= clamav-devel>=0:${PORTSDIR}/security/clamav-devel
SUB_LIST+= CLAMD=clamd
-.endif
-.ifdef(WITHOUT_CLAMAV_LOCAL)
+. else
SUB_LIST+= CLAMD=
+. endif
.endif
# we need to know if we are building statically or dynamicaly for the plist
_DBDRV_COUNT= # blank, but defined so we can check against it
-#_DBDRV_ALL= pgsql_drv,ora_drv,libdb4_drv,sqlite3_drv,sqlite_drv,hash_drv,mysql_drv
-# above won't work because ORACLE support is broken so
_DBDRV= pgsql_drv,sqlite3_drv,sqlite_drv,hash_drv,mysql_drv,
.ifndef(WITHOUT_POSTGRESQL)
@@ -223,16 +230,6 @@ PLIST_SUB+= PGSQL="@comment "
_DBDRV:= ${_DBDRV:S/pgsql_drv,//}
.endif
-.if defined(WITH_ORACLE)
-#BUILD_DEPENDS= ${LOCALBASE}/oracle7/rdbms/lib/libnlsrtl3.a:\
-# ${PORTSDIR}/databases/oracle7-client
-#CONFIGURE_ARGS+= --with-oracle-home= ${LOCALBASE}/oracle7
-#PKGNAMESUFFIX= -oracle
-#_DBDRV_COUNT:= ${_DBDRV_COUNT}o
-#.else
-#_DBDRV:= ${_DBDRV:S/ora_drv,//}
-.endif
-
.ifndef(WITHOUT_SQLITE3)
USE_SQLITE= 3
_DBDRV_COUNT:= ${_DBDRV_COUNT}o
@@ -339,7 +336,7 @@ CONFIGURE_ARGS+= --enable-domain-scale
.endif
# add one 'o' here for each new LDA
-LDA_TOTAL_COUNT= ooooooo # 7
+LDA_TOTAL_COUNT= oooooooo # 8
LDA_COUNT= ${LDA_TOTAL_COUNT}
.if defined(WITH_CYRUS21_LDA)
@@ -354,6 +351,12 @@ CONFIGURE_ARGS+= --with-delivery-agent='${LOCALBASE}/cyrus/bin/deliver'
LDA_COUNT:= ${LDA_COUNT:S/o//}
.endif
+.if defined(WITH_CYRUS23_LDA)
+RUN_DEPENDS+= ${LOCALBASE}/cyrus/bin/deliver:${PORTSDIR}/mail/cyrus-imapd23
+CONFIGURE_ARGS+= --with-delivery-agent='${LOCALBASE}/cyrus/bin/deliver'
+LDA_COUNT:= ${LDA_COUNT:S/o//}
+.endif
+
.ifdef(WITH_EXIM_LDA)
. ifdef(WITH_MYSQL40) || (WITH_MYSQL41)
_EXIM_EXT= -mysql
@@ -441,9 +444,9 @@ MLINKS+= libdspam.3 dspam_destroy.3
MLINKS+= libdspam.3 dspam_detach.3
_DOCS= CHANGELOG LICENSE README README.FreeBSD RELEASE.NOTES UPGRADING
-_DOCSL= courier.txt exim.txt markov.txt mysql_drv.txt ora_drv.txt \
- pgsql_drv.txt pop3filter.txt postfix.txt qmail.txt relay.txt \
- sendmail.txt sqlite_drv.txt
+_DOCSL= courier.txt exim.txt markov.txt mysql_drv.txt pgsql_drv.txt\
+ pop3filter.txt postfix.txt qmail.txt relay.txt sendmail.txt \
+ sqlite_drv.txt
pre-everything::
.ifndef(MAINT)
@@ -487,8 +490,6 @@ post-patch:
${WRKSRC}/src/tools.mysql_drv/purge-4.1.sql
@${REINPLACE_CMD} -e 's|WHERE CURRENT_DATE - created_on > 14;|WHERE CURRENT_DATE - created_on > ${SIGNATURE_LIFE};|' \
${WRKSRC}/src/tools.pgsql_drv/purge.sql
- @${REINPLACE_CMD} -e 's|where SYSDATE-created_on > 14|where SYSDATE-created_on > ${SIGNATURE_LIFE};|' \
- ${WRKSRC}/src/tools.ora_drv/purge.sql
@${REINPLACE_CMD} -e "s|where date('now')-date(created_on) > 14;|where date('now')-date(created_on) > ${SIGNATURE_LIFE};|" \
${WRKSRC}/src/tools.sqlite_drv/purge-2.sql
@${REINPLACE_CMD} -e "s|where julianday('now')-julianday(created_on) > 14;|where julianday('now')-julianday(created_on) > ${SIGNATURE_LIFE};|" \
@@ -508,8 +509,8 @@ pre-configure:
@${FALSE}
.endif
.if defined(WITH_VIRT_USERS) && !(defined(USE_MYSQL) || \
- !defined(WITHOUT_POSTGRESQL) || defined(WITH_ORACLE) || !defined(WITHOUT_HASH) )
- @${ECHO_CMD} "You need MySQL, POSTGRESQL, HASH or ORACLE for virtual users."
+ !defined(WITHOUT_POSTGRESQL) || !defined(WITHOUT_HASH) )
+ @${ECHO_CMD} "You need MySQL, POSTGRESQL or HASH for virtual users."
@${FALSE}
.endif
.if defined(WITH_PREF_EXT) && !( defined(USE_MYSQL) || \
@@ -583,11 +584,6 @@ post-install:
cd ${WRKSRC}/src/tools.sqlite_drv && \
${INSTALL_DATA} *.sql ${EXAMPLESDIR}/sqlite
.endif
-.ifdef(WITH_ORACLE)
- @${MKDIR} ${EXAMPLESDIR}/oracle
- cd ${WRKSRC}/src/tools.ora_drv && \
- ${INSTALL_DATA} *.sql ${EXAMPLESDIR}/oracle
-.endif
.ifdef(WITH_CGI)
. for I in admin.cgi admingraph.cgi configure.pl dspam.cgi graph.cgi
diff --git a/mail/dspam-devel/distinfo b/mail/dspam-devel/distinfo
index 88a19c719eed..7928ff546742 100644
--- a/mail/dspam-devel/distinfo
+++ b/mail/dspam-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (dspam-devel-3.6.7.20060604.1555.tar.gz) = 9ecaa92f994ccdf5d6955751908b468f
-SHA256 (dspam-devel-3.6.7.20060604.1555.tar.gz) = 4249ebae581e5fb8b4d0e3f5da88fb58855700688eb9e039d8723f35d7cd0a76
-SIZE (dspam-devel-3.6.7.20060604.1555.tar.gz) = 383595
+MD5 (dspam-devel-3.6.8.20061010.1118.tar.gz) = 47e23036dcc9986558a7421adf404481
+SHA256 (dspam-devel-3.6.8.20061010.1118.tar.gz) = 0752b3ee4fac75a59b583c906adf09cec7e6619ab5b1ed165c8b310cacb4ce6c
+SIZE (dspam-devel-3.6.8.20061010.1118.tar.gz) = 372816
diff --git a/mail/dspam-devel/files/UPDATING b/mail/dspam-devel/files/UPDATING
index 5c615b3a2060..9e748d2d1040 100644
--- a/mail/dspam-devel/files/UPDATING
+++ b/mail/dspam-devel/files/UPDATING
@@ -11,6 +11,30 @@ in the port directory:
make extract; more `find . -type f -maxdepth 2 -name UPGRADING`
###########################################################################
+# dspam-devel-3.6.8.20061010.1118
+#
+
+Port changes:
+- fix longtime standing bug regarding CLAMAV: if "WITHOUT_CLAMAV_LOCAL=true"
+clamav support wasn't compiled in
+- added Cyrus's 2.3 deliver as LDA OPTION (on 2006-10-08) [1]
+
+Change features:
+- removed oracle driver (unmaintained, didn't work on FreeBSD anyway)
+
+New features:
+- ability to add tagline to messages based on their classification; see
+tagSpam and tagNonspam preferences in README
+
+Bug fixes:
+- fixed bugs from last release causing pgsql to fail on connection + other
+fixes
+- bugfix for segfault on mysql fail and null strlen calls for username
+
+[1] ports/103910 for mail/dspam by Steffen Rick <srick@srick.org>
+
+
+###########################################################################
# dspam-devel-3.6.7.20060604.1555
#
diff --git a/mail/dspam-devel/files/patch-src_dspam.conf.in b/mail/dspam-devel/files/patch-src_dspam.conf.in
index a369da8bf8f4..81ace77090a8 100644
--- a/mail/dspam-devel/files/patch-src_dspam.conf.in
+++ b/mail/dspam-devel/files/patch-src_dspam.conf.in
@@ -37,7 +37,7 @@
#
#ServerPort 24
#ServerQueueSize 32
-+# keep this is sync with /usr/local/etc/rc.d/dspam.rc script
++# keep this is sync with /usr/local/etc/rc.d/dspam[.sh] rc.d script
#ServerPID /var/run/dspam.pid
#
@@ -46,7 +46,7 @@
# much of the bandwidth overhead.
#
-#ServerDomainSocketPath "/tmp/dspam.sock"
-+# keep this is sync with /usr/local/etc/rd.d/dspam.rc script
++# keep this is sync with /usr/local/etc/rd.d/dspam[.sh] rc.d script
+#ServerDomainSocketPath "/var/run/dspam.sock"
#
diff --git a/mail/dspam-devel/pkg-plist b/mail/dspam-devel/pkg-plist
index 8620fa070b30..338ca31a3e58 100644
--- a/mail/dspam-devel/pkg-plist
+++ b/mail/dspam-devel/pkg-plist
@@ -23,6 +23,7 @@ include/dspam/decode.h
include/dspam/diction.h
include/dspam/error.h
include/dspam/heap.h
+include/dspam/ldap_client.h
include/dspam/libdspam.h
include/dspam/libdspam_objects.h
include/dspam/nodetree.h
@@ -58,7 +59,6 @@ libdata/pkgconfig/dspam.pc
%%PORTDOCS%%%%DOCSDIR%%/exim.txt
%%PORTDOCS%%%%DOCSDIR%%/markov.txt
%%PORTDOCS%%%%DOCSDIR%%/mysql_drv.txt
-%%PORTDOCS%%%%DOCSDIR%%/ora_drv.txt
%%PORTDOCS%%%%DOCSDIR%%/pgsql_drv.txt
%%PORTDOCS%%%%DOCSDIR%%/pop3filter.txt
%%PORTDOCS%%%%DOCSDIR%%/postfix.txt