aboutsummaryrefslogtreecommitdiff
path: root/mail/mdpop3d/Makefile
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2012-01-03 05:00:28 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2012-01-03 05:00:28 +0000
commitd96f9bb6697d78f592de1fa129dee8cb1749f42d (patch)
tree370fa2358fb360424d818ae85c2132406ebb84cb /mail/mdpop3d/Makefile
parent7d4b33face99388024b8b25af2e5f734c1ea8c3f (diff)
downloadports-d96f9bb6697d78f592de1fa129dee8cb1749f42d.tar.gz
ports-d96f9bb6697d78f592de1fa129dee8cb1749f42d.zip
- Fix build with clang
- Use PLIST_FILES - Remove extra tabs and spaces
Notes
Notes: svn path=/head/; revision=288452
Diffstat (limited to 'mail/mdpop3d/Makefile')
-rw-r--r--mail/mdpop3d/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/mail/mdpop3d/Makefile b/mail/mdpop3d/Makefile
index 809d5335b063..34f1c90e96f6 100644
--- a/mail/mdpop3d/Makefile
+++ b/mail/mdpop3d/Makefile
@@ -12,29 +12,29 @@ MASTER_SITES= ftp://ftp.corpit.ru/home/mjt/mdpop3d/
MAINTAINER= avl@FreeBSD.org
COMMENT= A simple and small POP3 daemon implementation with Maildir support
+PLIST_FILES= libexec/mdpop3d
MAN8= mdpop3d.8
MANCOMPRESSED= no
-OPTIONS= PAM "Build with PAM support" off \
- APOP "Build with APOP command support (requires PAM)" off
+OPTIONS= PAM "Build with PAM support" off \
+ APOP "Build with APOP command support (requires PAM)" off
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|LIBS = -lpam -ldl|LIBS = -lpam|' \
- ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|LIBS = -lpam -ldl|LIBS = -lpam|;/^CC[[:blank:]]*=/d' \
+ ${WRKSRC}/Makefile
.if defined(WITHOUT_PAM)
@${REINPLACE_CMD} -e 's|LIBS = -lpam|LIBS = -lcrypt|' \
- ${WRKSRC}/Makefile
+ ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|DEFS = -DUSE_PAM|#DEFS = -DUSE_PAM|' \
- ${WRKSRC}/Makefile
+ ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|OPTS = -DUSE_APOP|#OPTS = -DUSE_APOP|' \
- ${WRKSRC}/Makefile
+ ${WRKSRC}/Makefile
.endif
-
.if defined(WITHOUT_APOP)
@${REINPLACE_CMD} -e 's|OPTS = -DUSE_APOP|#OPTS = -DUSE_APOP|' \
- ${WRKSRC}/Makefile
+ ${WRKSRC}/Makefile
.endif
do-install: