aboutsummaryrefslogtreecommitdiff
path: root/mail/notmuch/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-06-19 19:29:32 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-06-19 19:29:32 +0000
commitca49c77afc3165ec484bd9d2a690c48fec81321a (patch)
treea6d63797a4394b774c014b8d899cb83789afe14d /mail/notmuch/Makefile
parentbdbdca878eb1b636cdc3780fb4d5b389bf67c2d9 (diff)
downloadports-ca49c77afc3165ec484bd9d2a690c48fec81321a.tar.gz
ports-ca49c77afc3165ec484bd9d2a690c48fec81321a.zip
mail/notmuch,mail/notmuch-emacs,mail/py-notmuch: update 0.26.2 -> 0.27
- add LICENSE to pet portlint - remove BROKEN_powerpc64 since the cause has been fixed in ports r471400 - adjust to upstream's new info page handling - fix parallel installation of flavored mail/py-notmuch PR: 229075 Submitted by: Sebastian Schwarz <seschwar@gmail.com> (maintainer) Relnotes: https://notmuchmail.org/pipermail/notmuch/2018/026684.html
Notes
Notes: svn path=/head/; revision=472817
Diffstat (limited to 'mail/notmuch/Makefile')
-rw-r--r--mail/notmuch/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index bb6ab2387d14..89a36cfed11f 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= notmuch
-PORTVERSION= 0.26.2
+PORTVERSION= 0.27
CATEGORIES?= mail
MASTER_SITES= https://notmuchmail.org/releases/
@@ -12,8 +12,6 @@ COMMENT?= Thread-based email index, search and tagging application
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/${WRKSRC_SUBDIR:C/[^\/]+/../g}/COPYING-GPL-3
-BROKEN_powerpc64= Does not build due to databases/xapian-core
-
.ifndef MASTERDIR
LIB_DEPENDS= libgmime-2.6.so:mail/gmime26 \
libxapian.so:databases/xapian-core \
@@ -34,7 +32,8 @@ USE_GNOME= glib20
USE_LDCONFIG= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
+CONFIGURE_ARGS= --infodir=${PREFIX}/${INFO_PATH} \
+ --mandir=${MANPREFIX}/man \
--prefix=${PREFIX} \
--with-bash-completion \
--with-retry-lock \
@@ -48,6 +47,7 @@ TEST_ENV+= NOTMUCH_SKIP_TESTS="basic.12 count.14 insert.2[89] insert.3[0-9] mess
TEST_TARGET= test
.endif
+PATCH_WRKSRC= ${WRKSRC}/${WRKSRC_SUBDIR:C/[^\/]+/../g}
PKGDIR= ${.CURDIR}
.ifndef MASTERDIR
@@ -62,11 +62,15 @@ MANPAGES_CONFIGURE_WITH= docs
# install completions even in absence of shells/bash-completions
post-configure:
- @${REINPLACE_CMD} -e '/^WITH_BASH[[:blank:]]*=/s/=.*/= 1/' ${WRKSRC}/Makefile.config
+ ${REINPLACE_CMD} \
+ -e '/^HAVE_INSTALL_INFO[[:blank:]]*=/s/=.*/=0/' \
+ -e '/^HAVE_MAKEINFO[[:blank:]]*=/s/=.*/=0/' \
+ -e '/^WITH_BASH[[:blank:]]*=/s/=.*/= 1/' \
+ ${WRKSRC}/Makefile.config
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notmuch
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnotmuch.so.5.1.0
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notmuch
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnotmuch.so.?*.?*.?*
# keep poudriere testport happy
post-install-MANPAGES-on: