aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Net-IMAP-Simple-SSL/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-12-30 21:57:35 +0000
committerLars Thegler <lth@FreeBSD.org>2004-12-30 21:57:35 +0000
commite97a376766ff96f2e8ec661393e0f11eebce3f66 (patch)
treef9181ab67bf819d670a5288a197fcbf00c2e4119 /mail/p5-Net-IMAP-Simple-SSL/Makefile
parente045a7d071662170b1e07f75847b7b81af96e443 (diff)
downloadports-e97a376766ff96f2e8ec661393e0f11eebce3f66.tar.gz
ports-e97a376766ff96f2e8ec661393e0f11eebce3f66.zip
Add p5-Net-IMAP-Simple-SSL 1.3, SSL support for Net::IMAP::Simple.
Notes
Notes: svn path=/head/; revision=125565
Diffstat (limited to 'mail/p5-Net-IMAP-Simple-SSL/Makefile')
-rw-r--r--mail/p5-Net-IMAP-Simple-SSL/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/mail/p5-Net-IMAP-Simple-SSL/Makefile b/mail/p5-Net-IMAP-Simple-SSL/Makefile
new file mode 100644
index 000000000000..767c054d85f7
--- /dev/null
+++ b/mail/p5-Net-IMAP-Simple-SSL/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mail/p5-Net-IMAP-Simple-SSL
+# Date created: 30 December 2004
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-IMAP-Simple-SSL
+PORTVERSION= 1.3
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= SSL support for Net::IMAP::Simple
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ ${SITE_PERL}/Net/IMAP/Simple.pm:${PORTSDIR}/mail/p5-Net-IMAP-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::IMAP::Simple::SSL.3
+
+.include <bsd.port.mk>