aboutsummaryrefslogtreecommitdiff
path: root/mail/rainloop/Makefile
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2016-10-02 18:14:02 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2016-10-02 18:14:02 +0000
commit3099720db79f31b78ee0a6242084c06b541103c3 (patch)
treea83e593ab2c1be400932b405f6c1b3bba4f6feff /mail/rainloop/Makefile
parent34580bf8bb503c16744ccae93a87b6bf6fee967f (diff)
downloadports-3099720db79f31b78ee0a6242084c06b541103c3.tar.gz
ports-3099720db79f31b78ee0a6242084c06b541103c3.zip
Update mail/rainloop and mail/rainloop-community each to version 1.10.4.183
PR: 212915 Submitted by: yasu@utahime.org Reported by: yasu@utahime.org Reviewed by: swills (mentor) loic.blot@unix-experience.fr (maintainer) Approved by: swills (mentor) loic.blot@unix-experience.fr (maintainer) Differential Revision: https://reviews.freebsd.org/D8106
Notes
Notes: svn path=/head/; revision=423144
Diffstat (limited to 'mail/rainloop/Makefile')
-rw-r--r--mail/rainloop/Makefile27
1 files changed, 6 insertions, 21 deletions
diff --git a/mail/rainloop/Makefile b/mail/rainloop/Makefile
index 10412a47c669..8f7582fef690 100644
--- a/mail/rainloop/Makefile
+++ b/mail/rainloop/Makefile
@@ -1,13 +1,12 @@
# $FreeBSD$
PORTNAME= rainloop
-PORTVERSION= 1.10.3
-CATEGORIES?= mail www
-MASTER_SITES= http://repository.rainloop.net/v2/webmail/${PORTVERSION}/
-DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}.${RBUILD}-${RHASH}
+PORTVERSION= 1.10.4.183
+CATEGORIES= mail www
+MASTER_SITES= https://github.com/RainLoop/rainloop-webmail/releases/download/v${PORTVERSION}/
MAINTAINER= loic.blot@unix-experience.fr
-COMMENT= Modern and interactive webmail
+COMMENT?= Modern and interactive webmail
.if !defined(PKGNAMESUFFIX)
LICENSE= RainLoop
@@ -17,19 +16,6 @@ LICENSE_PERMS= auto-accept
.endif
.if !defined(PKGNAMESUFFIX)
-# Refresh using info from http://repository.rainloop.net/v2/core.stable.json
-RHASH= c60080cb65e25169eeabc32e3a537848
-.endif
-
-.if defined(PKGNAMESUFFIX)
-# Refresh using info from http://repository.rainloop.net/v2/core.open.json
-RHASH= aa8d0c41baec166a35bb9855ee3d07b9
-.endif
-
-# Refresh using info from http://repository.rainloop.net/v2/core.(stable|open).json
-RBUILD= 151
-
-.if !defined(PKGNAMESUFFIX)
RESTRICTED= Redistribution in any form is prohibited
.endif
USES= php:web zip
@@ -37,8 +23,7 @@ NO_BUILD= yes
NO_ARCH= yes
NO_WRKSUBDIR= yes
USE_PHP= curl iconv json xml dom openssl pcre spl zlib
-RVER= ${PORTVERSION}.${RBUILD}
-PLIST_SUB= VER="${RVER}" WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
+PLIST_SUB= VER="${PORTVERSION}" WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
OPTIONS_RADIO= DB
OPTIONS_RADIO_DB= MYSQL PGSQL SQLITE
@@ -54,6 +39,6 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/index.php ${STAGEDIR}${WWWDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} rainloop ${STAGEDIR}${WWWDIR})
# Prune empty dirs
- @${FIND} ${STAGEDIR}${WWWDIR}/${PORTNAME}/v/${RVER} -type d -empty -delete
+ @${FIND} ${STAGEDIR}${WWWDIR}/${PORTNAME}/v/${PORTVERSION} -type d -empty -delete
.include <bsd.port.mk>