aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird/files
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-10-30 20:37:55 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-10-30 20:37:55 +0000
commit2cd503bcdb5f9bb9fadb663412a68fb84e801524 (patch)
treea87ddf1d023ec31d88d818886f89a42f8183ebd2 /mail/thunderbird/files
parent8603282df1f4ec28fd2ffa11843c31f4a4dcea3a (diff)
downloadports-2cd503bcdb5f9bb9fadb663412a68fb84e801524.tar.gz
ports-2cd503bcdb5f9bb9fadb663412a68fb84e801524.zip
- update firefox to 25.0
- update firefox-esr to 24.1.0 - update thunderbird to 24.1.0 - update seamonkey to 22.0 - update libxul to 24.1.0 - don't remove/add share/applications directory - remove checks for older gecko releases from bsd.gecko.mk - drop support for FreeBSD 9.0 Not staged yet. I started working on it, but didn't finish it in time for this release. I'll try to make the next one in 6 weeks. In collaboration with: Jan Beich
Notes
Notes: svn path=/head/; revision=332168
Diffstat (limited to 'mail/thunderbird/files')
-rw-r--r--mail/thunderbird/files/patch-bug85199250
-rw-r--r--mail/thunderbird/files/patch-bug91817736
2 files changed, 44 insertions, 42 deletions
diff --git a/mail/thunderbird/files/patch-bug851992 b/mail/thunderbird/files/patch-bug851992
index 59e39f81d68d..693ae6e57b90 100644
--- a/mail/thunderbird/files/patch-bug851992
+++ b/mail/thunderbird/files/patch-bug851992
@@ -79,14 +79,9 @@ diff --git a/configure.in b/configure.in
Location of Java binaries (java, javac, jar)],
JAVA_BIN_PATH=$withval)
diff --git a/js/src/Makefile.in b/js/src/Makefile.in
---- mozilla/js/src/Makefile.in
-+++ mozilla/js/src/Makefile.in
-@@ -232,48 +232,54 @@ endif
-
- #############################################
- # BEGIN ECMAScript Internationalization API
- #
-
+--- mozilla/js/src/Makefile.in.orig 2013-10-22 08:19:02.000000000 +0200
++++ mozilla/js/src/Makefile.in 2013-10-29 10:11:58.272605098 +0100
+@@ -237,10 +237,14 @@
# ICU headers need to be available whether we build with the complete
# Internationalization API or not - ICU stubs rely on them.
@@ -101,47 +96,23 @@ diff --git a/js/src/Makefile.in b/js/src/Makefile.in
ifdef ENABLE_INTL_API
- ifeq ($(OS_ARCH),WINNT)
- # Parallel gmake is buggy on Windows
- ICU_GMAKE_OPTIONS="-j1"
- # Library names: On Windows, ICU uses modified library names for static
- # and debug libraries.
- ifdef MOZ_DEBUG
- ICU_LIB_SUFFIX=d
- endif
- ICU_LIB_RENAME = $(foreach libname,$(ICU_LIB_NAMES),\
- cp -p intl/icu/lib/s$(libname)$(ICU_LIB_SUFFIX).lib intl/icu/lib/$(libname).lib;)
+@@ -260,6 +264,7 @@
+ ICU_MAKE = $(MAKE)
endif
+ifndef MOZ_NATIVE_ICU
# - Build ICU as part of the "export" target, so things get built
# in the right order.
# - ICU requires GNU make according to its readme.html. pymake can't be used
- # because it doesn't support order only dependencies.
- # - Force ICU to use the standard suffix for object files because expandlibs
- # will discard all files with a non-standard suffix (bug 857450).
- # - Options for genrb: -k strict parsing; -R omit collation tailoring rules.
- export::
- $(GMAKE) $(ICU_GMAKE_OPTIONS) -C intl/icu STATIC_O=$(OBJ_SUFFIX) GENRBOPTS='-k -R'
- $(ICU_LIB_RENAME)
-
- distclean clean::
+@@ -276,6 +281,7 @@
$(call SUBMAKE,$@,intl/icu)
-+endif
endif
++endif
#
# END ECMAScript Internationalization API
- #############################################
-
-
-@@ -398,17 +404,21 @@ CFLAGS += $(MOZ_ZLIB_CFLAGS)
- EXTRA_LIBS += $(MOZ_ZLIB_LIBS)
- # Enable zlib usage if zlib has been located. When building the browser on
- # Windows, MOZ_ZLIB_LIBS is empty because zlib is part of libmozglue. We thus
- # also enable zlib if mozglue is present.
- ifneq (,$(MOZ_ZLIB_LIBS)$(MOZ_GLUE_LDFLAGS))
+@@ -413,7 +419,11 @@
DEFINES += -DUSE_ZLIB
endif
@@ -154,11 +125,6 @@ diff --git a/js/src/Makefile.in b/js/src/Makefile.in
# Prevent floating point errors caused by VC++ optimizations
ifdef _MSC_VER
- # XXX We should add this to CXXFLAGS, too?
- CFLAGS += -fp:precise
-
- ifeq ($(CPU_ARCH),x86)
- # Workaround compiler bug on PGO (Bug 721284)
diff --git a/js/src/config/Makefile.in b/js/src/config/Makefile.in
--- mozilla/js/src/config/Makefile.in
+++ mozilla/js/src/config/Makefile.in
diff --git a/mail/thunderbird/files/patch-bug918177 b/mail/thunderbird/files/patch-bug918177
new file mode 100644
index 000000000000..96ce225c25a8
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug918177
@@ -0,0 +1,36 @@
+diff --git config/stl-headers config/stl-headers
+index c057d8e..dc7f6f0 100644
+--- mozilla/config/stl-headers
++++ mozilla/config/stl-headers
+@@ -21,6 +21,7 @@ algorithm
+ atomic
+ deque
+ ios
++iosfwd
+ iostream
+ iterator
+ limits
+diff --git config/system-headers config/system-headers
+index d31c94e..570c82a 100644
+--- mozilla/config/system-headers
++++ mozilla/config/system-headers
+@@ -469,6 +469,7 @@ IOKit/IOMessage.h
+ IOKit/pwr_mgt/IOPMLib.h
+ iomanip
+ ios
++iosfwd
+ iostream
+ iostream.h
+ iterator
+diff --git js/src/config/system-headers js/src/config/system-headers
+index d31c94e..570c82a 100644
+--- mozilla/js/src/config/system-headers
++++ mozilla/js/src/config/system-headers
+@@ -469,6 +469,7 @@ IOKit/IOMessage.h
+ IOKit/pwr_mgt/IOPMLib.h
+ iomanip
+ ios
++iosfwd
+ iostream
+ iostream.h
+ iterator