aboutsummaryrefslogtreecommitdiff
path: root/mail/tpop3d
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-04-03 05:42:25 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-04-03 05:42:25 +0000
commitaadc59d2cea3828385a0fa2e72bd811cd94696d2 (patch)
tree4ecc290d7e0d8841d365b2cf578ef3fc41490bf4 /mail/tpop3d
parent92118d1d773ba4dc3a7e15efc1a916485ebed6c4 (diff)
downloadports-aadc59d2cea3828385a0fa2e72bd811cd94696d2.tar.gz
ports-aadc59d2cea3828385a0fa2e72bd811cd94696d2.zip
- Remove unnecessary IS_INTERACTIVE from Makefile
- Added patch to prevent crashing whith nonexistent maildir PR: ports/79495 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=132313
Diffstat (limited to 'mail/tpop3d')
-rw-r--r--mail/tpop3d/Makefile3
-rw-r--r--mail/tpop3d/files/patch-maildir.c11
2 files changed, 12 insertions, 2 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index d50a7e41b879..3b536a71b86a 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -7,14 +7,13 @@
PORTNAME= tpop3d
PORTVERSION= 1.5.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://www.ex-parrot.com/~chris/tpop3d/
MAINTAINER= boris@tagnet.ru
COMMENT= Virtual-domain capable POP3 server supporting MySQL,PgSQL etc auth
-IS_INTERACTIVE= yes
USE_OPENSSL= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
diff --git a/mail/tpop3d/files/patch-maildir.c b/mail/tpop3d/files/patch-maildir.c
new file mode 100644
index 000000000000..ef52a6d143e2
--- /dev/null
+++ b/mail/tpop3d/files/patch-maildir.c
@@ -0,0 +1,11 @@
+--- maildir.c.orig Tue Nov 25 01:23:20 2003
++++ maildir.c Sun Apr 3 09:44:25 2005
+@@ -205,7 +205,7 @@
+ mailbox M, failM = NULL;
+ struct timeval tv1, tv2;
+ float f;
+- int locked;
++ int locked = 0;
+
+ alloc_struct(_mailbox, M);
+