aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-08-31 15:17:07 +0000
committerCy Schubert <cy@FreeBSD.org>2021-08-31 19:25:52 +0000
commit4cf22b504ccf9e40971e8a7bcc00c91b6e61ccaf (patch)
treedcde5ae3b3c0f47da73f9538a5613ffa3a7e522c /mail
parentf96f435c43a50dd949fdd7892b7966bbfb154eb1 (diff)
downloadports-4cf22b504ccf9e40971e8a7bcc00c91b6e61ccaf.tar.gz
ports-4cf22b504ccf9e40971e8a7bcc00c91b6e61ccaf.zip
mail/exmh2: Adjust MouseWheel scrolling parameters
Units and pages don't mean the same thing they did before. The number of pixels is in fact a divisor. - MouseWheel scrolls one line in the Folder Display box (no change). - MouseWheel scrolls five lines in the message box (no change). - Shift-MouseWheel scrolls one line (no change). - Control-MouseWheel scrolls ten lines (changed from a page as page doesn't work any more).
Diffstat (limited to 'mail')
-rw-r--r--mail/exmh2/Makefile2
-rw-r--r--mail/exmh2/files/patch-lib_exwin.tcl8
2 files changed, 5 insertions, 5 deletions
diff --git a/mail/exmh2/Makefile b/mail/exmh2/Makefile
index a8533f5ef6c4..adf14881c048 100644
--- a/mail/exmh2/Makefile
+++ b/mail/exmh2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= exmh
PORTVERSION= 2.9.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= mail tk
# XXX: Standard SF fails with a hung download
MASTER_SITES= https://sourceforge.net/projects/${PORTNAME}/files/${PORTNAME}/${PORTVERSION}/
diff --git a/mail/exmh2/files/patch-lib_exwin.tcl b/mail/exmh2/files/patch-lib_exwin.tcl
index cb6639714706..0e9c3165f158 100644
--- a/mail/exmh2/files/patch-lib_exwin.tcl
+++ b/mail/exmh2/files/patch-lib_exwin.tcl
@@ -18,11 +18,11 @@
+ # bind $bindtag <Control-Button-5> [list %W yview scroll 1 pages]
+ # bind $bindtag <Control-Button-4> [list %W yview scroll -1 pages]
+
-+ # tcl 8.7a5 and later (units can be pixels/units/pages). See
++ # tcl 8.7a5 and later. See
+ # https://core.tcl-lang.org/tips/doc/trunk/tip/474.md for more info:
-+ bind $bindtag <MouseWheel> [ list tk::MouseWheel %W y %D -$num units ]
-+ bind $bindtag <Shift-MouseWheel> { tk::MouseWheel %W y %D -1 units }
-+ bind $bindtag <Shift-MouseWheel> { tk::MouseWheel %W y %D -1 pages }
++ bind $bindtag <MouseWheel> [ list tk::MouseWheel %W y %D [ expr 10/-$num ] pixels ]
++ bind $bindtag <Shift-MouseWheel> { tk::MouseWheel %W y %D -10 pixels }
++ bind $bindtag <Control-MouseWheel> { tk::MouseWheel %W y %D -1 pixels }
}