aboutsummaryrefslogtreecommitdiff
path: root/math/dune-pdelab
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-05-25 09:58:19 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-05-25 10:00:10 +0000
commit8470aea030512cde1984737633959548a0e961af (patch)
tree35778b3519065cfff28b655296b94394d9fcb076 /math/dune-pdelab
parenta674df10cf4c11415d9503ad173f72afb1afe010 (diff)
downloadports-8470aea030512cde1984737633959548a0e961af.tar.gz
ports-8470aea030512cde1984737633959548a0e961af.zip
math/suitesparse: adapt dependency lines after modularization
Do not bump PORTREVISION, because this should not change the resulting packages. Note for maintainers: try to not depend on the whole suitesparse package, especially if your port do not require GraphBLAS (the biggest one).
Diffstat (limited to 'math/dune-pdelab')
-rw-r--r--math/dune-pdelab/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/math/dune-pdelab/Makefile b/math/dune-pdelab/Makefile
index 5d8a54938fb9..6b2d2c53752e 100644
--- a/math/dune-pdelab/Makefile
+++ b/math/dune-pdelab/Makefile
@@ -18,6 +18,7 @@ DUNE_DEPENDS= dune-common>0:math/dune-common \
dune-localfunctions>0:math/dune-localfunctions \
dune-typetree>0:math/dune-typetree
BUILD_DEPENDS= ${DUNE_DEPENDS} \
+ suitesparse>0:math/suitesparse \
${LOCALBASE}/mpi/openmpi/lib/libmpi.so:net/openmpi
LIB_DEPENDS= libarpack.so:math/arpack-ng \
libdunealugrid.so:math/dune-alugrid \
@@ -25,10 +26,10 @@ LIB_DEPENDS= libarpack.so:math/arpack-ng \
libgmp.so:math/gmp \
libmetis.so:math/metis \
libopenblas.so:math/openblas \
- libsuitesparseconfig.so:math/suitesparse \
libsuperlu.so:math/superlu \
libtbb.so:devel/onetbb
RUN_DEPENDS= ${DUNE_DEPENDS} \
+ suitesparse>0:math/suitesparse \
${LOCALBASE}/mpi/openmpi/lib/libmpi.so:net/openmpi
USES= cmake compiler:c++17-lang fortran pkgconfig