aboutsummaryrefslogtreecommitdiff
path: root/math/emc2
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-02 22:02:23 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-02 22:02:23 +0000
commit39aa0b14173af39253ebfb442771bec584842df4 (patch)
treeed1870d15f26f61f30e114702771a2cc8ccd5a1e /math/emc2
parentdfd17843b655371d5ffaac5acc8862b01063122a (diff)
downloadports-39aa0b14173af39253ebfb442771bec584842df4.tar.gz
ports-39aa0b14173af39253ebfb442771bec584842df4.zip
Add emc2 2.15,
Emc2 is a portable, interactive and graphic software Edition of two dimensional geometry and mesh. We can create and modify the geometry (CAD), define the discretization on the lines, define the subdomains, and define some reference numbers to take into account the boundary conditions and material properties. The elements of the mesh are triangles and quadrilaterals. We have two kind of meshes: grid mesh and Delaunay Voronoo (automatic mesh). We make the edition of the mesh by moving, removing, adding vertices, by regularization, or by transformations (symmetry, rotation,..), etc. Suggested add-on: the port math/bamg. WWW: http://www-rocq1.inria.fr/gamma/cdrom/www/emc2/eng.htm PR: 60835 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=97124
Diffstat (limited to 'math/emc2')
-rw-r--r--math/emc2/Makefile47
-rw-r--r--math/emc2/distinfo3
-rw-r--r--math/emc2/files/patch-Makefile15
-rw-r--r--math/emc2/files/patch-libI77::fio.h15
-rw-r--r--math/emc2/pkg-descr13
-rw-r--r--math/emc2/pkg-plist21
6 files changed, 114 insertions, 0 deletions
diff --git a/math/emc2/Makefile b/math/emc2/Makefile
new file mode 100644
index 000000000000..451b3a05a28d
--- /dev/null
+++ b/math/emc2/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: emc2
+# Date created: 16 December 2003
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= emc2
+PORTVERSION= 2.15
+CATEGORIES= math science
+MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/Gamma/emc2/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}c
+.if !defined(NOPORTDOCS)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}.doc.en.ps.gz ${PORTNAME}.doc.fr.ps.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+.endif
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A graphic editor of two dimensional geometry and mesh
+
+RESTRICTED= No resale, contact author for commercial usage
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_XLIB= yes
+USE_GMAKE= yes
+ALL_TARGET= ${PORTNAME}
+
+.if defined(LANG) && ${LANG:Mfr*} != ""
+CFLAGS+= -DFRENCH
+.endif
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/emc2
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${DOCSDIR}
+.for doc in ${PORTNAME}.doc.en.ps.gz ${PORTNAME}.doc.fr.ps.gz
+ @${INSTALL_DATA} ${DISTDIR}/${doc} ${DOCSDIR}
+.endfor
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/emc2/distinfo b/math/emc2/distinfo
new file mode 100644
index 000000000000..023f1210d25f
--- /dev/null
+++ b/math/emc2/distinfo
@@ -0,0 +1,3 @@
+MD5 (emc2-v2.15c.tar.gz) = 28452afd8e734e9fb27783fcc4df6fac
+MD5 (emc2.doc.en.ps.gz) = 5056bcca5d12d2410c121778404ab40c
+MD5 (emc2.doc.fr.ps.gz) = 9c65a98f9926eb85e51c651aa9ee4488
diff --git a/math/emc2/files/patch-Makefile b/math/emc2/files/patch-Makefile
new file mode 100644
index 000000000000..fd7cd9adc9e8
--- /dev/null
+++ b/math/emc2/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig Mon Feb 10 09:17:51 2003
++++ Makefile Tue Dec 16 23:22:42 2003
+@@ -8,9 +8,9 @@
+ # for IBM RS6000
+ #CC=xlc
+ #CFLAGS=-O
+-BIN=/usr/local/bin
+-X11INCLUDEDIR=/usr/include/X11R6
+-X11LIBDIR=/usr/lib/X11R6
++BIN=$(PREFIX)/bin
++X11INCLUDEDIR=$(X11BASE)/include
++X11LIBDIR=$(X11BASE)/lib
+ X11LIB= -L$(X11LIBDIR) -lX11
+ MATHLIB= -lm
+
diff --git a/math/emc2/files/patch-libI77::fio.h b/math/emc2/files/patch-libI77::fio.h
new file mode 100644
index 000000000000..1ebd63157a40
--- /dev/null
+++ b/math/emc2/files/patch-libI77::fio.h
@@ -0,0 +1,15 @@
+--- libI77/fio.h.orig Tue Nov 9 15:58:43 1999
++++ libI77/fio.h Tue Dec 16 23:53:43 2003
+@@ -17,6 +17,12 @@
+ #endif
+ #endif
+
++#ifdef __FreeBSD__
++#ifndef NON_UNIX_STDIO
++#define NON_UNIX_STDIO
++#endif
++#endif
++
+ #ifdef UIOLEN_int
+ typedef int uiolen;
+ #else
diff --git a/math/emc2/pkg-descr b/math/emc2/pkg-descr
new file mode 100644
index 000000000000..526a467bff70
--- /dev/null
+++ b/math/emc2/pkg-descr
@@ -0,0 +1,13 @@
+Emc2 is a portable, interactive and graphic software Edition of two
+dimensional geometry and mesh. We can create and modify the geometry
+(CAD), define the discretization on the lines, define the subdomains,
+and define some reference numbers to take into account the boundary
+conditions and material properties. The elements of the mesh are triangles
+and quadrilaterals. We have two kind of meshes: grid mesh and Delaunay
+Voronoo (automatic mesh). We make the edition of the mesh by moving,
+removing, adding vertices, by regularization, or by transformations
+(symmetry, rotation,..), etc.
+
+Suggested add-on: the port math/bamg.
+
+WWW: http://www-rocq1.inria.fr/gamma/cdrom/www/emc2/eng.htm
diff --git a/math/emc2/pkg-plist b/math/emc2/pkg-plist
new file mode 100644
index 000000000000..aa9a9abfd510
--- /dev/null
+++ b/math/emc2/pkg-plist
@@ -0,0 +1,21 @@
+bin/emc2
+bin/prf_f3d
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/emc2.doc.en.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/emc2.doc.fr.ps.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/c.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/cooler.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/culot1.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/demi_carre.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/fissure.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/gruyere.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/houman.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/levier.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/mos.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/naca.f
+%%PORTDOCS%%%%EXAMPLESDIR%%/naca.pts
+%%PORTDOCS%%%%EXAMPLESDIR%%/naca012.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/q.emc2_bd
+%%PORTDOCS%%%%EXAMPLESDIR%%/rotor.emc2_bd
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%