aboutsummaryrefslogtreecommitdiff
path: root/math/gmm++/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-06 10:48:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-06 10:48:23 +0000
commit84c1313bccdfe4e47a193fa57714554a246ad54e (patch)
tree6e33cd5d926bf69cc0bfb5e5a41522b007426e31 /math/gmm++/Makefile
parent7f45b414183634039462c6005d9d508a9878edf5 (diff)
downloadports-84c1313bccdfe4e47a193fa57714554a246ad54e.tar.gz
ports-84c1313bccdfe4e47a193fa57714554a246ad54e.zip
Gmm++ is a generic C++ template library for sparse, dense and skyline
matrices. It is built as a set of generic algorithms (mult, add, copy, sub-matrices, dense and sparse solvers ...) for any interfaced vector type or matrix type. It can be view as a glue library allowing cooperation between several vector and matrix types. However, basic sparse, dense and skyline matrix/vector types are built in Gmm++, hence it can be used as a standalone linear algebra library. Interfacing a vector or matrix type means writing "traits" objects called "linalg_traits", which describe their properties. The library offers predefined dense, sparse and skyline matrix types. WWW: http://home.gna.org/getfem/
Notes
Notes: svn path=/head/; revision=218131
Diffstat (limited to 'math/gmm++/Makefile')
-rw-r--r--math/gmm++/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/math/gmm++/Makefile b/math/gmm++/Makefile
new file mode 100644
index 000000000000..8a3b0454f021
--- /dev/null
+++ b/math/gmm++/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: gmm++
+# Date created: 2008-07-23
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmm++
+PORTVERSION= 3.0.4
+CATEGORIES= math
+MASTER_SITES= http://download.gna.org/getfem/stable/
+DISTNAME= ${PORTNAME:S/+//g}-${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= A generic matrix template library
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>