aboutsummaryrefslogtreecommitdiff
path: root/math/py-rpy2/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-04 17:58:05 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-04 17:58:05 +0000
commitb7206b465ee136541bcbcb5f09d8d1222866a0dd (patch)
treeb23ac0c8b3eb29c0b13a13bba5c622f5aa21f01d /math/py-rpy2/Makefile
parent27a3b968d55eb41d5ecc0f1a5bce05679ea86f08 (diff)
downloadports-b7206b465ee136541bcbcb5f09d8d1222866a0dd.tar.gz
ports-b7206b465ee136541bcbcb5f09d8d1222866a0dd.zip
Update to 3.0.1
Notes
Notes: svn path=/head/; revision=494620
Diffstat (limited to 'math/py-rpy2/Makefile')
-rw-r--r--math/py-rpy2/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/math/py-rpy2/Makefile b/math/py-rpy2/Makefile
index fd62a797b371..25e36b2728f5 100644
--- a/math/py-rpy2/Makefile
+++ b/math/py-rpy2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rpy2
-DISTVERSION= 2.9.5
-PORTREVISION= 1
+DISTVERSION= 3.0.1
CATEGORIES= math
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,19 +13,22 @@ COMMENT= Python interface to the R Programming Language
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/gpl-2.0.txt
-BUILD_DEPENDS= ${PYNUMPY}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR}
LIB_DEPENDS= libR.so:math/R \
libicui18n.so:devel/icu \
libomp.so:devel/openmp \
libpcre.so:devel/pcre
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}simplegeneric>=0:devel/py-simplegeneric@${PY_FLAVOR}
USES= fortran python:3.5+ readline
USE_PYTHON= autoplist distutils
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/rpy2/rinterface/*.so
+NO_ARCH= yes
+
+pre-build:
+ cd ${WRKSRC}/ && ${PYTHON_CMD} rpy/_rinterface_cffi_build.py
.include <bsd.port.mk>