aboutsummaryrefslogtreecommitdiff
path: root/math/py-rpy2
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-14 12:06:13 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-14 12:06:13 +0000
commit7b29a99341c7f15a466cd97dff55e7e00b80a95d (patch)
treeaa0ebe7ba87df9df36f1b1dcb6d214db619b331a /math/py-rpy2
parent54f96e55842a1c450202a7fddc5b126b48e5481e (diff)
downloadports-7b29a99341c7f15a466cd97dff55e7e00b80a95d.tar.gz
ports-7b29a99341c7f15a466cd97dff55e7e00b80a95d.zip
math/py-rpy2: fix build on GCC architectures
Use C11 compiler: rpy2/rinterface_lib/R_API_eventloop.h:24: error: redefinition of typedef 'InputHandler' rpy2/rinterface_lib/R_API_eventloop.h:6: error: previous declaration of 'InputHandler' was here Approved by: mentors (implicit approval)
Notes
Notes: svn path=/head/; revision=514457
Diffstat (limited to 'math/py-rpy2')
-rw-r--r--math/py-rpy2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/py-rpy2/Makefile b/math/py-rpy2/Makefile
index bdc76882ae52..ca7625f9c932 100644
--- a/math/py-rpy2/Makefile
+++ b/math/py-rpy2/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.10.0:devel/py-cffi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}simplegeneric>=0:devel/py-simplegeneric@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tzlocal>=0:devel/py-tzlocal@${PY_FLAVOR}
-USES= fortran python:3.5+ readline
+USES= compiler:c11 fortran python:3.5+ readline
USE_PYTHON= autoplist distutils
MAKE_ENV= RPY2_CFFI_MODE=BOTH