aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse-klu
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-05-24 16:42:48 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-05-25 10:00:07 +0000
commit14cd75c20d1a7e6b1b35d3af7e87e7105e8d7ec1 (patch)
treebe63ae4d97f1e824bc5cc43df34b0118160d4729 /math/suitesparse-klu
parent21ddf7a6bedcb93b9a6a36de9e362b24b549e47e (diff)
downloadports-14cd75c20d1a7e6b1b35d3af7e87e7105e8d7ec1.tar.gz
ports-14cd75c20d1a7e6b1b35d3af7e87e7105e8d7ec1.zip
suitesparse-klu: new port for the module KLU of SuiteSparse
Diffstat (limited to 'math/suitesparse-klu')
-rw-r--r--math/suitesparse-klu/Makefile25
-rw-r--r--math/suitesparse-klu/files/patch-KLU_Demo_Makefile18
-rw-r--r--math/suitesparse-klu/pkg-descr10
-rw-r--r--math/suitesparse-klu/pkg-plist6
4 files changed, 59 insertions, 0 deletions
diff --git a/math/suitesparse-klu/Makefile b/math/suitesparse-klu/Makefile
new file mode 100644
index 000000000000..f1096b2dcc5e
--- /dev/null
+++ b/math/suitesparse-klu/Makefile
@@ -0,0 +1,25 @@
+# Created by: Thierry Thomas (<thierry@pompo.net>)
+
+PORTNAME= KLU
+PORTVERSION= 1.3.9
+CATEGORIES= math
+
+COMMENT= Sparse LU factorization, for circuit simulation
+
+LICENSE= LGPL21+
+
+LIB_DEPENDS= libmetis.so:math/metis \
+ libamd.so:math/suitesparse-amd \
+ libbtf.so:math/suitesparse-btf \
+ libcamd.so:math/suitesparse-camd \
+ libcolamd.so:math/suitesparse-colamd \
+ libccolamd.so:math/suitesparse-ccolamd \
+ libcholmod.so:math/suitesparse-cholmod
+
+USES= localbase:ldflags
+OMP_NEEDED= yes
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+USE_LDCONFIG= yes
+
+.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
+.include <bsd.port.post.mk>
diff --git a/math/suitesparse-klu/files/patch-KLU_Demo_Makefile b/math/suitesparse-klu/files/patch-KLU_Demo_Makefile
new file mode 100644
index 000000000000..a8e5fa35797b
--- /dev/null
+++ b/math/suitesparse-klu/files/patch-KLU_Demo_Makefile
@@ -0,0 +1,18 @@
+--- KLU/Demo/Makefile.orig 2021-05-17 01:04:52 UTC
++++ KLU/Demo/Makefile
+@@ -32,15 +32,7 @@ all: library klu_simple kludemo kluldemo
+ - ./kluldemo < ../Matrix/ctina.mtx
+
+ library:
+- ( cd ../../SuiteSparse_config ; $(MAKE) )
+ ( cd ../Lib ; $(MAKE) )
+- ( cd ../../BTF ; $(MAKE) library )
+- ( cd ../../AMD ; $(MAKE) library )
+- ( cd ../../COLAMD ; $(MAKE) library )
+- ( cd ../../CHOLMOD ; $(MAKE) library )
+- - ( cd ../../CAMD ; $(MAKE) )
+- - ( cd ../../CCOLAMD ; $(MAKE) )
+- - ( cd ../.. ; $(MAKE) metis )
+
+ purge: distclean
+
diff --git a/math/suitesparse-klu/pkg-descr b/math/suitesparse-klu/pkg-descr
new file mode 100644
index 000000000000..cfd39e997b15
--- /dev/null
+++ b/math/suitesparse-klu/pkg-descr
@@ -0,0 +1,10 @@
+This port installs the module KLU of SuiteSparse.
+
+KLU is a set of routines for solving sparse linear systems of equations. It is
+particularly well-suited to matrices arising in SPICE-like circuit simulation
+applications. It relies on a permutation to block triangular form (BTF), several
+methods for finding a fill-reducing ordering (variants of approximate minimum
+degree, and nested dissection), and a sparse left-looking LU factorization
+method to factorize each block.
+
+WWW: http://faculty.cse.tamu.edu/davis/suitesparse.html
diff --git a/math/suitesparse-klu/pkg-plist b/math/suitesparse-klu/pkg-plist
new file mode 100644
index 000000000000..be3e628039a5
--- /dev/null
+++ b/math/suitesparse-klu/pkg-plist
@@ -0,0 +1,6 @@
+include/suitesparse/klu.h
+lib/libklu.so
+lib/libklu.so.1
+lib/libklu.so.1.3.8
+%%PORTDOCS%%%%DOCSDIR%%/KLU_README.txt
+%%PORTDOCS%%%%DOCSDIR%%/KLU_UserGuide.pdf