aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse-slip_lu/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-05-24 16:44:41 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-05-25 10:00:09 +0000
commitef9eb0a7f8ae139aeaa1b1f8ed663d97680402ba (patch)
treeb7f7f0d0ea3b24e461c63334d83c9bd7010524cd /math/suitesparse-slip_lu/Makefile
parent12739831125b435b75730489a3055a01d90c440f (diff)
downloadports-ef9eb0a7f8ae139aeaa1b1f8ed663d97680402ba.tar.gz
ports-ef9eb0a7f8ae139aeaa1b1f8ed663d97680402ba.zip
suitesparse-slip_lu: new port for the module SLIP_LU of SuiteSparse
Diffstat (limited to 'math/suitesparse-slip_lu/Makefile')
-rw-r--r--math/suitesparse-slip_lu/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/suitesparse-slip_lu/Makefile b/math/suitesparse-slip_lu/Makefile
new file mode 100644
index 000000000000..ca39f6955bd9
--- /dev/null
+++ b/math/suitesparse-slip_lu/Makefile
@@ -0,0 +1,25 @@
+# Created by: Thierry Thomas (<thierry@pompo.net>)
+
+PORTNAME= SLIP_LU
+PORTVERSION= 1.0.2
+CATEGORIES= math
+
+COMMENT= Sparse Left-looking Integer-Preserving LU Factorization
+
+LICENSE= GPLv2+ LGPL3+
+LICENSE_COMB= dual
+LICENSE_FILE= ${BUILD_WRKSRC}/License/license.txt
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr \
+ libamd.so:math/suitesparse-amd \
+ libcolamd.so:math/suitesparse-colamd
+
+USES= localbase:ldflags
+OMP_NEEDED= yes
+
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+USE_LDCONFIG= yes
+
+.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
+.include <bsd.port.post.mk>