aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-08-18 10:51:01 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-08-18 10:51:01 +0000
commit23ee2a7d628e74980199fb95b27ce242a5f718a6 (patch)
treece0de1d0b7bda5eb762e64fe58300177d350898c /math
parentb95ee05497bd32b93280aec9b333ab635f3d381e (diff)
downloadports-23ee2a7d628e74980199fb95b27ce242a5f718a6.tar.gz
ports-23ee2a7d628e74980199fb95b27ce242a5f718a6.zip
Uses/cmake.mk: Replace CMAKE_ENV with CONFIGURE_ENV.
Instead of defining a variable that is almost always based on CONFIGURE_ENV, just use CONFIGURE_ENV directly. This also matches the behavior of other ports that do not use autotools (so most ports can just worry about CONFIGURE_ENV). Additionally, the fact that we do not use ?= means we do not have problems if another file in Uses/ needs to set CONFIGURE_ENV (with CMAKE_ENV, the order of the arguments to USES would matter). Ports which set CMAKE_ENV have been adjusted accordingly. In most cases, CMAKE_ENV was just replaced with CONFIGURE_ENV, the exceptions being: * databases/sqliteman: CMAKE_ENV line removed; setting QMAKESPEC there has no effect on the build system. * devel/freeocl: CMAKE_ENV line removed; FREEOCL_CXX_COMPILER is already retrieved from the CMAKE_CXX_COMPILER variable in the build system. * graphics/openimageio: CMAKE_ENV line removed; setting Qt variables there has no effect on the build system. Reviewed by: makc Differential Revision: https://reviews.freebsd.org/D3403
Notes
Notes: svn path=/head/; revision=394572
Diffstat (limited to 'math')
-rw-r--r--math/eigen3/Makefile2
-rw-r--r--math/metis/Makefile2
-rw-r--r--math/scalapack/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/math/eigen3/Makefile b/math/eigen3/Makefile
index 3188a10571d9..47a8fb01c751 100644
--- a/math/eigen3/Makefile
+++ b/math/eigen3/Makefile
@@ -15,7 +15,7 @@ LICENSE= LGPL21 MPL
LICENSE_COMB= multi
USES= cmake:outsource tar:bzip2
-CMAKE_ENV+= PKG_CONFIG_LIBDIR="${PREFIX}/libdata"
+CONFIGURE_ENV+= PKG_CONFIG_LIBDIR="${PREFIX}/libdata"
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-1306d75b4a21
diff --git a/math/metis/Makefile b/math/metis/Makefile
index 8d7b397a4d84..04034d29d2de 100644
--- a/math/metis/Makefile
+++ b/math/metis/Makefile
@@ -91,7 +91,7 @@ do-configure:
.for o in SHARED STATIC #PROFILE
.if ${PORT_OPTIONS:M${o}}
@${PRINTF} "\n\nConfiguring ${o}:\n\n\n"
- @cd ${WRKSRC_${o}}; ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} \
+ @cd ${WRKSRC_${o}}; ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} \
${CMAKE_ARGS:C|${CFLAGS}|& ${${o}_FLAGS}|g} ${CMAKE_ARGS_${o}} \
-DGKLIB_PATH="${WRKSRC_${o}}/GKlib" ${CMAKE_SOURCE_PATH}
.endif
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index 8bb5c3966d69..312d89639ed0 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -112,7 +112,7 @@ post-build:
${RM} -rf ${WRKSRC}/CMakeFiles ${WRKSRC}/CMakeCache.txt
${CP} -p ${WRKSRC}/Makefile.dist ${WRKSRC}/Makefile
(cd ${WRKSRC} && \
- ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS:C|BUILD_STATIC_LIBS|BUILD_SHARED_LIBS|} ${CMAKE_SOURCE_PATH})
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS:C|BUILD_STATIC_LIBS|BUILD_SHARED_LIBS|} ${CMAKE_SOURCE_PATH})
(cd ${WRKSRC} && ${DO_MAKE_BUILD} ${ALL_TARGET})
post-install: