aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-06-06 19:52:39 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-06-06 20:18:37 +0000
commit38e42a5646cb2ad1d75484237bfb41424cc50f1c (patch)
treef458c47fafa7b231c83f8bd2ebc4bdb1464ae3fa /math
parent7f2f962b4a30b2e724a89fc8c2f3b26024a930db (diff)
downloadports-38e42a5646cb2ad1d75484237bfb41424cc50f1c.tar.gz
ports-38e42a5646cb2ad1d75484237bfb41424cc50f1c.zip
math/suitesparse*: force PORTNAME in lowercase
Force PORTNAME in lowercase, even if upstream uses uppercases. Requested by: sunpoet@ and danfe@
Diffstat (limited to 'math')
-rw-r--r--math/suitesparse-amd/Makefile4
-rw-r--r--math/suitesparse-btf/Makefile4
-rw-r--r--math/suitesparse-camd/Makefile4
-rw-r--r--math/suitesparse-ccolamd/Makefile4
-rw-r--r--math/suitesparse-cholmod/Makefile5
-rw-r--r--math/suitesparse-colamd/Makefile4
-rw-r--r--math/suitesparse-config/Makefile4
-rw-r--r--math/suitesparse-csparse/Makefile4
-rw-r--r--math/suitesparse-cxsparse/Makefile4
-rw-r--r--math/suitesparse-graphblas/Makefile5
-rw-r--r--math/suitesparse-klu/Makefile5
-rw-r--r--math/suitesparse-ldl/Makefile5
-rw-r--r--math/suitesparse-mongoose/Makefile4
-rw-r--r--math/suitesparse-rbio/Makefile4
-rw-r--r--math/suitesparse-slip_lu/Makefile4
-rw-r--r--math/suitesparse-spqr/Makefile8
-rw-r--r--math/suitesparse-umfpack/Makefile4
-rw-r--r--math/suitesparse/Makefile30
-rw-r--r--math/suitesparse/bsd.suitesparse.mk50
19 files changed, 83 insertions, 73 deletions
diff --git a/math/suitesparse-amd/Makefile b/math/suitesparse-amd/Makefile
index d48318342f9a..c4f38f62d1b4 100644
--- a/math/suitesparse-amd/Makefile
+++ b/math/suitesparse-amd/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= AMD
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 2.4.6
CATEGORIES= math
@@ -11,7 +11,7 @@ LICENSE= BSD3CLAUSE
USES= fortran localbase:ldflags
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= AMD
ALL_TARGET+= fortran
USE_LDCONFIG= yes
diff --git a/math/suitesparse-btf/Makefile b/math/suitesparse-btf/Makefile
index f6bcb1f8b5a9..32940f4706c4 100644
--- a/math/suitesparse-btf/Makefile
+++ b/math/suitesparse-btf/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= BTF
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 1.2.6
CATEGORIES= math
@@ -11,7 +11,7 @@ LICENSE= LGPL21+
USES= localbase:ldflags
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= BTF
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-camd/Makefile b/math/suitesparse-camd/Makefile
index 9e4658b42030..640c37d84c22 100644
--- a/math/suitesparse-camd/Makefile
+++ b/math/suitesparse-camd/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= CAMD
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 2.4.6
CATEGORIES= math
@@ -11,7 +11,7 @@ LICENSE= BSD3CLAUSE
USES= localbase:ldflags
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= CAMD
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-ccolamd/Makefile b/math/suitesparse-ccolamd/Makefile
index 252880b3bded..c731e3589701 100644
--- a/math/suitesparse-ccolamd/Makefile
+++ b/math/suitesparse-ccolamd/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= CCOLAMD
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 2.9.6
CATEGORIES= math
@@ -11,7 +11,7 @@ LICENSE= BSD3CLAUSE
USES= localbase:ldflags
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= CCOLAMD
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-cholmod/Makefile b/math/suitesparse-cholmod/Makefile
index 682d15ea7e2a..12688bb23b65 100644
--- a/math/suitesparse-cholmod/Makefile
+++ b/math/suitesparse-cholmod/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= CHOLMOD
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 3.0.14
CATEGORIES= math
@@ -17,7 +17,8 @@ LIB_DEPENDS= libmetis.so:math/metis \
USES= localbase:ldflags
BLAS_NEEDED= yes
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+
+MPORTNAME= CHOLMOD
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-colamd/Makefile b/math/suitesparse-colamd/Makefile
index 1417606fa072..fdd6765eeca3 100644
--- a/math/suitesparse-colamd/Makefile
+++ b/math/suitesparse-colamd/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= COLAMD
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 2.9.6
CATEGORIES= math
@@ -11,7 +11,7 @@ LICENSE= BSD3CLAUSE
USES= localbase:ldflags
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= COLAMD
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-config/Makefile b/math/suitesparse-config/Makefile
index ef426c7cf8ae..62af94ee1f31 100644
--- a/math/suitesparse-config/Makefile
+++ b/math/suitesparse-config/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= config
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= ${SSPVERSION}
CATEGORIES= math
@@ -10,7 +10,7 @@ LICENSE= GPLv2+
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/SuiteSparse_config
+MPORTNAME= config
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-csparse/Makefile b/math/suitesparse-csparse/Makefile
index a42b1365bf37..701eb4317adc 100644
--- a/math/suitesparse-csparse/Makefile
+++ b/math/suitesparse-csparse/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= CSparse
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 3.2.0
CATEGORIES= math
@@ -10,7 +10,7 @@ LICENSE= LGPL21+
USES= localbase:ldflags
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= CSparse
USE_LDCONFIG= yes
PLIST_FILES= # empty
diff --git a/math/suitesparse-cxsparse/Makefile b/math/suitesparse-cxsparse/Makefile
index 8b3c347a8ae3..a470c2b850d0 100644
--- a/math/suitesparse-cxsparse/Makefile
+++ b/math/suitesparse-cxsparse/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= CXSparse
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 3.2.0
CATEGORIES= math
@@ -11,7 +11,7 @@ LICENSE= LGPL21+
USES= localbase:ldflags
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= CXSparse
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-graphblas/Makefile b/math/suitesparse-graphblas/Makefile
index 092e10bda4ef..b5b418ac284e 100644
--- a/math/suitesparse-graphblas/Makefile
+++ b/math/suitesparse-graphblas/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= GraphBLAS
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 5.0.5
PORTREVISION= 1
CATEGORIES= math
@@ -11,7 +11,8 @@ LICENSE= APACHE20
USES= cmake:insource localbase:ldflags
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+
+MPORTNAME= GraphBLAS
USE_LDCONFIG= yes
PORTDOCS= CSC20_OpenMP_GraphBLAS.pdf GraphBLAS_API_C_v13.pdf \
diff --git a/math/suitesparse-klu/Makefile b/math/suitesparse-klu/Makefile
index f1096b2dcc5e..bf8aa4b2306f 100644
--- a/math/suitesparse-klu/Makefile
+++ b/math/suitesparse-klu/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= KLU
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 1.3.9
CATEGORIES= math
@@ -18,7 +18,8 @@ LIB_DEPENDS= libmetis.so:math/metis \
USES= localbase:ldflags
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+
+MPORTNAME= KLU
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-ldl/Makefile b/math/suitesparse-ldl/Makefile
index ca297ced70d6..570ab4b8c216 100644
--- a/math/suitesparse-ldl/Makefile
+++ b/math/suitesparse-ldl/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= LDL
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 2.2.6
CATEGORIES= math
@@ -12,7 +12,8 @@ LIB_DEPENDS= libamd.so:math/suitesparse-amd
USES= localbase:ldflags
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+
+MPORTNAME= LDL
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-mongoose/Makefile b/math/suitesparse-mongoose/Makefile
index d78518b7aa6a..a36c8b521fb9 100644
--- a/math/suitesparse-mongoose/Makefile
+++ b/math/suitesparse-mongoose/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= Mongoose
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 2.0.4
CATEGORIES= math
@@ -10,7 +10,7 @@ LICENSE= GPLv3
USES= cmake:insource localbase:ldflags
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= Mongoose
USE_LDCONFIG= yes
CONFLICTS_INSTALL= mongoose # bin/mongoose
diff --git a/math/suitesparse-rbio/Makefile b/math/suitesparse-rbio/Makefile
index 9d83c4ffcd96..7a43cd304632 100644
--- a/math/suitesparse-rbio/Makefile
+++ b/math/suitesparse-rbio/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= RBio
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 2.2.6
CATEGORIES= math
@@ -10,7 +10,7 @@ LICENSE= GPLv2+
USES= localbase:ldflags
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= RBio
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-slip_lu/Makefile b/math/suitesparse-slip_lu/Makefile
index ca39f6955bd9..6aec6b174780 100644
--- a/math/suitesparse-slip_lu/Makefile
+++ b/math/suitesparse-slip_lu/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= SLIP_LU
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 1.0.2
CATEGORIES= math
@@ -18,7 +18,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
USES= localbase:ldflags
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= SLIP_LU
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse-spqr/Makefile b/math/suitesparse-spqr/Makefile
index 9d0995c8a0ec..9cab4c94bee9 100644
--- a/math/suitesparse-spqr/Makefile
+++ b/math/suitesparse-spqr/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= SPQR
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 2.0.9
CATEGORIES= math
@@ -15,12 +15,12 @@ LIB_DEPENDS= libamd.so:math/suitesparse-amd \
libcholmod.so:math/suitesparse-cholmod
USES= localbase:ldflags
-
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
-USE_LDCONFIG= yes
BLAS_NEEDED= yes
OMP_NEEDED= yes
+MPORTNAME= SPQR
+USE_LDCONFIG= yes
+
# See https://github.com/DrTimothyAldenDavis/SuiteSparse/issues/72 and PR 252651
#OPTIONS_DEFINE+= TBB
#OPTIONS_DEFAULT+= TBB
diff --git a/math/suitesparse-umfpack/Makefile b/math/suitesparse-umfpack/Makefile
index 9e1e4bf6d660..9aef333a568a 100644
--- a/math/suitesparse-umfpack/Makefile
+++ b/math/suitesparse-umfpack/Makefile
@@ -1,6 +1,6 @@
# Created by: Thierry Thomas (<thierry@pompo.net>)
-PORTNAME= UMFPACK
+PORTNAME= ${MPORTNAME:tl}
PORTVERSION= 5.7.9
CATEGORIES= math
@@ -19,7 +19,7 @@ USES= localbase:ldflags
BLAS_NEEDED= yes
OMP_NEEDED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MPORTNAME= UMFPACK
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index 67274847faa0..59a3989a8094 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -9,23 +9,23 @@ COMMENT= Set of packages for sparse matrix calculation
LICENSE= GPLv2+
-RUN_DEPENDS= suitesparse-AMD>0:math/suitesparse-amd \
- suitesparse-BTF>0:math/suitesparse-btf \
- suitesparse-CCOLAMD>0:math/suitesparse-ccolamd \
- suitesparse-CHOLMOD>0:math/suitesparse-cholmod \
- suitesparse-COLAMD>0:math/suitesparse-colamd \
+RUN_DEPENDS= suitesparse-amd>0:math/suitesparse-amd \
+ suitesparse-btf>0:math/suitesparse-btf \
+ suitesparse-ccolamd>0:math/suitesparse-ccolamd \
+ suitesparse-cholmod>0:math/suitesparse-cholmod \
+ suitesparse-colamd>0:math/suitesparse-colamd \
suitesparse-config>0:math/suitesparse-config \
- suitesparse-CXSparse>0:math/suitesparse-cxsparse \
- suitesparse-GraphBLAS>0:math/suitesparse-graphblas \
- suitesparse-KLU>0:math/suitesparse-klu \
- suitesparse-LDL>0:math/suitesparse-ldl \
- suitesparse-Mongoose>0:math/suitesparse-mongoose \
- suitesparse-RBio>0:math/suitesparse-rbio \
- suitesparse-SLIP_LU>0:math/suitesparse-slip_lu \
- suitesparse-SPQR>0:math/suitesparse-spqr \
- suitesparse-UMFPACK>0:math/suitesparse-umfpack
+ suitesparse-cxsparse>0:math/suitesparse-cxsparse \
+ suitesparse-graphblas>0:math/suitesparse-graphblas \
+ suitesparse-klu>0:math/suitesparse-klu \
+ suitesparse-ldl>0:math/suitesparse-ldl \
+ suitesparse-mongoose>0:math/suitesparse-mongoose \
+ suitesparse-rbio>0:math/suitesparse-rbio \
+ suitesparse-slip_lu>0:math/suitesparse-slip_lu \
+ suitesparse-spqr>0:math/suitesparse-spqr \
+ suitesparse-umfpack>0:math/suitesparse-umfpack
.if !defined(PACKAGE_BUILDING)
-RUN_DEPENDS+= suitesparse-CSparse>0:math/suitesparse-csparse
+RUN_DEPENDS+= suitesparse-csparse>0:math/suitesparse-csparse
.endif
USES= metaport
diff --git a/math/suitesparse/bsd.suitesparse.mk b/math/suitesparse/bsd.suitesparse.mk
index 1138901747f1..6d812ba10cfd 100644
--- a/math/suitesparse/bsd.suitesparse.mk
+++ b/math/suitesparse/bsd.suitesparse.mk
@@ -18,14 +18,20 @@ DISTNAME= ${DISTVERSIONPREFIX}${SSPVERSION}
DIST_SUBDIR= ${SSPNAME}
WRKSRC= ${WRKDIR}/${GH_PROJECT}-${SSPVERSION}
-.if ${PORTNAME} != config && \
- ${PORTNAME} != CSparse && \
- ${PORTNAME} != ssget
+.if ${MPORTNAME} != config
+BUILD_WRKSRC= ${WRKSRC}/${MPORTNAME}
+.else
+BUILD_WRKSRC= ${WRKSRC}/SuiteSparse_config
+.endif
+
+.if ${MPORTNAME} != config && \
+ ${MPORTNAME} != CSparse && \
+ ${MPORTNAME} != ssget
LIB_DEPENDS+= libsuitesparseconfig.so:math/suitesparse-config
.endif
-.if ${PORTNAME} != config && \
- ${PORTNAME} != BTF && \
- ${PORTNAME} != ssget
+.if ${MPORTNAME} != config && \
+ ${MPORTNAME} != BTF && \
+ ${MPORTNAME} != ssget
OPTIONS_DEFINE+=DEMOS
.else
ALL_TARGET= library
@@ -80,7 +86,7 @@ OPENMP_VARS= OPENMP=gcc-
.endif
DEMOS_DESC= Build the demonstrations
-.if ${PORTNAME} == Mongoose
+.if ${MPORTNAME} == Mongoose
DEMOS_ALL_TARGET= default
.else
DEMOS_ALL_TARGET= all
@@ -95,20 +101,20 @@ LDFLAGS+= -s
post-extract:
${RM} -r ${WRKSRC}/metis-*
-.if ${PORTNAME} == AMD || \
- ${PORTNAME} == CAMD || \
- ${PORTNAME} == CCOLAMD || \
- ${PORTNAME} == CHOLMOD || \
- ${PORTNAME} == COLAMD || \
- ${PORTNAME} == CSparse || \
- ${PORTNAME} == CXSparse_newfiles || \
- ${PORTNAME} == CXSparse || \
- ${PORTNAME} == GPUQREngine || \
- ${PORTNAME} == KLU || \
- ${PORTNAME} == LDL || \
- ${PORTNAME} == RBio || \
- ${PORTNAME} == SPQR || \
- ${PORTNAME} == UMFPACK
+.if ${MPORTNAME} == AMD || \
+ ${MPORTNAME} == CAMD || \
+ ${MPORTNAME} == CCOLAMD || \
+ ${MPORTNAME} == CHOLMOD || \
+ ${MPORTNAME} == COLAMD || \
+ ${MPORTNAME} == CSparse || \
+ ${MPORTNAME} == CXSparse_newfiles || \
+ ${MPORTNAME} == CXSparse || \
+ ${MPORTNAME} == GPUQREngine || \
+ ${MPORTNAME} == KLU || \
+ ${MPORTNAME} == LDL || \
+ ${MPORTNAME} == RBio || \
+ ${MPORTNAME} == SPQR || \
+ ${MPORTNAME} == UMFPACK
pre-configure:
${REINPLACE_CMD} -e 's|-I../../include|-I${STAGEDIR}${PREFIX}/include/suitesparse -I../../SuiteSparse_config -I../../AMD/Include -I../../COLAMD/Include -I../../BTF/Include -I../../CHOLMOD/Include|;\
s|-lsuitesparseconfig|-lsuitesparseconfig -L${LOCALBASE}/lib|' \
@@ -118,7 +124,7 @@ pre-configure:
do-configure: # skip USES=cmake
post-install:
-.if ! ${PORTNAME} == config
+.if ! ${MPORTNAME} == config
@${RM} ${STAGEDIR}${DOCSDIR}/SUITESPARSECONFIG_README.txt \
${STAGEDIR}${PREFIX}/include/suitesparse/SuiteSparse_config.h
.endif