aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2021-11-14 07:45:24 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-11-14 08:09:31 +0000
commit3ef489e2c022073e87ec7b4f98642bc826574765 (patch)
tree882ccb1b11b311e8a8b3aa59b8fc63212f2d1686 /math
parenta456c8e29e44d08b4c23ad6121afa1046fe98899 (diff)
downloadports-3ef489e2c022073e87ec7b4f98642bc826574765.tar.gz
ports-3ef489e2c022073e87ec7b4f98642bc826574765.zip
math/gismo: Set TARGET_ARCHITECTURE on aarch64.
Set the target architecture on aarch64 to fix the build. CMake Error at cmake/OptimizeForArchitecture.cmake:1781 (message): Unknown target architecture: "generic". Please set TARGET_ARCHITECTURE to a supported value. Approved by: portmgr (build fix blanket)
Diffstat (limited to 'math')
-rw-r--r--math/gismo/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/math/gismo/Makefile b/math/gismo/Makefile
index d00e4bda09bb..3c43f787c19d 100644
--- a/math/gismo/Makefile
+++ b/math/gismo/Makefile
@@ -20,4 +20,10 @@ CMAKE_TESTING_ON= GISMO_BUILD_UNITTESTS # one test is known to fail: https://git
GH_TUPLE= gismo:gsElasticity:7bfde6d:gsElasticity/extensions/gsElasticity \
gismo:gsUnitTest:7c42e58:gsUnitTest/extensions/gsUnitTest
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == aarch64
+CMAKE_ARGS+= -DTARGET_ARCHITECTURE="cortex-a53"
+.endif
+
+.include <bsd.port.post.mk>