aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-10-18 16:11:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-10-18 16:54:27 +0000
commitccfa0d0a90fea4accf358383331acd4578e4ffcf (patch)
treeaa6eb17c0bb96fa09a8a3e695728a5f3f3dd84da /math
parent460f534008b66f8fc11ba8aeead518f70de3a526 (diff)
downloadports-ccfa0d0a90fea4accf358383331acd4578e4ffcf.tar.gz
ports-ccfa0d0a90fea4accf358383331acd4578e4ffcf.zip
math/py-ducc0: Add the test target
At least one test fails due to numpy version being too low.
Diffstat (limited to 'math')
-rw-r--r--math/py-ducc0/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/math/py-ducc0/Makefile b/math/py-ducc0/Makefile
index 6bdd58f1acff..0aa188f10db0 100644
--- a/math/py-ducc0/Makefile
+++ b/math/py-ducc0/Makefile
@@ -12,6 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR}
RUN_DEPENDS= ${PYNUMPY}
+TEST_DEPENDS= py.test:devel/py-pytest@${PY_FLAVOR}
USES= python:3.6+
@@ -31,4 +32,7 @@ USES+= compiler:c++17-lang
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/ducc0*.so
+do-test: install
+ @cd ${WRKSRC} && py.test
+
.include <bsd.port.mk>