aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-11-26 19:39:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-11-26 22:02:39 +0000
commitde46e513ae6c049bf2e931937c853cc6acaf19cc (patch)
tree8ca30a1cbb3c94431c8b66dd1584d499199c077c /math
parentefa95596af10355a65865124722b6895723c5ef2 (diff)
downloadports-de46e513ae6c049bf2e931937c853cc6acaf19cc.tar.gz
ports-de46e513ae6c049bf2e931937c853cc6acaf19cc.zip
math/xtensor-io: New port: Xtensor plugin to read/write images, audio files, numpy npz and HDF5
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/xtensor-io/Makefile30
-rw-r--r--math/xtensor-io/distinfo3
-rw-r--r--math/xtensor-io/pkg-descr9
-rw-r--r--math/xtensor-io/pkg-plist26
5 files changed, 69 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index b46addb51c06..0a07c732e1d4 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -1076,6 +1076,7 @@
SUBDIR += xspread
SUBDIR += xtensor
SUBDIR += xtensor-blas
+ SUBDIR += xtensor-io
SUBDIR += yacas
SUBDIR += yices
SUBDIR += z3
diff --git a/math/xtensor-io/Makefile b/math/xtensor-io/Makefile
new file mode 100644
index 000000000000..806266803828
--- /dev/null
+++ b/math/xtensor-io/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= xtensor-io
+DISTVERSION= 0.13.0
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Xtensor plugin to read/write images, audio files, numpy npz and HDF5
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+HPP_DEPENDS= xtensor>0:math/xtensor
+BUILD_DEPENDS= ${HPP_DEPENDS}
+RUN_DEPENDS= ${HPP_DEPENDS}
+TEST_DEPENDS= googletest>0:devel/googletest
+
+USES= cmake compiler:c++14-lang
+
+USE_GITHUB= yes
+GH_ACCOUNT= xtensor-stack
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+do-test: install # tests fail to compile, see https://github.com/xtensor-stack/xtensor-io/issues/168
+ @cd ${WRKSRC}/test && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} . && \
+ ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} && \
+ ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} xtest
+
+.include <bsd.port.mk>
diff --git a/math/xtensor-io/distinfo b/math/xtensor-io/distinfo
new file mode 100644
index 000000000000..5231ace98812
--- /dev/null
+++ b/math/xtensor-io/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1637954965
+SHA256 (xtensor-stack-xtensor-io-0.13.0_GH0.tar.gz) = 470bedee082adb0ef25ef7b54f9cfd3684e27b8489c42cf7980e0d90c14d04da
+SIZE (xtensor-stack-xtensor-io-0.13.0_GH0.tar.gz) = 402965
diff --git a/math/xtensor-io/pkg-descr b/math/xtensor-io/pkg-descr
new file mode 100644
index 000000000000..e30fc6081389
--- /dev/null
+++ b/math/xtensor-io/pkg-descr
@@ -0,0 +1,9 @@
+xtensor-io offers an API to read and write various file formats into xtensor
+data structures:
+* images
+* audio files
+* NumPy's compressed storage format (NPZ)
+* HDF5 files
+* Blosc
+
+WWW: https://github.com/xtensor-stack/xtensor-io
diff --git a/math/xtensor-io/pkg-plist b/math/xtensor-io/pkg-plist
new file mode 100644
index 000000000000..c61f2cfef60c
--- /dev/null
+++ b/math/xtensor-io/pkg-plist
@@ -0,0 +1,26 @@
+include/xtensor-io/thirdparty/zstr/strict_fstream.hpp
+include/xtensor-io/thirdparty/zstr/zstr.hpp
+include/xtensor-io/xaudio.hpp
+include/xtensor-io/xchunk_store_manager.hpp
+include/xtensor-io/xfile_array.hpp
+include/xtensor-io/xgdal.hpp
+include/xtensor-io/xhighfive.hpp
+include/xtensor-io/ximage.hpp
+include/xtensor-io/xio_aws_handler.hpp
+include/xtensor-io/xio_binary.hpp
+include/xtensor-io/xio_blosc.hpp
+include/xtensor-io/xio_disk_handler.hpp
+include/xtensor-io/xio_file_wrapper.hpp
+include/xtensor-io/xio_gcs_handler.hpp
+include/xtensor-io/xio_gdal_handler.hpp
+include/xtensor-io/xio_gzip.hpp
+include/xtensor-io/xio_stream_wrapper.hpp
+include/xtensor-io/xio_vsilfile_wrapper.hpp
+include/xtensor-io/xio_zlib.hpp
+include/xtensor-io/xnpz.hpp
+include/xtensor-io/xtensor-io.hpp
+include/xtensor-io/xtensor_io_config.hpp
+lib/cmake/xtensor-io/xtensor-ioConfig.cmake
+lib/cmake/xtensor-io/xtensor-ioConfigVersion.cmake
+lib/cmake/xtensor-io/xtensor-ioTargets.cmake
+libdata/pkgconfig/xtensor-io.pc