aboutsummaryrefslogtreecommitdiff
path: root/misc/xiphos/Makefile
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2020-03-01 12:47:29 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2020-03-01 12:47:29 +0000
commita478c272f54c3e26c65684e54348921691105ac3 (patch)
treef37b8591eabf31d0ef9b582dceebae0f666d9276 /misc/xiphos/Makefile
parentc680260bc8dcfa0fd461b05347d79476fc351651 (diff)
downloadports-a478c272f54c3e26c65684e54348921691105ac3.tar.gz
ports-a478c272f54c3e26c65684e54348921691105ac3.zip
Resurrect, update and adopt misc/xiphos
Resurrect the port and update it from 3.1.6 to a git commit after the latest release. The commit was selected so that the port does not depend on python2.7. Resurrection is possible because the dependency on webkit-gtk3 in the expired version has been replaced by a dependency on webkit2-gtk3. PR: 243934 Approved by: gerald (mentor)
Notes
Notes: svn path=/head/; revision=527549
Diffstat (limited to 'misc/xiphos/Makefile')
-rw-r--r--misc/xiphos/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
new file mode 100644
index 000000000000..f2801404dae3
--- /dev/null
+++ b/misc/xiphos/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= xiphos
+DISTVERSION= 4.1.0
+CATEGORIES= misc gnome
+
+MAINTAINER= salvadore@FreeBSD.org
+COMMENT= Bible interface utilizing the sword framework
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= appstream-util:devel/appstream-glib \
+ desktop-file-validate:devel/desktop-file-utils \
+ itstool:textproc/itstool \
+ yelp-build:textproc/yelp-tools
+LIB_DEPENDS= libbiblesync.so:misc/biblesync \
+ libdbus-1.so:devel/dbus \
+ libdbus-glib-1.so:devel/dbus-glib \
+ libenchant.so:textproc/enchant \
+ libicui18n.so:devel/icu \
+ libsoup-2.4.so:devel/libsoup \
+ libsword.so:misc/sword \
+ libuuid.so:misc/e2fsprogs-libuuid \
+ libwebkit2gtk-4.0.so:www/webkit2-gtk3
+
+USES= cmake gettext gnome pkgconfig
+USE_GCC= yes # misc/biblesync is build with GCC.
+USE_GITHUB= yes
+GH_ACCOUNT= crosswire
+GH_TAGNAME= 9e57333
+USE_GNOME= cairo gconf2 gtk30 gtkhtml4 intltool libgsf
+INSTALLS_ICONS= yes
+
+CMAKE_OFF= EPUB
+CMAKE_ON= GTKHTML
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= NLS
+
+.include <bsd.port.mk>