aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2017-06-08 17:25:47 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2017-06-08 17:25:47 +0000
commitad13b9f5a2cda59c93aa9f5c80c46420d18c290a (patch)
tree1c24b6ea667fa9bcf995072fd639507c74184bd7 /misc
parent766ffd903062d578d7ad92eef57480db78368e79 (diff)
downloadports-ad13b9f5a2cda59c93aa9f5c80c46420d18c290a.tar.gz
ports-ad13b9f5a2cda59c93aa9f5c80c46420d18c290a.zip
New compat11x port based on 11.0-RELEASE-p10.
Notes
Notes: svn path=/head/; revision=442944
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/compat11x/Makefile39
-rw-r--r--misc/compat11x/distinfo5
-rw-r--r--misc/compat11x/pkg-descr12
-rw-r--r--misc/compat11x/pkg-plist.amd6410
-rw-r--r--misc/compat11x/pkg-plist.i3866
6 files changed, 73 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index b097b314bbb9..b932823a6050 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -45,6 +45,7 @@
SUBDIR += colortail
SUBDIR += colwide
SUBDIR += compat10x
+ SUBDIR += compat11x
SUBDIR += compat4x
SUBDIR += compat5x
SUBDIR += compat6x
diff --git a/misc/compat11x/Makefile b/misc/compat11x/Makefile
new file mode 100644
index 000000000000..1c56c5c36a2e
--- /dev/null
+++ b/misc/compat11x/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= compat11x
+PORTVERSION= 11.0.1100122.20170608
+CATEGORIES= misc
+MASTER_SITES= LOCAL/des
+PKGNAMESUFFIX= -${ARCH}
+DISTNAME= ${PORTNAME}-${ARCH}-${PORTVERSION}
+
+MAINTAINER= des@FreeBSD.org
+COMMENT= Convenience package to install the compat11x libraries
+
+USES= tar:xz
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386 amd64
+PLIST= ${PKGDIR}/pkg-plist.${ARCH}
+TARGET_DIR= ${PREFIX}/lib/compat
+TARGET32_DIR= ${PREFIX}/lib32/compat
+USE_LDCONFIG= ${TARGET_DIR}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1100000
+IGNORE= is for FreeBSD 11.x and newer
+.endif
+
+.if ${ARCH} == amd64
+USE_LDCONFIG32= ${TARGET32_DIR}
+.endif
+
+do-install:
+ @${MKDIR} -m 0755 ${STAGEDIR}${TARGET_DIR}
+ (cd ${WRKSRC}/lib && ${INSTALL_LIB} *.so.* ${STAGEDIR}${TARGET_DIR})
+.if ${ARCH} == amd64
+ @${MKDIR} ${STAGEDIR}${TARGET32_DIR}
+ (cd ${WRKSRC}/lib32 && ${INSTALL_LIB} *.so.* ${STAGEDIR}${TARGET32_DIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/compat11x/distinfo b/misc/compat11x/distinfo
new file mode 100644
index 000000000000..43b9d1849e95
--- /dev/null
+++ b/misc/compat11x/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1496942485
+SHA256 (compat11x-amd64-11.0.1100122.20170608.tar.xz) = 0716ff9854096e0b0a22bc540ca87cdf9981f0599cd9fa6f6dcc815e016809a3
+SIZE (compat11x-amd64-11.0.1100122.20170608.tar.xz) = 772608
+SHA256 (compat11x-i386-11.0.1100122.20170608.tar.xz) = f08c607b818f85d5e84bd8a668a719969b2a7a61ca63ef123ffa263f35ede8ed
+SIZE (compat11x-i386-11.0.1100122.20170608.tar.xz) = 415672
diff --git a/misc/compat11x/pkg-descr b/misc/compat11x/pkg-descr
new file mode 100644
index 000000000000..5c50559158d2
--- /dev/null
+++ b/misc/compat11x/pkg-descr
@@ -0,0 +1,12 @@
+This package allows you to install the compat10x libraries on your
+system, so you can use legacy binaries that depend on them.
+
+Ports usage example:
+
+--
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 1100000
+LIB_DEPENDS+= libelf.so.1:misc/compat10x
+.endif
+--
diff --git a/misc/compat11x/pkg-plist.amd64 b/misc/compat11x/pkg-plist.amd64
new file mode 100644
index 000000000000..3778633d95df
--- /dev/null
+++ b/misc/compat11x/pkg-plist.amd64
@@ -0,0 +1,10 @@
+lib/compat/libarchive.so.6
+lib/compat/libbsnmptools.so.0
+lib/compat/libmilter.so.5
+lib/compat/libproc.so.3
+lib/compat/libzfs.so.2
+lib/compat/snmp_atm.so.6
+lib32/compat/libarchive.so.6
+lib32/compat/libmilter.so.5
+lib32/compat/libproc.so.3
+lib32/compat/libzfs.so.2
diff --git a/misc/compat11x/pkg-plist.i386 b/misc/compat11x/pkg-plist.i386
new file mode 100644
index 000000000000..9bef1f3d274b
--- /dev/null
+++ b/misc/compat11x/pkg-plist.i386
@@ -0,0 +1,6 @@
+lib/compat/libarchive.so.6
+lib/compat/libbsnmptools.so.0
+lib/compat/libmilter.so.5
+lib/compat/libproc.so.3
+lib/compat/libzfs.so.2
+lib/compat/snmp_atm.so.6