aboutsummaryrefslogtreecommitdiff
path: root/multimedia/bsdav
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-11-05 04:05:57 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-11-05 04:05:57 +0000
commitcc0f3248a2eb77d7e3df88333fd25eb8594223dc (patch)
tree75010301fcd5889b207534ba5547f93d0a151a7f /multimedia/bsdav
parent27c9c69fc96a28af11c42355724e1745a90b84e2 (diff)
downloadports-cc0f3248a2eb77d7e3df88333fd25eb8594223dc.tar.gz
ports-cc0f3248a2eb77d7e3df88333fd25eb8594223dc.zip
Add bsdav 1.3, BSD native set of programs for audio and video reading
and writing. PR: ports/88509 Submitted by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
Notes
Notes: svn path=/head/; revision=147258
Diffstat (limited to 'multimedia/bsdav')
-rw-r--r--multimedia/bsdav/Makefile30
-rw-r--r--multimedia/bsdav/distinfo2
-rw-r--r--multimedia/bsdav/files/patch-Makefile20
-rw-r--r--multimedia/bsdav/pkg-descr22
-rw-r--r--multimedia/bsdav/pkg-plist13
5 files changed, 87 insertions, 0 deletions
diff --git a/multimedia/bsdav/Makefile b/multimedia/bsdav/Makefile
new file mode 100644
index 000000000000..65c6869af42d
--- /dev/null
+++ b/multimedia/bsdav/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: bsdav
+# Date created: 2005-11-04
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdav
+PORTVERSION= 1.3
+CATEGORIES= multimedia
+MASTER_SITES= http://www.jakemsr.com/bsdav/ \
+ http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
+
+MAINTAINER= itetcu@people.tecnik93.com
+COMMENT= BSD native set of programs for audio and video reading and writing
+
+INSTALLS_SHLIB= yes
+
+MAN1= audiorec.1 bktrrec.1 bsdavdemux.1 bsdavrec.1 btv.1 tunerctl.1 avplay.1 \
+ bktrplay.1 bsdavplay.1
+MAN5= bsdav.5
+
+.if !( defined(NO_PORTDOCS) || defined(NOPORTDOCS) )
+PORTDOCS= README
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/bsdav/distinfo b/multimedia/bsdav/distinfo
new file mode 100644
index 000000000000..13a611e8365c
--- /dev/null
+++ b/multimedia/bsdav/distinfo
@@ -0,0 +1,2 @@
+MD5 (bsdav-1.3.tar.gz) = 61b3bc2383f444432aa11594bde0c279
+SIZE (bsdav-1.3.tar.gz) = 43367
diff --git a/multimedia/bsdav/files/patch-Makefile b/multimedia/bsdav/files/patch-Makefile
new file mode 100644
index 000000000000..194aebcd21cf
--- /dev/null
+++ b/multimedia/bsdav/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.dist Sat Nov 5 00:06:42 2005
++++ Makefile Sat Nov 5 00:27:42 2005
+@@ -171,13 +171,13 @@
+ .for i in ${SCRIPTS}
+ install -c -o ${BINOWN} -g ${BINGRP} -m 555 ${i} ${PREFIX}/bin
+ .endfor
+- mkdir -p ${PREFIX}/man/cat1
++ mkdir -p ${PREFIX}/man/man1
+ .for i in ${MAN1S}
+- install -c -o ${MANOWN} -g ${MANGRP} -m 444 ${i} ${PREFIX}/man/cat1
++ install -c -o ${MANOWN} -g ${MANGRP} -m 444 ${i} ${PREFIX}/man/man1/${i:S/.0$/.1/}
+ .endfor
+- mkdir -p ${PREFIX}/man/cat5
++ mkdir -p ${PREFIX}/man/man5
+ .for i in ${MAN5S}
+- install -c -o ${MANOWN} -g ${MANGRP} -m 444 ${i} ${PREFIX}/man/cat5
++ install -c -o ${MANOWN} -g ${MANGRP} -m 444 ${i} ${PREFIX}/man/man5/${i:S/.0$/.5/}
+ .endfor
+
+
diff --git a/multimedia/bsdav/pkg-descr b/multimedia/bsdav/pkg-descr
new file mode 100644
index 000000000000..30d0289f9a40
--- /dev/null
+++ b/multimedia/bsdav/pkg-descr
@@ -0,0 +1,22 @@
+The bsdav package is a set of programs for audio and video reading and writing.
+The programs use BSD native devices and the source code is free-as-in-BSD
+licensed as well.The bsdav package also includes a general purpose library,
+libbsdav, for both accessing audio(4) and bktr(4) devices, and simple data
+operations. While one of the goals of the bsdav project is simplicity, another
+goal is to make A/V processing on *BSD systems "easily" accessible. So to ease
+the storage and synchronization of both audio and video streams, bsdav has it's
+own, very simple, A/V container format. Hopefully the bsdav programs are
+written understandably and correclty enough that they may help others
+understand how to use audio(4) and bktr(4).
+
+bsdav consists of:
+ audiorec - record raw audio streams from audio(4) to file
+ bktrrec - record raw video streams from bktr(4) to file
+ avplay - play raw audio and/or raw video streams
+ bktrplay - display video from bktr(4) via Xv(3X)
+ tunerctl - manipulate bktr(4) tuner devices
+ bsdavrec - records audio and/or video in bsdav(5) streams
+ bsdavplay - play audio and/or video in bsdav(5) streams
+ bsdavdemux - extract audio and/or video from bsdav(5) streams
+ btv - shell script frontend for the above programs
+ libbsdav - general purpose *BSD A/V library
diff --git a/multimedia/bsdav/pkg-plist b/multimedia/bsdav/pkg-plist
new file mode 100644
index 000000000000..e028b510ff4c
--- /dev/null
+++ b/multimedia/bsdav/pkg-plist
@@ -0,0 +1,13 @@
+bin/audiorec
+bin/avplay
+bin/bktrplay
+bin/bktrrec
+bin/bsdavdemux
+bin/bsdavplay
+bin/bsdavrec
+bin/btv
+bin/tunerctl
+include/bsdav.h
+lib/libbsdav.a
+lib/libbsdav.so
+lib/libbsdav.so.1