aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ffmpeg/files
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-08-14 22:08:02 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-08-14 22:08:02 +0000
commit2e6153f64fc8c34f093fe8996451422c88ec97bc (patch)
treea36287ddbd1f91c5860a7dda3f159d80e7a69f6e /multimedia/ffmpeg/files
parent04a7ee12ce7595a5a03430fa8d198eb15a264ce3 (diff)
downloadports-2e6153f64fc8c34f093fe8996451422c88ec97bc.tar.gz
ports-2e6153f64fc8c34f093fe8996451422c88ec97bc.zip
Enable the img_resample (old) code even if ffmpeg is built with libswscale
support. There were patches floating around for other OSes that did something similar. While applications should be moving to libswscale, some (e.g. vlc) haven't gotten there yet.
Notes
Notes: svn path=/head/; revision=218561
Diffstat (limited to 'multimedia/ffmpeg/files')
-rw-r--r--multimedia/ffmpeg/files/patch-libavcodec_Makefile12
-rw-r--r--multimedia/ffmpeg/files/patch-libavcodec_imgconvert.c18
2 files changed, 30 insertions, 0 deletions
diff --git a/multimedia/ffmpeg/files/patch-libavcodec_Makefile b/multimedia/ffmpeg/files/patch-libavcodec_Makefile
new file mode 100644
index 000000000000..178aebe3d41a
--- /dev/null
+++ b/multimedia/ffmpeg/files/patch-libavcodec_Makefile
@@ -0,0 +1,12 @@
+--- libavcodec/Makefile.orig 2008-08-14 14:31:06.000000000 -0400
++++ libavcodec/Makefile 2008-08-14 14:31:16.000000000 -0400
+@@ -373,9 +373,7 @@ OBJS-$(HAVE_W32THREADS) +
+
+ OBJS-$(HAVE_XVMC) += xvmcvideo.o
+
+-ifndef CONFIG_SWSCALE
+ OBJS += imgresample.o
+-endif
+
+ # processor-specific code
+ ifdef HAVE_MMX
diff --git a/multimedia/ffmpeg/files/patch-libavcodec_imgconvert.c b/multimedia/ffmpeg/files/patch-libavcodec_imgconvert.c
new file mode 100644
index 000000000000..426fd546ffd7
--- /dev/null
+++ b/multimedia/ffmpeg/files/patch-libavcodec_imgconvert.c
@@ -0,0 +1,18 @@
+--- libavcodec/imgconvert.c.orig 2008-08-14 14:31:37.000000000 -0400
++++ libavcodec/imgconvert.c 2008-08-14 14:31:54.000000000 -0400
+@@ -2108,7 +2108,6 @@ int img_pad(AVPicture *dst, const AVPict
+ }
+ #endif
+
+-#ifndef CONFIG_SWSCALE
+ static uint8_t y_ccir_to_jpeg[256];
+ static uint8_t y_jpeg_to_ccir[256];
+ static uint8_t c_ccir_to_jpeg[256];
+@@ -2628,7 +2627,6 @@ int img_convert(AVPicture *dst, int dst_
+ avpicture_free(tmp);
+ return ret;
+ }
+-#endif
+
+ /* NOTE: we scan all the pixels to have an exact information */
+ static int get_alpha_info_pal8(const AVPicture *src, int width, int height)