aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdvdcss
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-06 04:26:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-06 04:26:40 +0000
commitf07080b33c418338b35c4bf937286f5f65e0e039 (patch)
tree930daea819ad24af09b88edbe4b00b7cee6b156c /multimedia/libdvdcss
parent132c9cdc22c7e3e42f546ba55d86cdaabccfd59c (diff)
downloadports-f07080b33c418338b35c4bf937286f5f65e0e039.tar.gz
ports-f07080b33c418338b35c4bf937286f5f65e0e039.zip
add libdvdcss
Accessing DVDs like a block device w/o having to bother about the decryption
Notes
Notes: svn path=/head/; revision=44802
Diffstat (limited to 'multimedia/libdvdcss')
-rw-r--r--multimedia/libdvdcss/Makefile25
-rw-r--r--multimedia/libdvdcss/distinfo1
-rw-r--r--multimedia/libdvdcss/pkg-comment1
-rw-r--r--multimedia/libdvdcss/pkg-descr14
-rw-r--r--multimedia/libdvdcss/pkg-plist6
5 files changed, 47 insertions, 0 deletions
diff --git a/multimedia/libdvdcss/Makefile b/multimedia/libdvdcss/Makefile
new file mode 100644
index 000000000000..0914e12cb78a
--- /dev/null
+++ b/multimedia/libdvdcss/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: libdvdcss
+# Date created: Jul 6, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdvdcss
+PORTVERSION= 0.0.1
+CATEGORIES= graphics
+MASTER_SITES= http://www.videolan.org/pub/videolan/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/libdvdcss/distinfo b/multimedia/libdvdcss/distinfo
new file mode 100644
index 000000000000..21f086058272
--- /dev/null
+++ b/multimedia/libdvdcss/distinfo
@@ -0,0 +1 @@
+MD5 (libdvdcss-0.0.1.tar.gz) = e98d0078e710e2c4dd7befc9e2da30e1
diff --git a/multimedia/libdvdcss/pkg-comment b/multimedia/libdvdcss/pkg-comment
new file mode 100644
index 000000000000..8f21fc76988f
--- /dev/null
+++ b/multimedia/libdvdcss/pkg-comment
@@ -0,0 +1 @@
+Accessing DVDs like a block device w/o having to bother about the decryption
diff --git a/multimedia/libdvdcss/pkg-descr b/multimedia/libdvdcss/pkg-descr
new file mode 100644
index 000000000000..c020f824534a
--- /dev/null
+++ b/multimedia/libdvdcss/pkg-descr
@@ -0,0 +1,14 @@
+libdvdcss is a simple library designed for accessing DVDs like a block device
+without having to bother about the decryption. The important features are:
+
+ - Portability. Currently supported platforms are GNU/Linux, FreeBSD, BeOS
+ and Windows.
+ - The MacOS X version is being worked on as well.
+ - Simplicity. There are currently 7 functions in the API, and we intend to
+ keep this number low.
+ - Freedom. libdvdcss is released under the General Public License, ensuring
+ it will stay free, and used only for free software products.
+ - Just better. Unlike most similar projects, libdvdcss doesn't require the
+ region of your drive to be set.
+
+WWW: http://www.videolan.org/libdvdcss/
diff --git a/multimedia/libdvdcss/pkg-plist b/multimedia/libdvdcss/pkg-plist
new file mode 100644
index 000000000000..8e7b846d2ad0
--- /dev/null
+++ b/multimedia/libdvdcss/pkg-plist
@@ -0,0 +1,6 @@
+include/videolan/dvdcss.h
+@dirrm include/videolan
+lib/libdvdcss.a
+lib/libdvdcss.so
+lib/libdvdcss.so.0
+lib/libdvdcss.so.0.0.1