aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-markad/files/patch-command_Makefile
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-05-10 15:35:19 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-05-10 15:35:19 +0000
commitf44f67e9b8093b1620f3abcf1a0cf62844232930 (patch)
tree01273598056c1692ec32443b05a21fc2388f4b57 /multimedia/vdr-plugin-markad/files/patch-command_Makefile
parent5fb19cc017161787e7dd5ca5f9c30910f6e9ea03 (diff)
downloadports-f44f67e9b8093b1620f3abcf1a0cf62844232930.tar.gz
ports-f44f67e9b8093b1620f3abcf1a0cf62844232930.zip
multimedia/vdr-plugin-markad: Fix build with ffmpeg 3.0.x
- Update patch of command/decoder.cpp to allow vdr-plugin-markad to build successfully once multimedia/ffmpeg is updated to 3.0.x. Note that multimedia/ffmpeg is currently still on the 2.8.x branch, however this patch is backwards compatible with ffmpeg 2.8.x. The additional changes to this file were based on upstream bug report #1898 [1], and also the requirement to replace s/avcodec_alloc_frame/av_frame_alloc/g. - Regenerate patches with makepatch (pet portlint), and remove PATCH_STRIP=-p1 from Makefile. [1] https://projects.vdr-developer.org/issues/1898 PR: 209386 Reported by: antoine (PR207547) Reviewed by: mat (mentor) Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D6283
Notes
Notes: svn path=/head/; revision=414944
Diffstat (limited to 'multimedia/vdr-plugin-markad/files/patch-command_Makefile')
-rw-r--r--multimedia/vdr-plugin-markad/files/patch-command_Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/multimedia/vdr-plugin-markad/files/patch-command_Makefile b/multimedia/vdr-plugin-markad/files/patch-command_Makefile
new file mode 100644
index 000000000000..d849bfda235c
--- /dev/null
+++ b/multimedia/vdr-plugin-markad/files/patch-command_Makefile
@@ -0,0 +1,48 @@
+--- command/Makefile.orig 2012-09-11 07:54:03 UTC
++++ command/Makefile
+@@ -16,6 +16,10 @@ CXXFLAGS ?= -g -rdynamic -O3 -funroll-lo
+ PKG-CONFIG ?= pkg-config
+ STRIP ?= strip
+
++ifdef FREEBSD
++LIBS+=-lintl -lexecinfo
++endif
++
+ ### Includes and Defines (add further entries here):
+
+ PKG-LIBS += libavcodec libavutil
+@@ -86,17 +90,34 @@ markad: $(OBJS)
+ $(CXX) $(CXXFLAGS) $(OBJS) $(LIBS) -o $@
+
+
++ifdef FREEBSD
++MANDIR = $(PREFIX)/man
++else
+ MANDIR = $(DESTDIR)/usr/share/man
++endif
+ install-doc:
++ifdef FREEBSD
++ @mkdir -p ${DESTDIR}$(MANDIR)/man1
++ @gzip -c markad.1 > ${DESTDIR}$(MANDIR)/man1/markad.1.gz
++else
+ @mkdir -p $(MANDIR)/man1
+ @gzip -c markad.1 > $(MANDIR)/man1/markad.1.gz
++endif
+
+ install: install-doc markad $(I18Nmsgs)
++ifdef FREEBSD
++ @mkdir -p ${DESTDIR}$(PREFIX)/bin
++ @cp -f markad ${DESTDIR}$(PREFIX)/bin/markad
++ @$(STRIP) ${DESTDIR}$(PREFIX)/bin/markad
++ @mkdir -p ${DESTDIR}$(DATADIR)/logos
++ @cp logos/* ${DESTDIR}$(DATADIR)/logos
++else
+ @mkdir -p $(DESTDIR)/usr/bin
+ @cp --remove-destination markad $(DESTDIR)/usr/bin/markad
+ @$(STRIP) $(DESTDIR)/usr/bin/markad
+ @mkdir -p $(DESTDIR)/var/lib/markad
+ @cp -a logos/* $(DESTDIR)/var/lib/markad
++endif
+ @echo markad installed
+
+ clean: