aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-05-10 15:35:19 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-05-10 15:35:19 +0000
commitf44f67e9b8093b1620f3abcf1a0cf62844232930 (patch)
tree01273598056c1692ec32443b05a21fc2388f4b57 /multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
parent5fb19cc017161787e7dd5ca5f9c30910f6e9ea03 (diff)
downloadports-f44f67e9b8093b1620f3abcf1a0cf62844232930.tar.gz
ports-f44f67e9b8093b1620f3abcf1a0cf62844232930.zip
multimedia/vdr-plugin-markad: Fix build with ffmpeg 3.0.x
- Update patch of command/decoder.cpp to allow vdr-plugin-markad to build successfully once multimedia/ffmpeg is updated to 3.0.x. Note that multimedia/ffmpeg is currently still on the 2.8.x branch, however this patch is backwards compatible with ffmpeg 2.8.x. The additional changes to this file were based on upstream bug report #1898 [1], and also the requirement to replace s/avcodec_alloc_frame/av_frame_alloc/g. - Regenerate patches with makepatch (pet portlint), and remove PATCH_STRIP=-p1 from Makefile. [1] https://projects.vdr-developer.org/issues/1898 PR: 209386 Reported by: antoine (PR207547) Reviewed by: mat (mentor) Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D6283
Notes
Notes: svn path=/head/; revision=414944
Diffstat (limited to 'multimedia/vdr-plugin-markad/files/patch-plugin-Makefile')
-rw-r--r--multimedia/vdr-plugin-markad/files/patch-plugin-Makefile22
1 files changed, 0 insertions, 22 deletions
diff --git a/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile b/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
deleted file mode 100644
index 528e9cc30d1a..000000000000
--- a/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/plugin/Makefile
-+++ b/plugin/Makefile
-@@ -99,11 +99,19 @@ i18n: $(I18Nmsgs) $(I18Npot)
- ### Targets:
-
- install: all
-+ifdef FREEBSD
-+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
-+else
- cp --remove-destination libvdr-$(PLUGIN).so $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
-+endif
-
- libvdr-$(PLUGIN).so: $(OBJS)
- $(CXX) $(CXXFLAGS) -shared $(OBJS) $(LIBS) -o $@
-+ifdef FREEBSD
-+ cp -f libvdr-$(PLUGIN).so $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
-+else
- cp --remove-destination libvdr-$(PLUGIN).so $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
-+endif
-
- clean:
- @-rm -f $(OBJS) $(DEPFILE) *.so *.so.* *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot