aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc/Makefile.inc
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-09 03:20:03 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-09 03:20:03 +0000
commite4624659dc347450133908642d4dc7fdb4788650 (patch)
tree8d6a5f63c9c9bd06ae8c4ce1f6c03bb4e687b34e /multimedia/vlc/Makefile.inc
parente7c045dcd9ad4d0684e9ccba76f55f7c275dfc54 (diff)
downloadports-e4624659dc347450133908642d4dc7fdb4788650.tar.gz
ports-e4624659dc347450133908642d4dc7fdb4788650.zip
- VLC 1.0.0 codenamed Goldeneye has arrived.
See www.videolan.org for full details. For FreeBSD: + SKINS now enabled by default. + OPTIMIZED_CFLAGS have been renamed to a more proper OCFLAGS and gaven an -O3 nudge for those who feel they may get something out of this. - OPENGL option that enables the galaktos visualization has been removed due to it's need for fmemopen() which isn't (yet) in FreeBSD. PR: ports/136451 Submitted by: "Joseph S. Atkinson" <jsa@wickedmachine.net> (maintainer)
Notes
Notes: svn path=/head/; revision=237468
Diffstat (limited to 'multimedia/vlc/Makefile.inc')
-rw-r--r--multimedia/vlc/Makefile.inc11
1 files changed, 4 insertions, 7 deletions
diff --git a/multimedia/vlc/Makefile.inc b/multimedia/vlc/Makefile.inc
index de0aad7e4322..f398762e5fd3 100644
--- a/multimedia/vlc/Makefile.inc
+++ b/multimedia/vlc/Makefile.inc
@@ -174,17 +174,14 @@
# WITHOUT_HAL=yes
# Disable HAL support
#
-# WITH_OPENGL=yes
-# Enable OpenGL visual plugin (not playback, play back is default with X11)
-#
# WITHOUT_SAMBA=yes
# Enable SAMBA Access module
#
# WITH_SSL=yes
# Enable TLS/SSL Support for web (httpd) interface
#
-# WITH_OPTIMIZED_CFLAGS=yes
-# Compile with -O2 -ffast-math -fomit-frame-pointer
+# WITH_OCFLAGS=yes
+# Compile with -O3 -ffast-math -fomit-frame-pointer
#
# WITH_DVD_DEVICE=/dev/somedevice
# default 5.x and above: /dev/acd0
@@ -263,7 +260,7 @@ pre-install: build
cd ${FAKEDIR}/libdata && ${FIND} -s * -type f -o -type l| \
${SED} -e 's|^|libdata/|' >> ${PLIST} \
&& ${FIND} -d * -type d | \
- ${SED} -e 's|^|@dirrm libdata/|' >> ${PLIST}
+ ${SED} -e 's|^|@dirrmtry libdata/|' >> ${PLIST}
.for dir in vlc
cd ${FAKEDIR}/share/${dir} && ${FIND} -s * -type f -o -type l | \
${SED} -e 's|^|share/${dir}/|' >> ${PLIST} \
@@ -288,7 +285,7 @@ pre-install: build
${SED} -e 's|^|%%WEBPLUGINS_DIR%%/|' >> ${PLIST}
${ECHO_CMD} "@dirrmtry %%WEBPLUGINS_DIR%%" >> ${PLIST}
.endif
-.for locale in co fur my oc ps tet tl
+.for locale in ckb co fur km my oc ps tet tl
${ECHO_CMD} "@unexec ${RMDIR} %D/share/locale/${locale}/LC_MESSAGES 2>/dev/null || ${TRUE}" >> ${PLIST}
${ECHO_CMD} "@unexec ${RMDIR} %D/share/locale/${locale} 2>/dev/null || ${TRUE}" >> ${PLIST}
.endfor