aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-05-24 15:55:36 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-05-24 15:55:36 +0000
commit7d9b438a7ccd0c4b8533169c022e719c4d882dd1 (patch)
tree5ad9eefc809aa56f8eb0a187e9ff92c951758a5d /multimedia
parentb2620d934cd37d1e3915b3a394616a430444409e (diff)
downloadports-7d9b438a7ccd0c4b8533169c022e719c4d882dd1.tar.gz
ports-7d9b438a7ccd0c4b8533169c022e719c4d882dd1.zip
o Update to 0.90pre3
o No longer depends on port mplayer-skins Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=59907
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile69
-rw-r--r--multimedia/mplayer/distinfo2
-rw-r--r--multimedia/mplayer/files/install-user14
-rw-r--r--multimedia/mplayer/files/patch-ad66
-rw-r--r--multimedia/mplayer/files/patch-ae38
-rw-r--r--multimedia/mplayer/pkg-plist16
-rw-r--r--multimedia/mplayerxp/Makefile69
-rw-r--r--multimedia/mplayerxp/distinfo2
-rw-r--r--multimedia/mplayerxp/files/install-user14
-rw-r--r--multimedia/mplayerxp/files/patch-ad66
-rw-r--r--multimedia/mplayerxp/files/patch-ae38
-rw-r--r--multimedia/mplayerxp/pkg-plist16
12 files changed, 254 insertions, 156 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index a467fbcd3317..5654124eb6dd 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -6,43 +6,42 @@
#
PORTNAME= mplayer
-PORTVERSION= 0.60.1
-PORTREVISION= 2
+PORTVERSION= 0.90.0.4
CATEGORIES= graphics
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
http://www.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp2.mplayerhq.hu/MPlayer/releases/ \
- http://www.stud.uni-karlsruhe.de/~uedc/mplayer/ \
http://www.rrr.de/~riggs/mplayer/
-DISTNAME= MPlayer-0.60
+DISTNAME= MPlayer-0.90pre4
MAINTAINER= riggs@rrr.de
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
iconv.3:${PORTSDIR}/converters/libiconv \
- SDL-1.1.4:${PORTSDIR}/devel/sdl12
+ mp3lame.0:${PORTSDIR}/audio/lame
RUN_DEPENDS= ${LOCALBASE}/share/mplayer/fonts:${PORTSDIR}/graphics/mplayer-fonts
-NO_PACKAGE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS=${PTHREAD_LIBS}
-CONFIGURE_ARGS= --disable-mencoder \
- --with-extralibdir=${LOCALBASE}/lib \
+CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \
--with-extraincdir=${LOCALBASE}/include
+WANT_GTK= yes
MAN1= mplayer.1
+MLINKS= mplayer.1 mencoder.1
MANCOMPRESSED= no
-CONFFILES= codecs.conf example.conf
+CONFFILES= codecs.conf example.conf input.conf
DOCFILES= DVB bugreports.html cd-dvd.html codecs-in.html \
codecs.html documentation.html faq.html skin-en.html \
- DXR3 formats.html skin-en.html sound.html tech/tech-eng.txt \
+ encoding.html formats.html sound.html tech/tech-eng.txt \
+ users_against_developers.html \
video.html
.include <bsd.port.pre.mk>
@@ -55,6 +54,14 @@ WITH_DVD= yes
WITH_SVGALIB= yes
.endif
+.if exists(${LOCALBASE}/lib/libSDL-1.1.so.4)
+WITH_SDL= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libjpeg.so.9)
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+.endif
+
.if exists(${X11BASE}/bin/xanim)
WITH_XANIM= yes
.endif
@@ -63,16 +70,13 @@ WITH_XANIM= yes
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
+.if defined(HAVE_GTK)
+WITH_GUI= yes
+.endif
+
.if defined(WITH_GUI)
USE_GTK= yes
-
-RUN_DEPENDS+= ${SKIN_DETECTION_FILE}:${SKIN_PORT}
-
CONFIGURE_ARGS+= --enable-gui
-
-SKIN_PORT= ${PORTSDIR}/graphics/mplayer-skins
-#SKIN_PORT= ${.CURDIR}/../mplayer-skins
-SKIN_DETECTION_FILE!= ${MAKE} -f ${SKIN_PORT}/Makefile -V SKIN_DETECTION_FILE
.endif
.if defined(WITH_DVD)
@@ -83,11 +87,15 @@ LIB_DEPENDS+= dvdread.2:${PORTSDIR}/graphics/libdvdread
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
.endif
+.if defined(WITH_SDL)
+LIB_DEPENDS+= SDL-1.1.4:${PORTSDIR}/devel/sdl12
+.endif
+
.if defined(WITH_VORBIS)
LIB_DEPENDS+= vorbis.1:${PORTSDIR}/audio/libvorbis
.endif
-.if defined(WITH_XANIM)
+.if defined(WITH_XANIM)
BUILD_DEPENDS+= xanim:${PORTSDIR}/graphics/xanim
CONFIGURE_ARGS+=--enable-xanim --with-xanimlibdir=${X11BASE}/lib/X11/xanim
@@ -97,6 +105,9 @@ CONFIGURE_ARGS+=--disable-xanim
# "enable" build for other archs
.if ${ARCH} == "i386"
+.if !defined(WITHOUT_RUNTIME_CPUDETECTION)
+CONFIGURE_ARGS+=--enable-runtime-cpudetection
+.else #WITHOUT_RUNTIME_CPUDETECTION
.if defined(WITHOUT_MMX)
CONFIGURE_ARGS+=--disable-mmx
.endif
@@ -109,9 +120,13 @@ CONFIGURE_ARGS+=--disable-3dnowex
.if defined(WITHOUT_SSE)
CONFIGURE_ARGS+=--disable-mmx2 --disable-sse
.endif
+.endif #WITHOUT_RUNTIME_CPUDETECTION
.if !defined(WITH_SVGALIB)
CONFIGURE_ARGS+=--disable-svga
.endif
+.if !defined(WITH_SDL)
+CONFIGURE_ARGS+=--disable-sdl
+.endif
.if !defined(WITH_VORBIS)
CONFIGURE_ARGS+=--disable-vorbis
.endif
@@ -127,11 +142,15 @@ CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
.endif # ARCH == i386
pre-everything::
+.if defined(WITH_GUI)
+ @${ECHO_MSG} "You can download official skin collections from"
+ @${ECHO_MSG} "http://www.mplayerhq.hu/homepage/dload.html"
+.endif
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "You can enable additional compilation optimizations"
@${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
.endif
-.if !defined(WITH_GUI)
+.if !defined(WITH_GUI) && !defined(HAVE_GTK)
@${ECHO_MSG} "You can enable GTK GUI by defining WITH_GUI."
.endif
.if !defined(WITH_DVD)
@@ -140,6 +159,9 @@ pre-everything::
.if !defined(WITH_SVGALIB)
@${ECHO_MSG} "You can enable SVGALIB support by defining WITH_SVGALIB."
.endif
+.if !defined(WITH_SDL)
+ @${ECHO_MSG} "You can enable SDL support by defining WITH_SDL."
+.endif
.if !defined(WITH_VORBIS)
@${ECHO_MSG} "You can enable VORBIS sound support by defining WITH_VORBIS."
.endif
@@ -149,8 +171,9 @@ pre-everything::
.if ${ARCH} == "i386"
.if !defined(WITHOUT_WIN32_CODECS)
@${ECHO_MSG} "You can disable support (this turns this into a X86 only port)"
- @${ECHO_MSG} "for Win32 codecs"
+ @${ECHO_MSG} "for Win32 codecs by defining WITHOUT_WIN32_CODECS"
.endif
+.if defined(WITHOUT_RUNTIME_CPUDETECTION)
.if !defined(WITHOUT_SSE)
@${ECHO_MSG} "You have to enable \"options CPU_ENABLE_SSE\" in your kernel"
@${ECHO_MSG} "config in order to enable kernel support for SSE/MMX2."
@@ -166,8 +189,14 @@ pre-everything::
.endif
@${ECHO_MSG} "Note: The cpu features are autodetected, so there is probably no need"
@${ECHO_MSG} "to manually disable them."
+.else
+ @${ECHO_MSG} "You can disable runtime cpu detection features by defining WITHOUT_RUNTIME_CPUDETECTION"
+.endif
.endif # ARCH == i386
+pre-configure:
+ @${RM} -Rf ${WRKSRC}/libmpdvdkit/
+
post-install:
@${MKDIR} ${DATADIR}
@${CHMOD} 755 ${DATADIR}
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index cca391e55fc1..dad620f9f409 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1 +1 @@
-MD5 (MPlayer-0.60.tar.bz2) = 0acefa2cb6130b14848955695e51d934
+MD5 (MPlayer-0.90pre4.tar.bz2) = 987436bd5f94a718d4813a6c69f07625
diff --git a/multimedia/mplayer/files/install-user b/multimedia/mplayer/files/install-user
index 0fd764316a50..deef2d700fa8 100644
--- a/multimedia/mplayer/files/install-user
+++ b/multimedia/mplayer/files/install-user
@@ -1,6 +1,6 @@
#This perl script links the codec config file
#and the fonts dir to the user's home dir.
-#V0.2 Last touched: 2001-10-12 riggs
+#Last touched: 2002-05-04 riggs
if (-e "$ENV{HOME}/.mplayer/")
{
@@ -38,16 +38,18 @@ if ($lang eq "1" || $lang eq "2")
system "mkdir $ENV{HOME}/.mplayer";
if ($lang eq "c")
{
- system "ln -s $prefix/fonts/cyrillic/ $ENV{HOME}/.mplayer/font";
+ system "ln -sv $prefix/fonts/cyrillic/ $ENV{HOME}/.mplayer/font";
}
elsif ($lang eq "r")
{
- system "ln -s $prefix/fonts/koi8r-font/ $ENV{HOME}/.mplayer/font";
+ system "ln -sv $prefix/fonts/koi8r-font/ $ENV{HOME}/.mplayer/font";
}
elsif ($lang eq "2")
{
- system "ln -s $prefix/fonts/iso-8859-2/arial-$size/ $ENV{HOME}/.mplayer/font";
+ system "ln -sv $prefix/fonts/iso-8859-2/arial-$size/ $ENV{HOME}/.mplayer/font";
}
-else {system "ln -s $prefix/fonts/iso-8859-1/arial-$size/ $ENV{HOME}/.mplayer/font"};
+else {system "ln -sv $prefix/fonts/iso-8859-1/arial-$size/ $ENV{HOME}/.mplayer/font"};
-system "ln -s $prefix/codecs.conf $ENV{HOME}/.mplayer/codecs.conf";
+system "ln -sv $prefix/codecs.conf $ENV{HOME}/.mplayer/codecs.conf";
+system "cp -pv $prefix/example.conf $ENV{HOME}/.mplayer/example.conf";
+system "cp -pv $prefix/input.conf $ENV{HOME}/.mplayer/input.conf";
diff --git a/multimedia/mplayer/files/patch-ad b/multimedia/mplayer/files/patch-ad
index dc33a4c21ead..1c25f3936d5b 100644
--- a/multimedia/mplayer/files/patch-ad
+++ b/multimedia/mplayer/files/patch-ad
@@ -1,6 +1,6 @@
---- configure.old Fri Jan 4 23:48:35 2002
-+++ configure Sat Jan 5 00:26:19 2002
-@@ -415,19 +415,10 @@
+--- configure.orig Mon May 13 22:52:10 2002
++++ configure Tue May 21 08:56:42 2002
+@@ -450,19 +450,10 @@
# Try to find the available options for the current CPU
if x86 ; then
@@ -20,40 +20,29 @@
pname=`$_cpuinfo | grep 'model name' | cut -d ':' -f 2 | head -1`
pvendor=`$_cpuinfo | grep 'vendor_id' | cut -d ':' -f 2 | cut -d ' ' -f 2 | head -1`
-@@ -1135,14 +1126,7 @@
- int main(void) { (void) malloc(0); return 0; }
- EOF
- _malloc=no
--cc_check && _malloc=yes
--if test "$_malloc" = yes ; then
-- _def_malloc='#define HAVE_MALLOC_H 1'
--else
-- _def_malloc='#undef HAVE_MALLOC_H'
--fi
--# malloc.h emits a warning in FreeBSD
--freebsd && _def_malloc='#undef HAVE_MALLOC_H'
-+_def_malloc='#undef HAVE_MALLOC_H'
- echores "$_malloc"
+@@ -1412,13 +1403,7 @@
-@@ -1153,12 +1137,7 @@
- int main (void) { (void) memalign(64, sizeof(char)); return 0; }
- EOF
+ echocheck "memalign()"
+-# XXX restrict to x86 ? extend to other CPUs/cacheline sizes ?
+-cat > $TMPC << EOF
+-#include <malloc.h>
+-int main (void) { (void) memalign(64, sizeof(char)); return 0; }
+-EOF
_memalign=no
-cc_check && _memalign=yes
--if test "$_memalign" = yes ; then
-- _def_memalign='#define HAVE_MEMALIGN 1'
--else
-- _def_memalign='#undef HAVE_MEMALIGN'
--fi
-+_def_memalign='#undef HAVE_MEMALIGN'
- echores "$_memalign"
+ if test "$_memalign" = yes ; then
+ _def_memalign='#define HAVE_MEMALIGN 1'
+ else
+@@ -1495,31 +1480,7 @@
-@@ -1235,15 +1214,7 @@
- void* func(void *arg) { return arg; }
- int main(void) { pthread_t tid; return pthread_create (&tid, 0, func, 0) == 0 ? 0 : 1; }
- EOF
+ echocheck "pthread"
+-cat > $TMPC << EOF
+-#include <pthread.h>
+-void* func(void *arg) { return arg; }
+-int main(void) { pthread_t tid; return pthread_create (&tid, 0, func, 0) == 0 ? 0 : 1; }
+-EOF
-if ( cc_check && $TMPO ) ; then # QNX
- _ld_pthread=''
-elif ( cc_check -lpthread && $TMPO ) ; then
@@ -61,13 +50,24 @@
-elif ( cc_check -pthread && $TMPO ) ; then
- _ld_pthread='-pthread'
-else
-- die "Lib pthread not found. (needed by windows and networking stuff)"
+- if test "$_ld_static" ; then
+- # for crosscompilation, we cannot execute the program, be happy if we can link statically
+- if ( cc_check -lpthread ) ; then
+- _ld_pthread='-lpthread'
+- elif ( cc_check -pthread ) ; then
+- _ld_pthread='-pthread'
+- else
+- die "Static lib pthread not found. (needed by windows and networking stuff)"
+- fi
+- else
+- die "Lib pthread not found. (needed by windows and networking stuff)"
+- fi
-fi
+_ld_pthread="${PTHREAD_LIBS}"
echores "yes (using $_ld_pthread)"
-@@ -2692,7 +2663,7 @@
+@@ -3570,7 +3531,7 @@
CFLAGS="$CFLAGS -D_REENTRANT"
elif bsd ; then
# FIXME bsd needs this so maybe other OS'es
diff --git a/multimedia/mplayer/files/patch-ae b/multimedia/mplayer/files/patch-ae
index 34aaa37e50bd..f86893178d60 100644
--- a/multimedia/mplayer/files/patch-ae
+++ b/multimedia/mplayer/files/patch-ae
@@ -1,7 +1,7 @@
---- Makefile.old Wed Jan 2 20:05:02 2002
-+++ Makefile Sat Jan 5 01:38:46 2002
-@@ -15,12 +15,12 @@
- PRG_MENCODER = mencoder
+--- Makefile.orig Tue May 21 09:11:05 2002
++++ Makefile Tue May 21 09:14:55 2002
+@@ -18,12 +18,12 @@
+ endif
#prefix = /usr/local
-BINDIR = ${prefix}/bin
@@ -14,23 +14,23 @@
-INSTALL = install
+INSTALL = @${BSD_INSTALL_PROGRAM}
- SRCS_COMMON = adpcm.c xacodec.c cpudetect.c mp_msg.c ac3-iec958.c dec_audio.c dec_video.c msvidc.c cinepak.c fli.c qtrle.c codec-cfg.c cfgparser.c my_profile.c RTjpegN.c minilzo.c nuppelvideo.c
- SRCS_MENCODER = mencoder.c $(SRCS_COMMON) libao2/afmt.c divx4_vbr.c libvo/aclib.c libvo/img_format.c
-@@ -186,38 +186,12 @@
-
- install: $(ALL_PRG)
- if test ! -d $(BINDIR) ; then mkdir -p $(BINDIR) ; fi
-- $(INSTALL) -m 755 -s $(PRG) $(BINDIR)/$(PRG)
+ SRCS_COMMON = xacodec.c cpudetect.c codec-cfg.c cfgparser.c my_profile.c spudec.c playtree.c playtreeparser.c asxparser.c vobsub.c subreader.c find_sub.c
+ SRCS_MENCODER = mencoder.c mp_msg-mencoder.c $(SRCS_COMMON) libao2/afmt.c divx4_vbr.c libvo/aclib.c libvo/osd.c libvo/sub.c libvo/font_load.c me-opt-reg.c
+@@ -220,44 +220,11 @@
+ ifeq ($(VIDIX),yes)
+ $(DO_MAKE)
+ endif
+- if test ! -d $(BINDIR) ; then mkdir -p $(BINDIR) ; fi
+ $(INSTALL) -m 755 -s $(PRG) $(BINDIR)/$(PRG)
-ifeq ($(GUI),yes)
- -ln -sf $(BINDIR)/$(PRG) $(BINDIR)/gmplayer
-endif
-+ $(INSTALL) $(PRG) $(BINDIR)/$(PRG)
- if test ! -d $(MANDIR)/man1 ; then mkdir -p $(MANDIR)/man1; fi
+- if test ! -d $(MANDIR)/man1 ; then mkdir -p $(MANDIR)/man1; fi
- $(INSTALL) -c -m 644 DOCS/mplayer.1 $(MANDIR)/man1/mplayer.1
-+ @${BSD_INSTALL_MAN} DOCS/mplayer.1 $(MANDIR)/man1/mplayer.1
++ @${BSD_INSTALL_MAN} DOCS/mplayer.1 $(MANDIR)/man1/mplayer.1
ifeq ($(MENCODER),yes)
$(INSTALL) -m 755 -s $(PRG_MENCODER) $(BINDIR)/$(PRG_MENCODER)
-- $(INSTALL) -c -m 644 DOCS/mencoder.1 $(MANDIR)/man1/mencoder.1
+ -ln -sf $(MANDIR)/man1/mplayer.1 $(MANDIR)/man1/mencoder.1
-endif
- @if test ! -d $(DATADIR) ; then mkdir -p $(DATADIR) ; fi
- @if test ! -d $(DATADIR)/font ; then mkdir -p $(DATADIR)/font ; fi
@@ -47,14 +47,18 @@
- @if test -f $(CONFDIR)/codecs.conf.old ; then mv -f $(CONFDIR)/codecs.conf.old $(CONFDIR)/codecs.conf.older ; fi
- @if test -f $(CONFDIR)/codecs.conf ; then mv -f $(CONFDIR)/codecs.conf $(CONFDIR)/codecs.conf.old ; fi
- $(INSTALL) -c -m 644 etc/codecs.conf $(CONFDIR)/codecs.conf
--
+-ifeq ($(DVDKIT),yes)
+-ifeq ($(DVDKIT_SHARED),yes)
+- if test ! -d $(LIBDIR) ; then mkdir -p $(LIBDIR) ; fi
+- $(INSTALL) -m 755 -s libmpdvdkit/libmpdvdkit.so $(LIBDIR)/libmpdvdkit.so
+-endif
+-endif
-ifeq ($(CSS_USE),yes)
- @echo "Following task requires root privs. If it fails don't panic"
- @echo "however it means you can't use fibmap_mplayer."
- @echo "Without this (or without running mplayer as root) you won't be"
- @echo "able to play encrypted DVDs."
- -$(INSTALL) -o 0 -g 0 -m 4755 -s $(PRG_FIBMAP) $(BINDIR)/$(PRG_FIBMAP)
-+ @${BSD_INSTALL_MAN} DOCS/mencoder.1 $(MANDIR)/man1/mencoder.1
endif
uninstall:
diff --git a/multimedia/mplayer/pkg-plist b/multimedia/mplayer/pkg-plist
index a6e4ad2f248f..1831ad5a2091 100644
--- a/multimedia/mplayer/pkg-plist
+++ b/multimedia/mplayer/pkg-plist
@@ -1,17 +1,31 @@
bin/mplayer
+bin/mencoder
+lib/libdha-0.1.so
+lib/libdha.so
+lib/mplayer/vidix/genfb_vid.so
+lib/mplayer/vidix/mach64_vid.so
+lib/mplayer/vidix/mga_crtc2_vid.so
+lib/mplayer/vidix/mga_vid.so
+lib/mplayer/vidix/nvidia_vid.so
+lib/mplayer/vidix/radeon_vid.so
+lib/mplayer/vidix/rage128_vid.so
%%PORTDOCS%%share/doc/mplayer/DVB
-%%PORTDOCS%%share/doc/mplayer/DXR3
%%PORTDOCS%%share/doc/mplayer/bugreports.html
%%PORTDOCS%%share/doc/mplayer/cd-dvd.html
%%PORTDOCS%%share/doc/mplayer/codecs-in.html
%%PORTDOCS%%share/doc/mplayer/codecs.html
%%PORTDOCS%%share/doc/mplayer/documentation.html
+%%PORTDOCS%%share/doc/mplayer/encoding.html
%%PORTDOCS%%share/doc/mplayer/faq.html
%%PORTDOCS%%share/doc/mplayer/formats.html
%%PORTDOCS%%share/doc/mplayer/skin-en.html
%%PORTDOCS%%share/doc/mplayer/sound.html
%%PORTDOCS%%share/doc/mplayer/video.html
%%PORTDOCS%%share/doc/mplayer/tech-eng.txt
+%%PORTDOCS%%share/doc/mplayer/users_against_developers.html
share/mplayer/codecs.conf
share/mplayer/example.conf
+share/mplayer/input.conf
%%PORTDOCS%%@dirrm share/doc/mplayer
+@dirrm lib/mplayer/vidix
+@dirrm lib/mplayer
diff --git a/multimedia/mplayerxp/Makefile b/multimedia/mplayerxp/Makefile
index a467fbcd3317..5654124eb6dd 100644
--- a/multimedia/mplayerxp/Makefile
+++ b/multimedia/mplayerxp/Makefile
@@ -6,43 +6,42 @@
#
PORTNAME= mplayer
-PORTVERSION= 0.60.1
-PORTREVISION= 2
+PORTVERSION= 0.90.0.4
CATEGORIES= graphics
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
http://www.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp2.mplayerhq.hu/MPlayer/releases/ \
- http://www.stud.uni-karlsruhe.de/~uedc/mplayer/ \
http://www.rrr.de/~riggs/mplayer/
-DISTNAME= MPlayer-0.60
+DISTNAME= MPlayer-0.90pre4
MAINTAINER= riggs@rrr.de
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
iconv.3:${PORTSDIR}/converters/libiconv \
- SDL-1.1.4:${PORTSDIR}/devel/sdl12
+ mp3lame.0:${PORTSDIR}/audio/lame
RUN_DEPENDS= ${LOCALBASE}/share/mplayer/fonts:${PORTSDIR}/graphics/mplayer-fonts
-NO_PACKAGE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS=${PTHREAD_LIBS}
-CONFIGURE_ARGS= --disable-mencoder \
- --with-extralibdir=${LOCALBASE}/lib \
+CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \
--with-extraincdir=${LOCALBASE}/include
+WANT_GTK= yes
MAN1= mplayer.1
+MLINKS= mplayer.1 mencoder.1
MANCOMPRESSED= no
-CONFFILES= codecs.conf example.conf
+CONFFILES= codecs.conf example.conf input.conf
DOCFILES= DVB bugreports.html cd-dvd.html codecs-in.html \
codecs.html documentation.html faq.html skin-en.html \
- DXR3 formats.html skin-en.html sound.html tech/tech-eng.txt \
+ encoding.html formats.html sound.html tech/tech-eng.txt \
+ users_against_developers.html \
video.html
.include <bsd.port.pre.mk>
@@ -55,6 +54,14 @@ WITH_DVD= yes
WITH_SVGALIB= yes
.endif
+.if exists(${LOCALBASE}/lib/libSDL-1.1.so.4)
+WITH_SDL= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libjpeg.so.9)
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+.endif
+
.if exists(${X11BASE}/bin/xanim)
WITH_XANIM= yes
.endif
@@ -63,16 +70,13 @@ WITH_XANIM= yes
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
+.if defined(HAVE_GTK)
+WITH_GUI= yes
+.endif
+
.if defined(WITH_GUI)
USE_GTK= yes
-
-RUN_DEPENDS+= ${SKIN_DETECTION_FILE}:${SKIN_PORT}
-
CONFIGURE_ARGS+= --enable-gui
-
-SKIN_PORT= ${PORTSDIR}/graphics/mplayer-skins
-#SKIN_PORT= ${.CURDIR}/../mplayer-skins
-SKIN_DETECTION_FILE!= ${MAKE} -f ${SKIN_PORT}/Makefile -V SKIN_DETECTION_FILE
.endif
.if defined(WITH_DVD)
@@ -83,11 +87,15 @@ LIB_DEPENDS+= dvdread.2:${PORTSDIR}/graphics/libdvdread
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
.endif
+.if defined(WITH_SDL)
+LIB_DEPENDS+= SDL-1.1.4:${PORTSDIR}/devel/sdl12
+.endif
+
.if defined(WITH_VORBIS)
LIB_DEPENDS+= vorbis.1:${PORTSDIR}/audio/libvorbis
.endif
-.if defined(WITH_XANIM)
+.if defined(WITH_XANIM)
BUILD_DEPENDS+= xanim:${PORTSDIR}/graphics/xanim
CONFIGURE_ARGS+=--enable-xanim --with-xanimlibdir=${X11BASE}/lib/X11/xanim
@@ -97,6 +105,9 @@ CONFIGURE_ARGS+=--disable-xanim
# "enable" build for other archs
.if ${ARCH} == "i386"
+.if !defined(WITHOUT_RUNTIME_CPUDETECTION)
+CONFIGURE_ARGS+=--enable-runtime-cpudetection
+.else #WITHOUT_RUNTIME_CPUDETECTION
.if defined(WITHOUT_MMX)
CONFIGURE_ARGS+=--disable-mmx
.endif
@@ -109,9 +120,13 @@ CONFIGURE_ARGS+=--disable-3dnowex
.if defined(WITHOUT_SSE)
CONFIGURE_ARGS+=--disable-mmx2 --disable-sse
.endif
+.endif #WITHOUT_RUNTIME_CPUDETECTION
.if !defined(WITH_SVGALIB)
CONFIGURE_ARGS+=--disable-svga
.endif
+.if !defined(WITH_SDL)
+CONFIGURE_ARGS+=--disable-sdl
+.endif
.if !defined(WITH_VORBIS)
CONFIGURE_ARGS+=--disable-vorbis
.endif
@@ -127,11 +142,15 @@ CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
.endif # ARCH == i386
pre-everything::
+.if defined(WITH_GUI)
+ @${ECHO_MSG} "You can download official skin collections from"
+ @${ECHO_MSG} "http://www.mplayerhq.hu/homepage/dload.html"
+.endif
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "You can enable additional compilation optimizations"
@${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
.endif
-.if !defined(WITH_GUI)
+.if !defined(WITH_GUI) && !defined(HAVE_GTK)
@${ECHO_MSG} "You can enable GTK GUI by defining WITH_GUI."
.endif
.if !defined(WITH_DVD)
@@ -140,6 +159,9 @@ pre-everything::
.if !defined(WITH_SVGALIB)
@${ECHO_MSG} "You can enable SVGALIB support by defining WITH_SVGALIB."
.endif
+.if !defined(WITH_SDL)
+ @${ECHO_MSG} "You can enable SDL support by defining WITH_SDL."
+.endif
.if !defined(WITH_VORBIS)
@${ECHO_MSG} "You can enable VORBIS sound support by defining WITH_VORBIS."
.endif
@@ -149,8 +171,9 @@ pre-everything::
.if ${ARCH} == "i386"
.if !defined(WITHOUT_WIN32_CODECS)
@${ECHO_MSG} "You can disable support (this turns this into a X86 only port)"
- @${ECHO_MSG} "for Win32 codecs"
+ @${ECHO_MSG} "for Win32 codecs by defining WITHOUT_WIN32_CODECS"
.endif
+.if defined(WITHOUT_RUNTIME_CPUDETECTION)
.if !defined(WITHOUT_SSE)
@${ECHO_MSG} "You have to enable \"options CPU_ENABLE_SSE\" in your kernel"
@${ECHO_MSG} "config in order to enable kernel support for SSE/MMX2."
@@ -166,8 +189,14 @@ pre-everything::
.endif
@${ECHO_MSG} "Note: The cpu features are autodetected, so there is probably no need"
@${ECHO_MSG} "to manually disable them."
+.else
+ @${ECHO_MSG} "You can disable runtime cpu detection features by defining WITHOUT_RUNTIME_CPUDETECTION"
+.endif
.endif # ARCH == i386
+pre-configure:
+ @${RM} -Rf ${WRKSRC}/libmpdvdkit/
+
post-install:
@${MKDIR} ${DATADIR}
@${CHMOD} 755 ${DATADIR}
diff --git a/multimedia/mplayerxp/distinfo b/multimedia/mplayerxp/distinfo
index cca391e55fc1..dad620f9f409 100644
--- a/multimedia/mplayerxp/distinfo
+++ b/multimedia/mplayerxp/distinfo
@@ -1 +1 @@
-MD5 (MPlayer-0.60.tar.bz2) = 0acefa2cb6130b14848955695e51d934
+MD5 (MPlayer-0.90pre4.tar.bz2) = 987436bd5f94a718d4813a6c69f07625
diff --git a/multimedia/mplayerxp/files/install-user b/multimedia/mplayerxp/files/install-user
index 0fd764316a50..deef2d700fa8 100644
--- a/multimedia/mplayerxp/files/install-user
+++ b/multimedia/mplayerxp/files/install-user
@@ -1,6 +1,6 @@
#This perl script links the codec config file
#and the fonts dir to the user's home dir.
-#V0.2 Last touched: 2001-10-12 riggs
+#Last touched: 2002-05-04 riggs
if (-e "$ENV{HOME}/.mplayer/")
{
@@ -38,16 +38,18 @@ if ($lang eq "1" || $lang eq "2")
system "mkdir $ENV{HOME}/.mplayer";
if ($lang eq "c")
{
- system "ln -s $prefix/fonts/cyrillic/ $ENV{HOME}/.mplayer/font";
+ system "ln -sv $prefix/fonts/cyrillic/ $ENV{HOME}/.mplayer/font";
}
elsif ($lang eq "r")
{
- system "ln -s $prefix/fonts/koi8r-font/ $ENV{HOME}/.mplayer/font";
+ system "ln -sv $prefix/fonts/koi8r-font/ $ENV{HOME}/.mplayer/font";
}
elsif ($lang eq "2")
{
- system "ln -s $prefix/fonts/iso-8859-2/arial-$size/ $ENV{HOME}/.mplayer/font";
+ system "ln -sv $prefix/fonts/iso-8859-2/arial-$size/ $ENV{HOME}/.mplayer/font";
}
-else {system "ln -s $prefix/fonts/iso-8859-1/arial-$size/ $ENV{HOME}/.mplayer/font"};
+else {system "ln -sv $prefix/fonts/iso-8859-1/arial-$size/ $ENV{HOME}/.mplayer/font"};
-system "ln -s $prefix/codecs.conf $ENV{HOME}/.mplayer/codecs.conf";
+system "ln -sv $prefix/codecs.conf $ENV{HOME}/.mplayer/codecs.conf";
+system "cp -pv $prefix/example.conf $ENV{HOME}/.mplayer/example.conf";
+system "cp -pv $prefix/input.conf $ENV{HOME}/.mplayer/input.conf";
diff --git a/multimedia/mplayerxp/files/patch-ad b/multimedia/mplayerxp/files/patch-ad
index dc33a4c21ead..1c25f3936d5b 100644
--- a/multimedia/mplayerxp/files/patch-ad
+++ b/multimedia/mplayerxp/files/patch-ad
@@ -1,6 +1,6 @@
---- configure.old Fri Jan 4 23:48:35 2002
-+++ configure Sat Jan 5 00:26:19 2002
-@@ -415,19 +415,10 @@
+--- configure.orig Mon May 13 22:52:10 2002
++++ configure Tue May 21 08:56:42 2002
+@@ -450,19 +450,10 @@
# Try to find the available options for the current CPU
if x86 ; then
@@ -20,40 +20,29 @@
pname=`$_cpuinfo | grep 'model name' | cut -d ':' -f 2 | head -1`
pvendor=`$_cpuinfo | grep 'vendor_id' | cut -d ':' -f 2 | cut -d ' ' -f 2 | head -1`
-@@ -1135,14 +1126,7 @@
- int main(void) { (void) malloc(0); return 0; }
- EOF
- _malloc=no
--cc_check && _malloc=yes
--if test "$_malloc" = yes ; then
-- _def_malloc='#define HAVE_MALLOC_H 1'
--else
-- _def_malloc='#undef HAVE_MALLOC_H'
--fi
--# malloc.h emits a warning in FreeBSD
--freebsd && _def_malloc='#undef HAVE_MALLOC_H'
-+_def_malloc='#undef HAVE_MALLOC_H'
- echores "$_malloc"
+@@ -1412,13 +1403,7 @@
-@@ -1153,12 +1137,7 @@
- int main (void) { (void) memalign(64, sizeof(char)); return 0; }
- EOF
+ echocheck "memalign()"
+-# XXX restrict to x86 ? extend to other CPUs/cacheline sizes ?
+-cat > $TMPC << EOF
+-#include <malloc.h>
+-int main (void) { (void) memalign(64, sizeof(char)); return 0; }
+-EOF
_memalign=no
-cc_check && _memalign=yes
--if test "$_memalign" = yes ; then
-- _def_memalign='#define HAVE_MEMALIGN 1'
--else
-- _def_memalign='#undef HAVE_MEMALIGN'
--fi
-+_def_memalign='#undef HAVE_MEMALIGN'
- echores "$_memalign"
+ if test "$_memalign" = yes ; then
+ _def_memalign='#define HAVE_MEMALIGN 1'
+ else
+@@ -1495,31 +1480,7 @@
-@@ -1235,15 +1214,7 @@
- void* func(void *arg) { return arg; }
- int main(void) { pthread_t tid; return pthread_create (&tid, 0, func, 0) == 0 ? 0 : 1; }
- EOF
+ echocheck "pthread"
+-cat > $TMPC << EOF
+-#include <pthread.h>
+-void* func(void *arg) { return arg; }
+-int main(void) { pthread_t tid; return pthread_create (&tid, 0, func, 0) == 0 ? 0 : 1; }
+-EOF
-if ( cc_check && $TMPO ) ; then # QNX
- _ld_pthread=''
-elif ( cc_check -lpthread && $TMPO ) ; then
@@ -61,13 +50,24 @@
-elif ( cc_check -pthread && $TMPO ) ; then
- _ld_pthread='-pthread'
-else
-- die "Lib pthread not found. (needed by windows and networking stuff)"
+- if test "$_ld_static" ; then
+- # for crosscompilation, we cannot execute the program, be happy if we can link statically
+- if ( cc_check -lpthread ) ; then
+- _ld_pthread='-lpthread'
+- elif ( cc_check -pthread ) ; then
+- _ld_pthread='-pthread'
+- else
+- die "Static lib pthread not found. (needed by windows and networking stuff)"
+- fi
+- else
+- die "Lib pthread not found. (needed by windows and networking stuff)"
+- fi
-fi
+_ld_pthread="${PTHREAD_LIBS}"
echores "yes (using $_ld_pthread)"
-@@ -2692,7 +2663,7 @@
+@@ -3570,7 +3531,7 @@
CFLAGS="$CFLAGS -D_REENTRANT"
elif bsd ; then
# FIXME bsd needs this so maybe other OS'es
diff --git a/multimedia/mplayerxp/files/patch-ae b/multimedia/mplayerxp/files/patch-ae
index 34aaa37e50bd..f86893178d60 100644
--- a/multimedia/mplayerxp/files/patch-ae
+++ b/multimedia/mplayerxp/files/patch-ae
@@ -1,7 +1,7 @@
---- Makefile.old Wed Jan 2 20:05:02 2002
-+++ Makefile Sat Jan 5 01:38:46 2002
-@@ -15,12 +15,12 @@
- PRG_MENCODER = mencoder
+--- Makefile.orig Tue May 21 09:11:05 2002
++++ Makefile Tue May 21 09:14:55 2002
+@@ -18,12 +18,12 @@
+ endif
#prefix = /usr/local
-BINDIR = ${prefix}/bin
@@ -14,23 +14,23 @@
-INSTALL = install
+INSTALL = @${BSD_INSTALL_PROGRAM}
- SRCS_COMMON = adpcm.c xacodec.c cpudetect.c mp_msg.c ac3-iec958.c dec_audio.c dec_video.c msvidc.c cinepak.c fli.c qtrle.c codec-cfg.c cfgparser.c my_profile.c RTjpegN.c minilzo.c nuppelvideo.c
- SRCS_MENCODER = mencoder.c $(SRCS_COMMON) libao2/afmt.c divx4_vbr.c libvo/aclib.c libvo/img_format.c
-@@ -186,38 +186,12 @@
-
- install: $(ALL_PRG)
- if test ! -d $(BINDIR) ; then mkdir -p $(BINDIR) ; fi
-- $(INSTALL) -m 755 -s $(PRG) $(BINDIR)/$(PRG)
+ SRCS_COMMON = xacodec.c cpudetect.c codec-cfg.c cfgparser.c my_profile.c spudec.c playtree.c playtreeparser.c asxparser.c vobsub.c subreader.c find_sub.c
+ SRCS_MENCODER = mencoder.c mp_msg-mencoder.c $(SRCS_COMMON) libao2/afmt.c divx4_vbr.c libvo/aclib.c libvo/osd.c libvo/sub.c libvo/font_load.c me-opt-reg.c
+@@ -220,44 +220,11 @@
+ ifeq ($(VIDIX),yes)
+ $(DO_MAKE)
+ endif
+- if test ! -d $(BINDIR) ; then mkdir -p $(BINDIR) ; fi
+ $(INSTALL) -m 755 -s $(PRG) $(BINDIR)/$(PRG)
-ifeq ($(GUI),yes)
- -ln -sf $(BINDIR)/$(PRG) $(BINDIR)/gmplayer
-endif
-+ $(INSTALL) $(PRG) $(BINDIR)/$(PRG)
- if test ! -d $(MANDIR)/man1 ; then mkdir -p $(MANDIR)/man1; fi
+- if test ! -d $(MANDIR)/man1 ; then mkdir -p $(MANDIR)/man1; fi
- $(INSTALL) -c -m 644 DOCS/mplayer.1 $(MANDIR)/man1/mplayer.1
-+ @${BSD_INSTALL_MAN} DOCS/mplayer.1 $(MANDIR)/man1/mplayer.1
++ @${BSD_INSTALL_MAN} DOCS/mplayer.1 $(MANDIR)/man1/mplayer.1
ifeq ($(MENCODER),yes)
$(INSTALL) -m 755 -s $(PRG_MENCODER) $(BINDIR)/$(PRG_MENCODER)
-- $(INSTALL) -c -m 644 DOCS/mencoder.1 $(MANDIR)/man1/mencoder.1
+ -ln -sf $(MANDIR)/man1/mplayer.1 $(MANDIR)/man1/mencoder.1
-endif
- @if test ! -d $(DATADIR) ; then mkdir -p $(DATADIR) ; fi
- @if test ! -d $(DATADIR)/font ; then mkdir -p $(DATADIR)/font ; fi
@@ -47,14 +47,18 @@
- @if test -f $(CONFDIR)/codecs.conf.old ; then mv -f $(CONFDIR)/codecs.conf.old $(CONFDIR)/codecs.conf.older ; fi
- @if test -f $(CONFDIR)/codecs.conf ; then mv -f $(CONFDIR)/codecs.conf $(CONFDIR)/codecs.conf.old ; fi
- $(INSTALL) -c -m 644 etc/codecs.conf $(CONFDIR)/codecs.conf
--
+-ifeq ($(DVDKIT),yes)
+-ifeq ($(DVDKIT_SHARED),yes)
+- if test ! -d $(LIBDIR) ; then mkdir -p $(LIBDIR) ; fi
+- $(INSTALL) -m 755 -s libmpdvdkit/libmpdvdkit.so $(LIBDIR)/libmpdvdkit.so
+-endif
+-endif
-ifeq ($(CSS_USE),yes)
- @echo "Following task requires root privs. If it fails don't panic"
- @echo "however it means you can't use fibmap_mplayer."
- @echo "Without this (or without running mplayer as root) you won't be"
- @echo "able to play encrypted DVDs."
- -$(INSTALL) -o 0 -g 0 -m 4755 -s $(PRG_FIBMAP) $(BINDIR)/$(PRG_FIBMAP)
-+ @${BSD_INSTALL_MAN} DOCS/mencoder.1 $(MANDIR)/man1/mencoder.1
endif
uninstall:
diff --git a/multimedia/mplayerxp/pkg-plist b/multimedia/mplayerxp/pkg-plist
index a6e4ad2f248f..1831ad5a2091 100644
--- a/multimedia/mplayerxp/pkg-plist
+++ b/multimedia/mplayerxp/pkg-plist
@@ -1,17 +1,31 @@
bin/mplayer
+bin/mencoder
+lib/libdha-0.1.so
+lib/libdha.so
+lib/mplayer/vidix/genfb_vid.so
+lib/mplayer/vidix/mach64_vid.so
+lib/mplayer/vidix/mga_crtc2_vid.so
+lib/mplayer/vidix/mga_vid.so
+lib/mplayer/vidix/nvidia_vid.so
+lib/mplayer/vidix/radeon_vid.so
+lib/mplayer/vidix/rage128_vid.so
%%PORTDOCS%%share/doc/mplayer/DVB
-%%PORTDOCS%%share/doc/mplayer/DXR3
%%PORTDOCS%%share/doc/mplayer/bugreports.html
%%PORTDOCS%%share/doc/mplayer/cd-dvd.html
%%PORTDOCS%%share/doc/mplayer/codecs-in.html
%%PORTDOCS%%share/doc/mplayer/codecs.html
%%PORTDOCS%%share/doc/mplayer/documentation.html
+%%PORTDOCS%%share/doc/mplayer/encoding.html
%%PORTDOCS%%share/doc/mplayer/faq.html
%%PORTDOCS%%share/doc/mplayer/formats.html
%%PORTDOCS%%share/doc/mplayer/skin-en.html
%%PORTDOCS%%share/doc/mplayer/sound.html
%%PORTDOCS%%share/doc/mplayer/video.html
%%PORTDOCS%%share/doc/mplayer/tech-eng.txt
+%%PORTDOCS%%share/doc/mplayer/users_against_developers.html
share/mplayer/codecs.conf
share/mplayer/example.conf
+share/mplayer/input.conf
%%PORTDOCS%%@dirrm share/doc/mplayer
+@dirrm lib/mplayer/vidix
+@dirrm lib/mplayer