aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-02-10 19:28:06 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-02-10 19:28:06 +0000
commitec0e57b389184a4b8adc8f5897d941a6a8409a5e (patch)
tree50677f74bdf65ae03600622dd7a5f6d88252015e /multimedia
parent39196eee6411a5eba6f5cb796ab6d3e4731f9cd4 (diff)
downloadports-ec0e57b389184a4b8adc8f5897d941a6a8409a5e.tar.gz
ports-ec0e57b389184a4b8adc8f5897d941a6a8409a5e.zip
o Update to use the 0.9-rc4 sources
o Remove libfame from the possible dependency list because integrated libavcodec does the same job o Apply libdemux-mov patch suggested by lioux (will fix some quicktime movies) o Fix pkg-plist PR: ports/48152 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=75256
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile16
-rw-r--r--multimedia/mplayer/distinfo2
-rw-r--r--multimedia/mplayer/files/patch-ad26
-rw-r--r--multimedia/mplayer/pkg-plist2
4 files changed, 19 insertions, 27 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index e31704e9f070..958db2055e7f 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -145,8 +145,7 @@
# to be installed.
PORTNAME= mplayer
-PORTVERSION= 0.90.0.103
-PORTREVISION= 1
+PORTVERSION= 0.90.0.104
CATEGORIES= multimedia audio
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
@@ -156,7 +155,7 @@ MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp2.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp.lug.udel.edu/MPlayer/releases/ \
http://www.rrr.de/~riggs/mplayer/
-DISTNAME= MPlayer-0.90rc3
+DISTNAME= MPlayer-0.90rc4
MAINTAINER= riggs@rrr.de
@@ -175,6 +174,7 @@ CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \
--with-x11libdir=${X11BASE}/lib \
--with-x11incdir=${X11BASE}/include \
--enable-png \
+ --disable-libfame \
--disable-tv-v4l
USE_GNOMENG= yes
@@ -186,7 +186,7 @@ LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/mplayer/vidix
CONFFILES= codecs.conf example.conf input.conf menu.conf
DOCFILES= bugreports.html cd-dvd.html codecs-in.html \
- codecs.html documentation.html faq.html skin-en.html \
+ codecs.html documentation.html faq.html skin.html \
encoding.html formats.html sound.html \
users_against_developers.html \
video.html
@@ -315,14 +315,6 @@ CONFIGURE_ARGS+= --enable-libdv
CONFIGURE_ARGS+= --disable-libdv
.endif
-.if defined(WITH_LIBFAME)
-LIB_DEPENDS+= fame-0.9.0:${PORTSDIR}/graphics/libfame
-
-CONFIGURE_ARGS+= --enable-libfame
-.else
-CONFIGURE_ARGS+= --disable-libfame
-.endif
-
.if defined(WITH_MAD)
LIB_DEPENDS+= mad.1:${PORTSDIR}/audio/mad
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index 8ed19123d0f7..4df2d51718e3 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1 +1 @@
-MD5 (MPlayer-0.90rc3.tar.bz2) = 47a298ccd8d788ff88333c553ca81d07
+MD5 (MPlayer-0.90rc4.tar.bz2) = 4976575433d5b0ad526ca1733f5cab26
diff --git a/multimedia/mplayer/files/patch-ad b/multimedia/mplayer/files/patch-ad
index 4588426a277a..7dd07cf4ce66 100644
--- a/multimedia/mplayer/files/patch-ad
+++ b/multimedia/mplayer/files/patch-ad
@@ -1,6 +1,6 @@
---- configure.orig Sat Dec 7 07:54:02 2002
-+++ configure Mon Dec 16 21:02:31 2002
-@@ -276,7 +276,7 @@
+--- configure.orig Sun Feb 9 06:29:05 2003
++++ configure Mon Feb 10 23:20:25 2003
+@@ -294,7 +294,7 @@
# 1st pass checking for vital options
@@ -9,19 +9,19 @@
_ranlib=ranlib
_cc=gcc
test "$CC" && _cc="$CC"
-@@ -512,19 +512,10 @@
+@@ -530,19 +530,10 @@
# Try to find the available options for the current CPU
if x86 || ppc; then
- if test -r /proc/cpuinfo ; then
-- # linux with /proc mounted, extract cpu information from it
+- # Linux with /proc mounted, extract CPU information from it
- _cpuinfo="cat /proc/cpuinfo"
- elif test -r /compat/linux/proc/cpuinfo ; then
-- # FreeBSD with linux emulation /proc mounted,
-- # extract cpu information from it
+- # FreeBSD with Linux emulation /proc mounted,
+- # extract CPU information from it
- _cpuinfo="cat /compat/linux/proc/cpuinfo"
- elif x86; then
- # all other OS try to extract cpu information from a small helper
+ # all other OSes try to extract CPU information from a small helper
# program TOOLS/cpuinfo instead
$_cc -o TOOLS/cpuinfo TOOLS/cpuinfo.c
_cpuinfo="TOOLS/cpuinfo"
@@ -29,7 +29,7 @@
pname=`$_cpuinfo | grep 'model name' | cut -d ':' -f 2 | head -1`
pvendor=`$_cpuinfo | grep 'vendor_id' | cut -d ':' -f 2 | cut -d ' ' -f 2 | head -1`
-@@ -1353,8 +1344,8 @@
+@@ -1394,8 +1385,8 @@
;;
*)
@@ -40,7 +40,7 @@
;;
esac
-@@ -1364,7 +1355,7 @@
+@@ -1405,7 +1396,7 @@
test -z "$_bindir" && _bindir="$_prefix/bin"
test -z "$_datadir" && _datadir="$_prefix/share/mplayer"
test -z "$_mandir" && _mandir="$_prefix/man"
@@ -49,7 +49,7 @@
test -z "$_libdir" && _libdir="$_prefix/lib"
test -z "$_mlibdir" && _mlibdir="$MLIBHOME"
-@@ -1784,13 +1775,7 @@
+@@ -1836,13 +1827,7 @@
echocheck "memalign()"
@@ -63,7 +63,7 @@
if test "$_memalign" = yes ; then
_def_memalign='#define HAVE_MEMALIGN 1'
else
-@@ -1879,31 +1864,7 @@
+@@ -1931,31 +1916,7 @@
echocheck "pthread"
@@ -96,7 +96,7 @@
echores "yes (using $_ld_pthread)"
-@@ -4483,7 +4444,7 @@
+@@ -4694,7 +4655,7 @@
CFLAGS="$CFLAGS -D_REENTRANT"
elif bsd ; then
# FIXME bsd needs this so maybe other OS'es
diff --git a/multimedia/mplayer/pkg-plist b/multimedia/mplayer/pkg-plist
index 0fdd26cf6cf9..53487bcc6bb5 100644
--- a/multimedia/mplayer/pkg-plist
+++ b/multimedia/mplayer/pkg-plist
@@ -9,7 +9,7 @@ bin/mplayer
%%PORTDOCS%%share/doc/mplayer/encoding.html
%%PORTDOCS%%share/doc/mplayer/faq.html
%%PORTDOCS%%share/doc/mplayer/formats.html
-%%PORTDOCS%%share/doc/mplayer/skin-en.html
+%%PORTDOCS%%share/doc/mplayer/skin.html
%%PORTDOCS%%share/doc/mplayer/sound.html
%%PORTDOCS%%share/doc/mplayer/video.html
%%PORTDOCS%%share/doc/mplayer/users_against_developers.html