aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-10-07 14:47:25 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-10-25 08:49:11 +0000
commitc9d85f0d9ca12976d76cad14dcbf24e3acba1ec0 (patch)
tree76d5ac318bd0c390e886fd787bf05dff7ac625fa /multimedia
parent714c353f67e7526c1ab04567348110de31df5b40 (diff)
downloadports-c9d85f0d9ca12976d76cad14dcbf24e3acba1ec0.tar.gz
ports-c9d85f0d9ca12976d76cad14dcbf24e3acba1ec0.zip
multimedia/gstreamer1-plugins-rust: Chase USES=cargo's new git source support
PR: 256581
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer1-plugins-rust/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/multimedia/gstreamer1-plugins-rust/Makefile b/multimedia/gstreamer1-plugins-rust/Makefile
index 2f72c45ff7e5..3464e996073b 100644
--- a/multimedia/gstreamer1-plugins-rust/Makefile
+++ b/multimedia/gstreamer1-plugins-rust/Makefile
@@ -16,12 +16,9 @@ BROKEN_aarch64= fails to build: device_name: [0i8; 64usize], expected `u8`, foun
BUILD_DEPENDS= cargo-cbuild:devel/cargo-c
USES= cargo gnome meson pkgconfig ssl
-USE_GITHUB= nodefault
USE_GITLAB= yes
USE_GNOME= glib20
USE_GSTREAMER1= yes
-GH_TUPLE= rust-av:flavors:ceb65b8ce94e183c4cf4011da0a40e3a4892c2c0:flavors \
- fengalin:tokio:2fd1551867c145cabe4548da2e37adc3bdf457a4:tokio
GL_SITE= https://gitlab.freedesktop.org
GL_ACCOUNT= gstreamer
GL_PROJECT= gst-plugins-rs
@@ -396,9 +393,9 @@ CARGO_CRATES= adler-1.0.2 \
ws2_32-sys-0.2.1 \
wyz-0.2.0 \
xml-rs-0.8.4 \
- zeroize-1.4.1
-CARGO_USE_GITHUB= yes
-CARGO_GIT_SUBDIR= tokio:tokio:tokio
+ zeroize-1.4.1 \
+ tokio,tokio-macros@git+https://github.com/fengalin/tokio\#2fd1551867c145cabe4548da2e37adc3bdf457a4 \
+ flavors@git+https://github.com/rust-av/flavors\#ceb65b8ce94e183c4cf4011da0a40e3a4892c2c0
CARGO_BUILD= no
CARGO_INSTALL= no
CARGO_TEST= no