aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-09 03:20:03 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-09 03:20:03 +0000
commite4624659dc347450133908642d4dc7fdb4788650 (patch)
tree8d6a5f63c9c9bd06ae8c4ce1f6c03bb4e687b34e /multimedia
parente7c045dcd9ad4d0684e9ccba76f55f7c275dfc54 (diff)
downloadports-e4624659dc347450133908642d4dc7fdb4788650.tar.gz
ports-e4624659dc347450133908642d4dc7fdb4788650.zip
- VLC 1.0.0 codenamed Goldeneye has arrived.
See www.videolan.org for full details. For FreeBSD: + SKINS now enabled by default. + OPTIMIZED_CFLAGS have been renamed to a more proper OCFLAGS and gaven an -O3 nudge for those who feel they may get something out of this. - OPENGL option that enables the galaktos visualization has been removed due to it's need for fmemopen() which isn't (yet) in FreeBSD. PR: ports/136451 Submitted by: "Joseph S. Atkinson" <jsa@wickedmachine.net> (maintainer)
Notes
Notes: svn path=/head/; revision=237468
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile30
-rw-r--r--multimedia/vlc/Makefile.inc11
-rw-r--r--multimedia/vlc/distinfo6
-rw-r--r--multimedia/vlc/files/patch-modules__gui__qt4__qt4.cpp14
-rw-r--r--multimedia/vlc/files/patch-v4l2
5 files changed, 19 insertions, 44 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 4a209952b410..e23dea78d9d9 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -9,8 +9,7 @@
#
PORTNAME= vlc
-DISTVERSION= 0.9.9a
-PORTREVISION= 2
+DISTVERSION= 1.0.0
PORTEPOCH= 3
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION}/ \
@@ -54,11 +53,11 @@ OPTIONS= A52 "a52 audio support, many DVDs use this" On \
SVG "SVG graphics support" Off \
SVGALIB "SVGALIB video output" Off \
SHOUT "Shout2 support" Off \
- SKINS "Enable winamp skins interface (requires QT4)" Off \
+ SKINS "Enable winamp skins interface (requires QT4)" On \
SPEEX "Speex voice codec support" On \
THEORA "OGG/Vorbis video codec support" On \
TWOLAME "Twolame mpeg2 audio encoder support" On \
- V4L "Enable Video for Linux" On\
+ V4L "Enable Video for Linux" On \
VORBIS "Vorbis support" On \
WIN32_CODECS "win32 multimedia DLL's" Off \
X264 "Enable H.264/AVC codec support" On \
@@ -82,14 +81,17 @@ CONFIGURE_ENV= CPPFLAGS="-I${FAKEDIR}/include -I${WRKSRC}/include ${CPPFLAGS} -I
LIBS="-lc"
CONFIGURE_ARGS+= --enable-vlc \
+ --enable-release \
--enable-avcodec \
--enable-avformat \
--enable-postproc \
--without-dv-raw1394 \
- --disable-dv
+ --disable-dv \
+ --disable-galaktos
MAN1= vlc.1 \
- vlc-config.1
+ vlc-config.1 \
+ vlc-wrapper.1
.include <bsd.port.pre.mk>
@@ -488,13 +490,6 @@ WITHOUT_VORBIS= yes
CONFIGURE_ARGS+=--enable-ncurses
.endif
-.if defined(WITH_OPENGL) && !defined(WITHOUT_OPENGL)
-USE_GL= yes
-CONFIGURE_ARGS+=--enable-galaktos
-.else
-CONFIGURE_ARGS+=--disable-galaktos
-.endif
-
.if !defined(WITHOUT_SAMBA)
LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
CONFIGURE_ARGS+=--enable-smb
@@ -579,12 +574,9 @@ CONFIGURE_ARGS+=--enable-debug
CONFIGURE_ARGS+=--enable-release
.endif
-.if defined(WITH_OPTIMIZED_CFLAGS)
-CFLAGS+= -O2 -ffast-math -fomit-frame-pointer
-CONFIGURE_ARGS+=--enable-release \
- --enable-optimizations
-.else
-CONFIGURE_ARGS+=--enable-release
+.if defined(WITH_OCFLAGS)
+CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
+CONFIGURE_ARGS+=--enable-optimizations
.endif
.if defined(WITHOUT_V4L)
diff --git a/multimedia/vlc/Makefile.inc b/multimedia/vlc/Makefile.inc
index de0aad7e4322..f398762e5fd3 100644
--- a/multimedia/vlc/Makefile.inc
+++ b/multimedia/vlc/Makefile.inc
@@ -174,17 +174,14 @@
# WITHOUT_HAL=yes
# Disable HAL support
#
-# WITH_OPENGL=yes
-# Enable OpenGL visual plugin (not playback, play back is default with X11)
-#
# WITHOUT_SAMBA=yes
# Enable SAMBA Access module
#
# WITH_SSL=yes
# Enable TLS/SSL Support for web (httpd) interface
#
-# WITH_OPTIMIZED_CFLAGS=yes
-# Compile with -O2 -ffast-math -fomit-frame-pointer
+# WITH_OCFLAGS=yes
+# Compile with -O3 -ffast-math -fomit-frame-pointer
#
# WITH_DVD_DEVICE=/dev/somedevice
# default 5.x and above: /dev/acd0
@@ -263,7 +260,7 @@ pre-install: build
cd ${FAKEDIR}/libdata && ${FIND} -s * -type f -o -type l| \
${SED} -e 's|^|libdata/|' >> ${PLIST} \
&& ${FIND} -d * -type d | \
- ${SED} -e 's|^|@dirrm libdata/|' >> ${PLIST}
+ ${SED} -e 's|^|@dirrmtry libdata/|' >> ${PLIST}
.for dir in vlc
cd ${FAKEDIR}/share/${dir} && ${FIND} -s * -type f -o -type l | \
${SED} -e 's|^|share/${dir}/|' >> ${PLIST} \
@@ -288,7 +285,7 @@ pre-install: build
${SED} -e 's|^|%%WEBPLUGINS_DIR%%/|' >> ${PLIST}
${ECHO_CMD} "@dirrmtry %%WEBPLUGINS_DIR%%" >> ${PLIST}
.endif
-.for locale in co fur my oc ps tet tl
+.for locale in ckb co fur km my oc ps tet tl
${ECHO_CMD} "@unexec ${RMDIR} %D/share/locale/${locale}/LC_MESSAGES 2>/dev/null || ${TRUE}" >> ${PLIST}
${ECHO_CMD} "@unexec ${RMDIR} %D/share/locale/${locale} 2>/dev/null || ${TRUE}" >> ${PLIST}
.endfor
diff --git a/multimedia/vlc/distinfo b/multimedia/vlc/distinfo
index ea0c229741c1..9c30b135bced 100644
--- a/multimedia/vlc/distinfo
+++ b/multimedia/vlc/distinfo
@@ -1,3 +1,3 @@
-MD5 (vlc-0.9.9a.tar.bz2) = c8d832deeef7f4072a73506f8d033198
-SHA256 (vlc-0.9.9a.tar.bz2) = e5d0a168263f56bccc62d30031287d56f0b6a3447b552f3a5224132d0b597dd6
-SIZE (vlc-0.9.9a.tar.bz2) = 17500620
+MD5 (vlc-1.0.0.tar.bz2) = fc78904ab5fa73f518d8fe4e852e7f67
+SHA256 (vlc-1.0.0.tar.bz2) = a41ae622dde65e8eb54abf7bece9949ff9aa4b9fa1f9ca2d06c9689d19bb1d9e
+SIZE (vlc-1.0.0.tar.bz2) = 19973964
diff --git a/multimedia/vlc/files/patch-modules__gui__qt4__qt4.cpp b/multimedia/vlc/files/patch-modules__gui__qt4__qt4.cpp
deleted file mode 100644
index fda9478fcf05..000000000000
--- a/multimedia/vlc/files/patch-modules__gui__qt4__qt4.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- patch-modules__gui__qt4__qt4.cpp begins here ---
-diff -up vlc-0.9.8a/modules/gui/qt4/qt4.cpp.embedded vlc-0.9.8a/modules/gui/qt4/qt4.cpp
---- modules/gui/qt4/qt4.cpp.embedded 2008-12-05 02:27:20.000000000 +0100
-+++ modules/gui/qt4/qt4.cpp 2008-12-05 02:27:27.000000000 +0100
-@@ -213,7 +213,7 @@ vlc_module_begin();
-
- set_callbacks( OpenDialogs, Close );
-
--#if 0
-+#if 1
- add_submodule();
- set_capability( "vout window", 50 );
- set_callbacks( WindowOpen, WindowClose );
---- patch-modules__gui__qt4__qt4.cpp ends here ---
diff --git a/multimedia/vlc/files/patch-v4l b/multimedia/vlc/files/patch-v4l
index 54e855434bfb..8e839692da80 100644
--- a/multimedia/vlc/files/patch-v4l
+++ b/multimedia/vlc/files/patch-v4l
@@ -67,7 +67,7 @@
}
- memcpy( p_block->p_buffer, p_frame, p_sys->i_video_frame_size );
-+ if(read(p_sys->fd_video, p_block->p_buffer, p_sys->i_video_frame_size) <= 0)
++ if(read(p_sys->i_fd, p_block->p_buffer, p_sys->i_video_frame_size) <= 0)
+ return 0;
+
p_sys->i_video_pts = p_block->i_pts = p_block->i_dts = mdate();