aboutsummaryrefslogtreecommitdiff
path: root/net-im/mtxclient/Makefile
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-06-15 11:36:42 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-06-15 11:36:42 +0000
commitf75dd037d9501177b98ae888c0b17eb7b665d1e2 (patch)
tree8143c14bd5d8fa5e3d865d892184135dd16efb15 /net-im/mtxclient/Makefile
parenta3db6d8797e5d316645190dffada077d241376bb (diff)
downloadports-f75dd037d9501177b98ae888c0b17eb7b665d1e2.tar.gz
ports-f75dd037d9501177b98ae888c0b17eb7b665d1e2.zip
Update net-im/nheko and support libraries to latest upstream
Notes
Notes: svn path=/head/; revision=538873
Diffstat (limited to 'net-im/mtxclient/Makefile')
-rw-r--r--net-im/mtxclient/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/net-im/mtxclient/Makefile b/net-im/mtxclient/Makefile
index 500b3a14c110..ffae7db21b88 100644
--- a/net-im/mtxclient/Makefile
+++ b/net-im/mtxclient/Makefile
@@ -2,8 +2,7 @@
PORTNAME= mtxclient
DISTVERSIONPREFIX= v
-DISTVERSION= 0.3.0
-PORTREVISION= 1
+DISTVERSION= 0.3.1
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@@ -13,7 +12,6 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json \
- spdlog>=1.3:devel/spdlog \
googletest>0:devel/googletest
LIB_DEPENDS= libsodium.so:security/libsodium \
libboost_date_time.so:devel/boost-libs \
@@ -22,7 +20,8 @@ LIB_DEPENDS= libsodium.so:security/libsodium \
libboost_regex.so:devel/boost-libs \
libboost_system.so:devel/boost-libs \
libboost_thread.so:devel/boost-libs \
- libolm.so:security/olm
+ libolm.so:security/olm \
+ libspdlog.so:devel/spdlog
USES= cmake compiler:c++17-lang pkgconfig ssl \
tar:xz
@@ -30,11 +29,4 @@ USES= cmake compiler:c++17-lang pkgconfig ssl \
USE_GITHUB= yes
GH_ACCOUNT= Nheko-Reborn
-# 71 files use #include <json.hpp>, which needs to be
-# elsewhere; an alternative would be to bung in -I${LOCALBASE}/include/nlohmann
-post-patch:
- ${FIND} ${WRKSRC} -type f -print0 | \
- ${XARGS} -0 ${REINPLACE_CMD} \
- 's+include <json.hpp>+include <nlohmann/json.hpp>+'
-
.include <bsd.port.mk>