aboutsummaryrefslogtreecommitdiff
path: root/net-im/tg_owt
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2021-11-17 16:09:59 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2021-11-17 17:07:29 +0000
commit618f78768591ccf6766571cbdcdee5b2d01323a4 (patch)
treeeb348a2e0d28b87aa5a59922215b2a2cea7fb188 /net-im/tg_owt
parente833fe5a169e010c44745398843679427a08feee (diff)
downloadports-618f78768591ccf6766571cbdcdee5b2d01323a4.tar.gz
ports-618f78768591ccf6766571cbdcdee5b2d01323a4.zip
net-im/tg_owt: Update to 20 October 2021 snapshot and set new maintainer
Reported by: glebius
Diffstat (limited to 'net-im/tg_owt')
-rw-r--r--net-im/tg_owt/Makefile8
-rw-r--r--net-im/tg_owt/distinfo6
-rw-r--r--net-im/tg_owt/files/patch-CMakeLists.txt12
-rw-r--r--net-im/tg_owt/files/patch-cmake_external.cmake11
-rw-r--r--net-im/tg_owt/files/patch-cmake_libevent.cmake26
-rw-r--r--net-im/tg_owt/files/patch-cmake_libyuv.cmake11
-rw-r--r--net-im/tg_owt/files/patch-src_rtc__base_byte__order.h11
-rw-r--r--net-im/tg_owt/files/patch-src_rtc__base_ip__address.cc10
-rw-r--r--net-im/tg_owt/files/patch-src_rtc__base_physical__socket__server.cc29
-rw-r--r--net-im/tg_owt/files/patch-src_rtc__base_physical__socket__server.h11
-rw-r--r--net-im/tg_owt/files/patch-src_rtc__base_platform__thread__types.cc43
-rw-r--r--net-im/tg_owt/pkg-plist32
12 files changed, 7 insertions, 203 deletions
diff --git a/net-im/tg_owt/Makefile b/net-im/tg_owt/Makefile
index 2573a6eddf1d..3ffdd6ce9b02 100644
--- a/net-im/tg_owt/Makefile
+++ b/net-im/tg_owt/Makefile
@@ -1,10 +1,10 @@
# Created by: Henry Hu <henry.hu.sh@gmail.com>
PORTNAME= tg_owt
-PORTVERSION= 0.0.20210915
+PORTVERSION= 0.0.20211021
CATEGORIES= net-im
-MAINTAINER= henry.hu.sh@gmail.com
+MAINTAINER= glebius@FreeBSD.org
COMMENT= Webrtc library used by telegram-desktop
LICENSE= BSD3CLAUSE
@@ -26,12 +26,12 @@ USES= cmake pkgconfig xorg
USE_XORG= x11 xcomposite xdamage xrender xrandr
USE_GITHUB= yes
GH_ACCOUNT= desktop-app
-GH_TAGNAME= 575fb17
+GH_TAGNAME= d578c76
# libyuv cloned from https://chromium.googlesource.com/libyuv/libyuv
GH_TUPLE= webmproject:libvpx:5b63f0f:libvpx/src/third_party/libvpx/source/libvpx \
HenryHu:libyuv:ad89006:libyuv/src/third_party/libyuv
-CMAKE_OFF= BUILD_SHARED_LIBS
+CMAKE_OFF= BUILD_SHARED_LIBS TG_OWT_BUILD_AUDIO_BACKENDS
# Disable DCHECKs, otherwise video calls will crash.
CXXFLAGS+= -DNDEBUG
diff --git a/net-im/tg_owt/distinfo b/net-im/tg_owt/distinfo
index 5555ee3deace..f44b4f5c3aae 100644
--- a/net-im/tg_owt/distinfo
+++ b/net-im/tg_owt/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1633579018
-SHA256 (desktop-app-tg_owt-0.0.20210915-575fb17_GH0.tar.gz) = be4c4ecb32c73805beead778f5b7f52eefc9c8c69c7b0fea163816b45ba81709
-SIZE (desktop-app-tg_owt-0.0.20210915-575fb17_GH0.tar.gz) = 16261219
+TIMESTAMP = 1634830083
+SHA256 (desktop-app-tg_owt-0.0.20211021-d578c76_GH0.tar.gz) = 6bd6f32979ceba9b6e6338331d16e772d1b194db5bf1993de894f674b39a1345
+SIZE (desktop-app-tg_owt-0.0.20211021-d578c76_GH0.tar.gz) = 16073998
SHA256 (webmproject-libvpx-5b63f0f_GH0.tar.gz) = 4fdacb6ee107b504cb21b072784c649be9af6b6d73103906a0d9ea5f3000de74
SIZE (webmproject-libvpx-5b63f0f_GH0.tar.gz) = 5333441
SHA256 (HenryHu-libyuv-ad89006_GH0.tar.gz) = 96fc87a2c7051d289a9dcf31c4f8100e341dda3b5499e4bf6d82369f5d18416e
diff --git a/net-im/tg_owt/files/patch-CMakeLists.txt b/net-im/tg_owt/files/patch-CMakeLists.txt
deleted file mode 100644
index 2cf7f849c07f..000000000000
--- a/net-im/tg_owt/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,12 +0,0 @@
---- CMakeLists.txt.orig 2021-06-27 05:27:48 UTC
-+++ CMakeLists.txt
-@@ -171,6 +170,9 @@ if (UNIX AND NOT APPLE)
- link_x11(tg_owt)
- link_glib(tg_owt)
- endif()
-+
-+target_include_directories(tg_owt BEFORE PRIVATE $<TARGET_PROPERTY:tg_owt::libabsl,INTERFACE_INCLUDE_DIRECTORIES>)
-+target_include_directories(tg_owt BEFORE PRIVATE $<TARGET_PROPERTY:tg_owt::libyuv,INTERFACE_INCLUDE_DIRECTORIES>)
-
- function(add_sublibrary postfix)
- add_library(tg_owt_${postfix} OBJECT)
diff --git a/net-im/tg_owt/files/patch-cmake_external.cmake b/net-im/tg_owt/files/patch-cmake_external.cmake
deleted file mode 100644
index 820b2709d5be..000000000000
--- a/net-im/tg_owt/files/patch-cmake_external.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake/external.cmake.orig 2021-06-27 05:27:48 UTC
-+++ cmake/external.cmake
-@@ -109,7 +109,7 @@ endfunction()
- # libabsl
- # HINT: System abseil should be built with -DCMAKE_CXX_STANDARD=17
- function(link_libabsl target_name)
-- if (TG_OWT_PACKAGED_BUILD)
-+ if (0)
- find_package(absl)
- set(absl_FOUND ${absl_FOUND} PARENT_SCOPE)
- if (absl_FOUND)
diff --git a/net-im/tg_owt/files/patch-cmake_libevent.cmake b/net-im/tg_owt/files/patch-cmake_libevent.cmake
deleted file mode 100644
index 0c7474e62adf..000000000000
--- a/net-im/tg_owt/files/patch-cmake_libevent.cmake
+++ /dev/null
@@ -1,26 +0,0 @@
---- cmake/libevent.cmake.orig 2021-02-03 11:42:41 UTC
-+++ cmake/libevent.cmake
-@@ -17,14 +17,13 @@ if (APPLE)
- else()
- target_include_directories(libevent
- PRIVATE
-- ${libevent_loc}/linux
-+ ${libevent_loc}/freebsd
- )
- endif()
-
- nice_target_sources(libevent ${libevent_loc}
- PRIVATE
- buffer.c
-- epoll.c
- evbuffer.c
- evdns.c
- event.c
-@@ -32,6 +31,7 @@ PRIVATE
- evrpc.c
- evutil.c
- http.c
-+ kqueue.c
- log.c
- poll.c
- select.c
diff --git a/net-im/tg_owt/files/patch-cmake_libyuv.cmake b/net-im/tg_owt/files/patch-cmake_libyuv.cmake
deleted file mode 100644
index b8d81dc36870..000000000000
--- a/net-im/tg_owt/files/patch-cmake_libyuv.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake/libyuv.cmake.orig 2021-02-03 11:42:41 UTC
-+++ cmake/libyuv.cmake
-@@ -126,7 +126,7 @@ else()
- endif()
-
- target_include_directories(libyuv
--PUBLIC
-+BEFORE PUBLIC
- $<BUILD_INTERFACE:${libyuv_loc}/include>
- $<INSTALL_INTERFACE:${webrtc_includedir}/third_party/libyuv/include>
- )
diff --git a/net-im/tg_owt/files/patch-src_rtc__base_byte__order.h b/net-im/tg_owt/files/patch-src_rtc__base_byte__order.h
deleted file mode 100644
index 976f4709c629..000000000000
--- a/net-im/tg_owt/files/patch-src_rtc__base_byte__order.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/rtc_base/byte_order.h.orig 2021-02-03 11:42:41 UTC
-+++ src/rtc_base/byte_order.h
-@@ -89,7 +89,7 @@
- #endif // defined(WEBRTC_ARCH_LITTLE_ENDIAN)
-
- #elif defined(WEBRTC_POSIX)
--#include <endian.h>
-+#include <sys/endian.h>
- #else
- #error "Missing byte order functions for this arch."
- #endif // defined(WEBRTC_MAC)
diff --git a/net-im/tg_owt/files/patch-src_rtc__base_ip__address.cc b/net-im/tg_owt/files/patch-src_rtc__base_ip__address.cc
deleted file mode 100644
index e1a71d9d3577..000000000000
--- a/net-im/tg_owt/files/patch-src_rtc__base_ip__address.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/rtc_base/ip_address.cc.orig 2021-02-03 11:42:41 UTC
-+++ src/rtc_base/ip_address.cc
-@@ -15,6 +15,7 @@
- #include <netinet/in_systm.h>
- #endif
- #ifndef __native_client__
-+#include <sys/types.h>
- #include <netinet/ip.h>
- #endif
- #include <netdb.h>
diff --git a/net-im/tg_owt/files/patch-src_rtc__base_physical__socket__server.cc b/net-im/tg_owt/files/patch-src_rtc__base_physical__socket__server.cc
deleted file mode 100644
index 3cb199f32e2f..000000000000
--- a/net-im/tg_owt/files/patch-src_rtc__base_physical__socket__server.cc
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/rtc_base/physical_socket_server.cc.orig 2021-06-27 05:27:48 UTC
-+++ src/rtc_base/physical_socket_server.cc
-@@ -51,6 +51,8 @@
- #include "rtc_base/synchronization/mutex.h"
- #include "rtc_base/time_utils.h"
-
-+#undef WEBRTC_LINUX
-+
- #if defined(WEBRTC_LINUX)
- #include <linux/sockios.h>
- #endif
-@@ -70,7 +72,7 @@ typedef void* SockOptArg;
-
- #endif // WEBRTC_POSIX
-
--#if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(__native_client__)
-+#if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(__native_client__) && !defined(__FreeBSD__)
-
- int64_t GetSocketRecvTimestamp(int socket) {
- struct timeval tv_ioctl;
-@@ -564,7 +566,7 @@ int PhysicalSocket::TranslateOption(Option opt, int* s
- *slevel = IPPROTO_IP;
- *sopt = IP_DONTFRAGMENT;
- break;
--#elif defined(WEBRTC_MAC) || defined(BSD) || defined(__native_client__)
-+#elif defined(WEBRTC_MAC) || defined(BSD) || defined(__native_client__) || defined(__FreeBSD__)
- RTC_LOG(LS_WARNING) << "Socket::OPT_DONTFRAGMENT not supported.";
- return -1;
- #elif defined(WEBRTC_POSIX)
diff --git a/net-im/tg_owt/files/patch-src_rtc__base_physical__socket__server.h b/net-im/tg_owt/files/patch-src_rtc__base_physical__socket__server.h
deleted file mode 100644
index 5dd3ba60c4ac..000000000000
--- a/net-im/tg_owt/files/patch-src_rtc__base_physical__socket__server.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/rtc_base/physical_socket_server.h.orig 2021-02-03 11:42:41 UTC
-+++ src/rtc_base/physical_socket_server.h
-@@ -12,8 +12,6 @@
- #define RTC_BASE_PHYSICAL_SOCKET_SERVER_H_
-
- #if defined(WEBRTC_POSIX) && defined(WEBRTC_LINUX)
--#include <sys/epoll.h>
--#define WEBRTC_USE_EPOLL 1
- #endif
-
- #include <array>
diff --git a/net-im/tg_owt/files/patch-src_rtc__base_platform__thread__types.cc b/net-im/tg_owt/files/patch-src_rtc__base_platform__thread__types.cc
deleted file mode 100644
index cb4f11a8d336..000000000000
--- a/net-im/tg_owt/files/patch-src_rtc__base_platform__thread__types.cc
+++ /dev/null
@@ -1,43 +0,0 @@
---- src/rtc_base/platform_thread_types.cc.orig 2021-02-03 11:42:41 UTC
-+++ src/rtc_base/platform_thread_types.cc
-@@ -11,10 +11,14 @@
- #include "rtc_base/platform_thread_types.h"
-
- #if defined(WEBRTC_LINUX)
--#include <sys/prctl.h>
- #include <sys/syscall.h>
- #endif
-
-+#ifdef __FreeBSD__
-+#include <sys/thr.h>
-+#include <pthread_np.h>
-+#endif
-+
- #if defined(WEBRTC_WIN)
- #include "rtc_base/arraysize.h"
-
-@@ -38,7 +42,13 @@ PlatformThreadId CurrentThreadId() {
- #elif defined(WEBRTC_FUCHSIA)
- return zx_thread_self();
- #elif defined(WEBRTC_LINUX)
-+#if defined(__FreeBSD__)
-+ long id;
-+ thr_self(&id);
-+ return id;
-+#else
- return syscall(__NR_gettid);
-+#endif
- #elif defined(__EMSCRIPTEN__)
- return static_cast<PlatformThreadId>(pthread_self());
- #else
-@@ -106,9 +116,7 @@ void SetCurrentThreadName(const char* name) {
- }
- #pragma warning(pop)
- #elif defined(WEBRTC_LINUX) || defined(WEBRTC_ANDROID)
-- prctl(PR_SET_NAME, reinterpret_cast<unsigned long>(name)); // NOLINT
--#elif defined(WEBRTC_MAC) || defined(WEBRTC_IOS)
-- pthread_setname_np(name);
-+ pthread_set_name_np(pthread_self(), name);
- #endif
- }
-
diff --git a/net-im/tg_owt/pkg-plist b/net-im/tg_owt/pkg-plist
index 9670acb8cc07..83025e93f067 100644
--- a/net-im/tg_owt/pkg-plist
+++ b/net-im/tg_owt/pkg-plist
@@ -324,36 +324,6 @@ include/tg_owt/base/android/task_scheduler/task_runner_android.h
include/tg_owt/base/android/timezone_utils.h
include/tg_owt/base/android/unguessable_token_android.h
include/tg_owt/base/compiler_specific.h
-include/tg_owt/base/third_party/libevent/aix/config.h
-include/tg_owt/base/third_party/libevent/aix/event-config.h
-include/tg_owt/base/third_party/libevent/android/config.h
-include/tg_owt/base/third_party/libevent/android/event-config.h
-include/tg_owt/base/third_party/libevent/compat/sys/_libevent_time.h
-include/tg_owt/base/third_party/libevent/compat/sys/queue.h
-include/tg_owt/base/third_party/libevent/evdns.h
-include/tg_owt/base/third_party/libevent/event-config.h
-include/tg_owt/base/third_party/libevent/event-internal.h
-include/tg_owt/base/third_party/libevent/event.h
-include/tg_owt/base/third_party/libevent/evhttp.h
-include/tg_owt/base/third_party/libevent/evrpc-internal.h
-include/tg_owt/base/third_party/libevent/evrpc.h
-include/tg_owt/base/third_party/libevent/evsignal.h
-include/tg_owt/base/third_party/libevent/evutil.h
-include/tg_owt/base/third_party/libevent/freebsd/config.h
-include/tg_owt/base/third_party/libevent/freebsd/event-config.h
-include/tg_owt/base/third_party/libevent/http-internal.h
-include/tg_owt/base/third_party/libevent/linux/config.h
-include/tg_owt/base/third_party/libevent/linux/event-config.h
-include/tg_owt/base/third_party/libevent/log.h
-include/tg_owt/base/third_party/libevent/mac/config.h
-include/tg_owt/base/third_party/libevent/mac/event-config.h
-include/tg_owt/base/third_party/libevent/min_heap.h
-include/tg_owt/base/third_party/libevent/nacl_nonsfi/config.h
-include/tg_owt/base/third_party/libevent/nacl_nonsfi/event-config.h
-include/tg_owt/base/third_party/libevent/solaris/config.h
-include/tg_owt/base/third_party/libevent/solaris/event-config.h
-include/tg_owt/base/third_party/libevent/strlcpy-internal.h
-include/tg_owt/base/third_party/libevent/test/regress.h
include/tg_owt/build/build_config.h
include/tg_owt/call/adaptation/adaptation_constraint.h
include/tg_owt/call/adaptation/broadcast_resource_listener.h
@@ -3112,8 +3082,6 @@ lib/libtg_owt.a
@dir include/tg_owt/base/android/junit/src/org/chromium/base/task
@dir include/tg_owt/base/android/junit/src/org/chromium/base/util
@dir include/tg_owt/base/android/proguard
-@dir include/tg_owt/base/third_party/libevent/m4
-@dir include/tg_owt/base/third_party/libevent/sample
@dir include/tg_owt/modules/audio_coding/codecs/g711/test
@dir include/tg_owt/modules/audio_coding/codecs/g722/test
@dir include/tg_owt/modules/audio_coding/codecs/ilbc/test