aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
commite1bfdfbe5665c963621e06f6bbfbbc2c000a804e (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /net-im
parentf57bc4af665126de839ff734a08e57726e84da84 (diff)
downloadports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.tar.gz
ports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.zip
Add DOCS options to ports that should have one.
Also various fixes related to said option. PR: 230864 Submitted by: mat exp-runs by: antoine
Notes
Notes: svn path=/head/; revision=479406
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centerim-devel/Makefile2
-rw-r--r--net-im/centerim/Makefile2
-rw-r--r--net-im/kaccounts-integration/Makefile2
-rw-r--r--net-im/kaccounts-providers/Makefile2
-rw-r--r--net-im/kopete/Makefile2
-rw-r--r--net-im/ktp-accounts-kcm/Makefile2
-rw-r--r--net-im/ktp-approver/Makefile2
-rw-r--r--net-im/ktp-auth-handler/Makefile2
-rw-r--r--net-im/ktp-call-ui/Makefile2
-rw-r--r--net-im/ktp-common-internals/Makefile2
-rw-r--r--net-im/ktp-contact-list/Makefile2
-rw-r--r--net-im/ktp-contact-runner/Makefile2
-rw-r--r--net-im/ktp-desktop-applets/Makefile2
-rw-r--r--net-im/ktp-filetransfer-handler/Makefile2
-rw-r--r--net-im/ktp-kded-module/Makefile2
-rw-r--r--net-im/ktp-send-file/Makefile2
-rw-r--r--net-im/ktp-text-ui/Makefile2
-rw-r--r--net-im/prosody-modules/Makefile2
-rw-r--r--net-im/sayaka/Makefile2
-rw-r--r--net-im/skype-devel/Makefile2
-rw-r--r--net-im/skype/Makefile2
-rw-r--r--net-im/skype4/Makefile2
-rw-r--r--net-im/talkatu/Makefile2
-rw-r--r--net-im/telegram/Makefile2
-rw-r--r--net-im/vacuum-im/Makefile2
25 files changed, 43 insertions, 7 deletions
diff --git a/net-im/centerim-devel/Makefile b/net-im/centerim-devel/Makefile
index 29e71591b30d..38402c1b504e 100644
--- a/net-im/centerim-devel/Makefile
+++ b/net-im/centerim-devel/Makefile
@@ -29,7 +29,7 @@ SHEBANG_LANG= gawk
gawk_OLD_CMD= /bin/gawk
gawk_CMD= /usr/bin/awk
-OPTIONS_DEFINE= NLS MULTIBYTE FRIBIDI MSN YAHOO IRC JABBER GPGME RSS LJ GG
+OPTIONS_DEFINE= NLS MULTIBYTE FRIBIDI MSN YAHOO IRC JABBER GPGME RSS LJ GG DOCS
FRIBIDI_DESC= Fribidi Support
MSN_DESC= MSN Protocol
diff --git a/net-im/centerim/Makefile b/net-im/centerim/Makefile
index 3e87f9d199d4..d372b0b3138d 100644
--- a/net-im/centerim/Makefile
+++ b/net-im/centerim/Makefile
@@ -29,7 +29,7 @@ SHEBANG_FILES= misc/CenterIMLog2HTML.py misc/cimformathistory misc/cimextracthis
gawk_OLD_CMD= /bin/gawk
gawk_CMD= /usr/bin/awk
-OPTIONS_DEFINE= NLS MULTIBYTE FRIBIDI MSN YAHOO IRC JABBER GPGME RSS LJ GG
+OPTIONS_DEFINE= NLS MULTIBYTE FRIBIDI MSN YAHOO IRC JABBER GPGME RSS LJ GG DOCS
FRIBIDI_DESC= Fribidi Support
MSN_DESC= MSN Protocol
diff --git a/net-im/kaccounts-integration/Makefile b/net-im/kaccounts-integration/Makefile
index d5cbfbdc9ae4..1961b0612e78 100644
--- a/net-im/kaccounts-integration/Makefile
+++ b/net-im/kaccounts-integration/Makefile
@@ -21,4 +21,6 @@ USE_KDE= auth codecs config configwidgets coreaddons dbusaddons ecm \
USE_QT= dbus core gui network qml widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/kaccounts-providers/Makefile b/net-im/kaccounts-providers/Makefile
index 6b423a4e34ec..96165e0508ea 100644
--- a/net-im/kaccounts-providers/Makefile
+++ b/net-im/kaccounts-providers/Makefile
@@ -18,6 +18,8 @@ USE_KDE= config coreaddons i18n kdeclarative kio package service
USE_QT= core gui network qml xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
#install to ${LOCALBASE}:
pre-configure:
${REINPLACE_CMD} -e 's,/etc,${PREFIX}/etc,' \
diff --git a/net-im/kopete/Makefile b/net-im/kopete/Makefile
index 5dcac3bdb59c..2f604b7fb422 100644
--- a/net-im/kopete/Makefile
+++ b/net-im/kopete/Makefile
@@ -34,4 +34,6 @@ SHEBANG_FILES= protocols/winpopup/winpopup-install \
protocols/winpopup/winpopup-send \
kopete/kconf_update/*.pl
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-accounts-kcm/Makefile b/net-im/ktp-accounts-kcm/Makefile
index c710ee9abc62..bc9c58654ce8 100644
--- a/net-im/ktp-accounts-kcm/Makefile
+++ b/net-im/ktp-accounts-kcm/Makefile
@@ -27,7 +27,7 @@ USE_QT= core dbus gui network qml sql widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
-OPTIONS_DEFINE= HAZE IRC JABBER SALUT
+OPTIONS_DEFINE= HAZE IRC JABBER SALUT DOCS
OPTIONS_DEFAULT=JABBER
HAZE_DESC= libpurple protocols support
diff --git a/net-im/ktp-approver/Makefile b/net-im/ktp-approver/Makefile
index f2aa6a6a371a..1362ea87d920 100644
--- a/net-im/ktp-approver/Makefile
+++ b/net-im/ktp-approver/Makefile
@@ -16,4 +16,6 @@ USE_KDE= config coreaddons ecm dbusaddons service i18n notifications
USE_QT= core dbus gui network widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-auth-handler/Makefile b/net-im/ktp-auth-handler/Makefile
index 530106515197..faa51062d6d3 100644
--- a/net-im/ktp-auth-handler/Makefile
+++ b/net-im/ktp-auth-handler/Makefile
@@ -20,4 +20,6 @@ USE_KDE= completion config coreaddons ecm i18n jobwidgets kdewebkit \
USE_QT= core dbus gui network webkit widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-call-ui/Makefile b/net-im/ktp-call-ui/Makefile
index 259fa9ec9848..290e61ba7d18 100644
--- a/net-im/ktp-call-ui/Makefile
+++ b/net-im/ktp-call-ui/Makefile
@@ -25,4 +25,6 @@ USE_QT= core dbus gui network qml quick widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-common-internals/Makefile b/net-im/ktp-common-internals/Makefile
index 60644a228215..0de901f12ec8 100644
--- a/net-im/ktp-common-internals/Makefile
+++ b/net-im/ktp-common-internals/Makefile
@@ -27,4 +27,6 @@ USE_QT= core dbus gui network qml sql widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-contact-list/Makefile b/net-im/ktp-contact-list/Makefile
index ad30cd9300d6..73ac7955a3b5 100644
--- a/net-im/ktp-contact-list/Makefile
+++ b/net-im/ktp-contact-list/Makefile
@@ -19,4 +19,6 @@ USE_KDE= auth codecs completion config configwidgets coreaddons \
USE_QT= core dbus gui network widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-contact-runner/Makefile b/net-im/ktp-contact-runner/Makefile
index ab3afb7859ec..8ad683526983 100644
--- a/net-im/ktp-contact-runner/Makefile
+++ b/net-im/ktp-contact-runner/Makefile
@@ -16,4 +16,6 @@ USE_KDE= config coreaddons ecm i18n package plasma-framework runner \
USE_QT= core dbus gui network widgets xml\
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-desktop-applets/Makefile b/net-im/ktp-desktop-applets/Makefile
index 9794bdfd8dcc..1c683762933e 100644
--- a/net-im/ktp-desktop-applets/Makefile
+++ b/net-im/ktp-desktop-applets/Makefile
@@ -14,4 +14,6 @@ USE_KDE= ecm plasma-framework windowsystem
USE_QT= core dbus gui network qml widgets \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-filetransfer-handler/Makefile b/net-im/ktp-filetransfer-handler/Makefile
index 507df8f28dc4..99b2471d00d9 100644
--- a/net-im/ktp-filetransfer-handler/Makefile
+++ b/net-im/ktp-filetransfer-handler/Makefile
@@ -17,4 +17,6 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
USE_QT= core dbus gui network xml widgets \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-kded-module/Makefile b/net-im/ktp-kded-module/Makefile
index 9614ef704e3e..74c55782fbd3 100644
--- a/net-im/ktp-kded-module/Makefile
+++ b/net-im/ktp-kded-module/Makefile
@@ -17,4 +17,6 @@ USE_KDE= activities auth codecs completion config configwidgets coreaddons \
USE_QT= concurrent core dbus gui network sql widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-send-file/Makefile b/net-im/ktp-send-file/Makefile
index cab72ca872ff..12eff9f09f55 100644
--- a/net-im/ktp-send-file/Makefile
+++ b/net-im/ktp-send-file/Makefile
@@ -19,4 +19,6 @@ USE_KDE= auth codecs completion config configwidgets coreaddons ecm \
USE_QT= core dbus gui network widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/ktp-text-ui/Makefile b/net-im/ktp-text-ui/Makefile
index f169825ef22e..85aeb6835ab9 100644
--- a/net-im/ktp-text-ui/Makefile
+++ b/net-im/ktp-text-ui/Makefile
@@ -23,4 +23,6 @@ USE_QT= core dbus gui location network qml quick speech webchannel \
buildtools_build qmake_build
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/prosody-modules/Makefile b/net-im/prosody-modules/Makefile
index 31dff4e878b5..dcadf1ccec5e 100644
--- a/net-im/prosody-modules/Makefile
+++ b/net-im/prosody-modules/Makefile
@@ -23,6 +23,8 @@ PLIST_SUB= INSTALLPATH=${INSTALLPATH}
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTNAME}
INSTALLPATH= ${PREFIX}/lib/${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${INSTALLPATH} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} mod_*/*.lua ${STAGEDIR}${INSTALLPATH}
diff --git a/net-im/sayaka/Makefile b/net-im/sayaka/Makefile
index f306d326d848..8e837cb0fc20 100644
--- a/net-im/sayaka/Makefile
+++ b/net-im/sayaka/Makefile
@@ -22,7 +22,7 @@ PORTDOCS= README.md
WRKSRC_SUBDIR= vala
-OPTIONS_DEFINE= COLORMAP
+OPTIONS_DEFINE= COLORMAP DOCS
OPTIONS_DEFAULT=COLORMAP
OPTIONS_SUB= yes
diff --git a/net-im/skype-devel/Makefile b/net-im/skype-devel/Makefile
index 257fee4403e2..7da7354e4227 100644
--- a/net-im/skype-devel/Makefile
+++ b/net-im/skype-devel/Makefile
@@ -14,7 +14,7 @@ COMMENT= P2P VoIP software, development version
CONFLICTS= skype-[0-9]*
-OPTIONS_DEFINE= VIDEO
+OPTIONS_DEFINE= DOCS VIDEO
OPTIONS_DEFAULT=VIDEO
VIDEO_DESC= [broken] Video support
diff --git a/net-im/skype/Makefile b/net-im/skype/Makefile
index a91cba9cc398..7b334f0af19e 100644
--- a/net-im/skype/Makefile
+++ b/net-im/skype/Makefile
@@ -14,7 +14,7 @@ COMMENT= P2P VoIP software
CONFLICTS= skype-devel-[0-9]*
-OPTIONS_DEFINE= VIDEO
+OPTIONS_DEFINE= DOCS VIDEO
OPTIONS_DEFAULT=VIDEO
NO_BUILD= yes
diff --git a/net-im/skype4/Makefile b/net-im/skype4/Makefile
index f1c6a5a71329..f8fda8f48077 100644
--- a/net-im/skype4/Makefile
+++ b/net-im/skype4/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${LINUXBASE}/lib/skype_oss_wrapper/libpulse.so.0:audio/linux-skype_
CONFLICTS= skype-devel-[0-9]*
-OPTIONS_DEFINE= VIDEO
+OPTIONS_DEFINE= DOCS VIDEO
OPTIONS_DEFAULT=VIDEO
NO_BUILD= yes
diff --git a/net-im/talkatu/Makefile b/net-im/talkatu/Makefile
index bf9f7d0b13b9..798d30546e02 100644
--- a/net-im/talkatu/Makefile
+++ b/net-im/talkatu/Makefile
@@ -22,4 +22,6 @@ USE_LDCONFIG= yes
MESON_ARGS= -Dgobject-introspection=false
WRKSRC= ${WRKDIR}/rw_grim-talkatu-${DISTNAME}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/net-im/telegram/Makefile b/net-im/telegram/Makefile
index 6161cc855e14..9283d5b85e85 100644
--- a/net-im/telegram/Makefile
+++ b/net-im/telegram/Makefile
@@ -33,6 +33,8 @@ PLIST_FILES= bin/telegram-cli \
etc/telegram-cli/server.pub
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/telegram-cli
${INSTALL_PROGRAM} ${WRKSRC}/bin/telegram-cli ${STAGEDIR}${PREFIX}/bin
diff --git a/net-im/vacuum-im/Makefile b/net-im/vacuum-im/Makefile
index e72b78352727..0bcbca5466ae 100644
--- a/net-im/vacuum-im/Makefile
+++ b/net-im/vacuum-im/Makefile
@@ -29,4 +29,6 @@ DESKTOP_ENTRIES="Vacuum-IM" "Modular, crossplatform Jabber client" \
"${PREFIX}/share/pixmaps/vacuum.png" "${PORTNAME}" \
"Qt;Network;InstantMessaging;" false
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>