aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-12-19 16:42:41 +0000
committerJohn Marino <marino@FreeBSD.org>2014-12-19 16:42:41 +0000
commit042424b7bf5b7a5671ba24eda7f0f7b06566ed0a (patch)
tree17c9a34afbf75c185d02d2a666cbfc71901fb423 /net-mgmt
parent31fb3cf6226c1022897f910347ffc78a91b8a17c (diff)
downloadports-042424b7bf5b7a5671ba24eda7f0f7b06566ed0a.tar.gz
ports-042424b7bf5b7a5671ba24eda7f0f7b06566ed0a.zip
net-mgmt/ccnet: Fix kernel thread support for DragonFly
PR: 196006 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=374950
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ccnet/Makefile2
-rw-r--r--net-mgmt/ccnet/files/patch-lib_utils.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/net-mgmt/ccnet/Makefile b/net-mgmt/ccnet/Makefile
index 26613660c111..6b58c66e3bb3 100644
--- a/net-mgmt/ccnet/Makefile
+++ b/net-mgmt/ccnet/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ccnet
PORTVERSION= 3.1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt devel
MAINTAINER= yan_jingfeng@yahoo.com
diff --git a/net-mgmt/ccnet/files/patch-lib_utils.c b/net-mgmt/ccnet/files/patch-lib_utils.c
index 2fa7aeafbcd3..cf66b30d6a13 100644
--- a/net-mgmt/ccnet/files/patch-lib_utils.c
+++ b/net-mgmt/ccnet/files/patch-lib_utils.c
@@ -92,7 +92,7 @@
+
+#elif defined(__DragonFly__)
+#define PSKIP(kp) ((kp)->kp_pid == mypid || \
-+ (!kthreads && ((kp)->kp_flags & P_KTHREADP) != 0))
++ (!kthreads && ((kp)->kp_flags & P_SYSTEM) != 0))
+#define KVM_OPENFILES(exec, coref, buf) \
+ kvm_openfiles(exec, coref, NULL, O_RDONLY, buf)
+#define KVM_GETPROCS(kd, plist, nproc) \