aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/gnewtellium
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-20 16:23:28 +0000
commit7ae7b018ccf7760013f368fcb83aad9ecd8982a8 (patch)
treee83ee6693050a76e305a95a376451aa583df151e /net-p2p/gnewtellium
parenta35ba13770957a577275c3575d979457605f2aff (diff)
downloadports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.tar.gz
ports-7ae7b018ccf7760013f368fcb83aad9ecd8982a8.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=417166
Diffstat (limited to 'net-p2p/gnewtellium')
-rw-r--r--net-p2p/gnewtellium/Makefile3
-rw-r--r--net-p2p/gnewtellium/files/patch-src_config.c (renamed from net-p2p/gnewtellium/files/patch-src__config.c)110
2 files changed, 57 insertions, 56 deletions
diff --git a/net-p2p/gnewtellium/Makefile b/net-p2p/gnewtellium/Makefile
index d812c31389fa..06a07ceb2011 100644
--- a/net-p2p/gnewtellium/Makefile
+++ b/net-p2p/gnewtellium/Makefile
@@ -13,7 +13,8 @@ COMMENT= Gnutella client
PORTSCOUT= skipv:0.05 # older than current one
USE_GNOME= gtk12
-USES= gmake
+USES= dos2unix gmake
+DOS2UNIX_GLOB= *.c
GNU_CONFIGURE= yes
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
diff --git a/net-p2p/gnewtellium/files/patch-src__config.c b/net-p2p/gnewtellium/files/patch-src_config.c
index 54d3eba3f8be..8c2d7e2a2535 100644
--- a/net-p2p/gnewtellium/files/patch-src__config.c
+++ b/net-p2p/gnewtellium/files/patch-src_config.c
@@ -1,55 +1,55 @@
---- src/config.c.orig Tue Feb 5 03:50:18 2002
-+++ src/config.c Tue Mar 9 20:37:00 2004
-@@ -539,8 +539,8 @@
- gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 0);
- gtk_widget_show(hbox);
-
-- label = gtk_label_new("Let Newtella know what speed your Internet Connection is.
--Setting this to an accurate number will help you get the most out of
-+ label = gtk_label_new("Let Newtella know what speed your Internet Connection is.\n\
-+Setting this to an accurate number will help you get the most out of\n\
- Newtella's advanced bandwidth management.");
- gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
- hbox = gtk_hbox_new(FALSE, 0);
-@@ -579,7 +579,7 @@
- gtk_widget_show(button);
-
- hbox = gtk_hbox_new(FALSE, 0);
-- label = gtk_label_new("Select the directory where you want to store your newly
-+ label = gtk_label_new("Select the directory where you want to store your newly\n\
- downloaded files.");
- gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
- gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
-@@ -627,8 +627,8 @@
- gtk_widget_show(hbox);
- gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 5);
-
-- label = gtk_label_new("Add any number of directories here.
--All .mp3 files under any of these directories can then be
-+ label = gtk_label_new("Add any number of directories here.\n\
-+All .mp3 files under any of these directories can then be\n\
- downloaded by other Newtella users.");
- gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
- hbox = gtk_hbox_new(FALSE, 0);
-@@ -686,8 +686,8 @@
- gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 10);
-
- hbox = gtk_hbox_new(FALSE, 0);
-- label = gtk_label_new("Select how much search results Newtella will maximally send to
--other clients. Use this to limit the impact of stupid searches on your
-+ label = gtk_label_new("Select how much search results Newtella will maximally send to\n\
-+other clients. Use this to limit the impact of stupid searches on your\n\
- computer.");
- gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
- gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
-@@ -724,8 +724,8 @@
- gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 10);
-
- hbox = gtk_hbox_new(FALSE, 0);
-- label = gtk_label_new("Returns the entered IP with search results instead of your real one.
--Useful if your're behind a NAT Firewall (like Windows 98 Internet
-+ label = gtk_label_new("Returns the entered IP with search results instead of your real one.\n\
-+Useful if your're behind a NAT Firewall (like Windows 98 Internet\n\
- Connection Sharing)");
- gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
- gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
+--- src/config.c.orig 2016-06-20 14:36:47 UTC
++++ src/config.c
+@@ -539,8 +539,8 @@ void config_draw(void)
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 0);
+ gtk_widget_show(hbox);
+
+- label = gtk_label_new("Let Newtella know what speed your Internet Connection is.
+-Setting this to an accurate number will help you get the most out of
++ label = gtk_label_new("Let Newtella know what speed your Internet Connection is.\n\
++Setting this to an accurate number will help you get the most out of\n\
+ Newtella's advanced bandwidth management.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ hbox = gtk_hbox_new(FALSE, 0);
+@@ -579,7 +579,7 @@ Newtella's advanced bandwidth management
+ gtk_widget_show(button);
+
+ hbox = gtk_hbox_new(FALSE, 0);
+- label = gtk_label_new("Select the directory where you want to store your newly
++ label = gtk_label_new("Select the directory where you want to store your newly\n\
+ downloaded files.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
+@@ -627,8 +627,8 @@ downloaded files.");
+ gtk_widget_show(hbox);
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 5);
+
+- label = gtk_label_new("Add any number of directories here.
+-All .mp3 files under any of these directories can then be
++ label = gtk_label_new("Add any number of directories here.\n\
++All .mp3 files under any of these directories can then be\n\
+ downloaded by other Newtella users.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ hbox = gtk_hbox_new(FALSE, 0);
+@@ -686,8 +686,8 @@ downloaded by other Newtella users.");
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 10);
+
+ hbox = gtk_hbox_new(FALSE, 0);
+- label = gtk_label_new("Select how much search results Newtella will maximally send to
+-other clients. Use this to limit the impact of stupid searches on your
++ label = gtk_label_new("Select how much search results Newtella will maximally send to\n\
++other clients. Use this to limit the impact of stupid searches on your\n\
+ computer.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
+@@ -724,8 +724,8 @@ computer.");
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 10);
+
+ hbox = gtk_hbox_new(FALSE, 0);
+- label = gtk_label_new("Returns the entered IP with search results instead of your real one.
+-Useful if your're behind a NAT Firewall (like Windows 98 Internet
++ label = gtk_label_new("Returns the entered IP with search results instead of your real one.\n\
++Useful if your're behind a NAT Firewall (like Windows 98 Internet\n\
+ Connection Sharing)");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);