aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/go-ethereum/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-08-04 19:29:35 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-08-04 19:29:35 +0000
commit5fc4c8f2f1f2bb8399dd1a8fd043a218fa6ec9c9 (patch)
treebd46fc5b451a3bbf80d10f749923a383cd9a705a /net-p2p/go-ethereum/Makefile
parent0c5aac4426d45c943d72b9db7518bbb074b4d071 (diff)
downloadports-5fc4c8f2f1f2bb8399dd1a8fd043a218fa6ec9c9.tar.gz
ports-5fc4c8f2f1f2bb8399dd1a8fd043a218fa6ec9c9.zip
- Update to version 1.4.10 [1]
- Move variables declarations before options block - Use option helpers for install target PR: 211560 [1] Submitted by: maintainer [1]
Notes
Notes: svn path=/head/; revision=419654
Diffstat (limited to 'net-p2p/go-ethereum/Makefile')
-rw-r--r--net-p2p/go-ethereum/Makefile42
1 files changed, 21 insertions, 21 deletions
diff --git a/net-p2p/go-ethereum/Makefile b/net-p2p/go-ethereum/Makefile
index 42ecd40feb2e..d47b3ce7c689 100644
--- a/net-p2p/go-ethereum/Makefile
+++ b/net-p2p/go-ethereum/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= go-ethereum
-PORTVERSION= 1.4.7
+PORTVERSION= 1.4.10
DISTVERSIONPREFIX= v
CATEGORIES= net-p2p
@@ -13,6 +13,11 @@ LICENSE= GPLv3
BUILD_DEPENDS= go:lang/go
RUN_DEPENDS= go:lang/go
+USE_GITHUB= yes
+GH_ACCOUNT= ethereum
+
+USE_GCC= yes
+
OPTIONS_DEFINE= BOOTNODE ETHTEST EVM DISASM RLPDUMP
OPTIONS_SUB= yes
@@ -22,27 +27,22 @@ EVM_DESC= A generic Ethereum Virtual Machine
DISASM_DESC= Disassembles EVM code
RLPDUMP_DESC= Prints RLP structures
-USE_GITHUB= yes
-GH_ACCOUNT= ethereum
-
-USE_GCC= yes
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build/bin/geth ${STAGEDIR}${PREFIX}/bin
- @if [ ${PORT_OPTIONS:MBOOTNODE} ]; then \
- ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/bootnode ${STAGEDIR}${PREFIX}/bin; \
- fi;
- @if [ ${PORT_OPTIONS:METHTEST} ]; then \
- ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/ethtest ${STAGEDIR}${PREFIX}/bin; \
- fi;
- @if [ ${PORT_OPTIONS:MEVM} ]; then \
- ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/evm ${STAGEDIR}${PREFIX}/bin; \
- fi;
- @if [ ${PORT_OPTIONS:MDISASM} ]; then \
- ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/disasm ${STAGEDIR}${PREFIX}/bin; \
- fi;
- @if [ ${PORT_OPTIONS:MRLPDUMP} ]; then \
- ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/rlpdump ${STAGEDIR}${PREFIX}/bin; \
- fi;
+
+do-install-BOOTNODE-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/bootnode ${STAGEDIR}${PREFIX}/bin
+
+do-install-ETHTEST-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/ethtest ${STAGEDIR}${PREFIX}/bin
+
+do-install-EVM-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/evm ${STAGEDIR}${PREFIX}/bin
+
+do-install-DISASM-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/disasm ${STAGEDIR}${PREFIX}/bin
+
+do-install-RLPDUMP-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/rlpdump ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>