aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/mldonkey-devel
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-08-28 19:01:22 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-08-28 19:01:22 +0000
commitc335e2d15426bb588aa256fd3d61c3a38cf9b3f4 (patch)
tree511901baae927459553d5b4ee5b895963735f500 /net-p2p/mldonkey-devel
parent21c7848dc92c998815f357dafb8a15aaf4632fdc (diff)
downloadports-c335e2d15426bb588aa256fd3d61c3a38cf9b3f4.tar.gz
ports-c335e2d15426bb588aa256fd3d61c3a38cf9b3f4.zip
o Much Makefile polishing [1]
o Update to 2.6.2 PR: 82466 [1] Submitted by: Jose M Rodriguez <josemi@freebsd.jazztel.es> [1]
Notes
Notes: svn path=/head/; revision=141175
Diffstat (limited to 'net-p2p/mldonkey-devel')
-rw-r--r--net-p2p/mldonkey-devel/Makefile26
-rw-r--r--net-p2p/mldonkey-devel/distinfo4
-rw-r--r--net-p2p/mldonkey-devel/pkg-message2
3 files changed, 18 insertions, 14 deletions
diff --git a/net-p2p/mldonkey-devel/Makefile b/net-p2p/mldonkey-devel/Makefile
index 90b0fce9ddcd..f7796c9bbe14 100644
--- a/net-p2p/mldonkey-devel/Makefile
+++ b/net-p2p/mldonkey-devel/Makefile
@@ -6,26 +6,19 @@
#
PORTNAME= mldonkey
-PORTVERSION= 2.6.0
+PORTVERSION= 2.6.2
CATEGORIES+= net
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME}-${DOWNLOADVERSION}
-
-PATCH_SITES= http://download.berlios.de/pub/mldonkey/spiralvoice/patchpacks/
-#PATCHFILES= patch_pack${PORTVERSION:C/^.\..\.(.)/\1/:C/\.//}.gz
MAINTAINER?= lioux@FreeBSD.org
COMMENT?= A OCAML client for multiple peer-to-peer networks
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-#DOWNLOADVERSION=${PORTVERSION:R}
-DOWNLOADVERSION=${PORTVERSION}
-
NO_LATEST_LINK= yes
-CONFLICTS= mldonkey-[0-9]* mldonkey-{core,gui}-[0.9]*
+CONFLICTS= mldonkey-[0-9]*
USE_BZIP2= yes
USE_ICONV= yes
@@ -44,8 +37,6 @@ CONFIGURE_ENV+= \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
-#WRKSRC= ${WRKDIR}/${PORTNAME}-${DOWNLOADVERSION}
-
###
## Options activation
###
@@ -57,12 +48,20 @@ CONFIGURE_ENV+= \
CONFIGURE_ARGS+=--disable-gui \
--disable-gd
PLIST_SUB+= CORE="" GUI="@comment " GUICORE="@comment "
+CONFLICTS+= mldonkey-core-[0.9]* mldonkey-core-stable-[0.9]* \
+ mldonkey-devel-[0-9]*
PKGNAMESUFFIX= -core-devel
.else
PLIST_SUB+= GUI=""
+CONFLICTS+= mldonkey-gui-[0.9]*
+.if !defined(WITHOUT_CORE)
+CONFLICTS+= mldonkey-devel-[0-9]*
+.endif
BUILD_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk \
${LOCALBASE}/lib/ocaml/jabbr.cma:${PORTSDIR}/net/ocaml-jabbr
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+
+CONFIGURE_ARGS+=--enable-gui=newgui1
# we don't need lablgtk as RUN dependency, but we need gtk+glib
USE_GNOME= gtk12
@@ -78,6 +77,7 @@ PLIST_SUB+= CORE="" GUICORE=""
DOCFILES= Authors.txt Bugs.txt ChangeLog Developers.txt FAQ.html \
Install.txt Readme.txt Todo.txt ed2k_links.txt
PORTDOCS= ${DOCFILES}
+PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
@@ -123,6 +123,10 @@ post-configure:
-e 's|^(PTHREAD_LIBS[^=]*=).*$$|\1${PTHREAD_LIBS}|' \
${BUILD_WRKSRC}/config/Makefile.config
+pre-install:
+ @${SED} -e 's,%%DOCSDIR%%,${DOCSDIR},' \
+ < ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+
do-install:
.ifndef(WITHOUT_CORE)
@${INSTALL_PROGRAM} ${WRKSRC}/mlnet ${PREFIX}/bin/mlnet-real
diff --git a/net-p2p/mldonkey-devel/distinfo b/net-p2p/mldonkey-devel/distinfo
index 725d807a3b57..9d5ede057d93 100644
--- a/net-p2p/mldonkey-devel/distinfo
+++ b/net-p2p/mldonkey-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (mldonkey-2.6.0.tar.bz2) = 3d9aff8eb7d44240950475ea1499ae75
-SIZE (mldonkey-2.6.0.tar.bz2) = 2622242
+MD5 (mldonkey-2.6.2.tar.bz2) = 9d7c0bdf332c656086d2c0bcbe8cb28d
+SIZE (mldonkey-2.6.2.tar.bz2) = 2655334
diff --git a/net-p2p/mldonkey-devel/pkg-message b/net-p2p/mldonkey-devel/pkg-message
index 9ec1ee80b84c..9758a622b676 100644
--- a/net-p2p/mldonkey-devel/pkg-message
+++ b/net-p2p/mldonkey-devel/pkg-message
@@ -1,7 +1,7 @@
ATTENTIONATTENTION:
- If you want to know how to use mldonkey, read "INSTALL" or
- "FAQ.html" in the port docs (/usr/local/share/doc/mldonkey)
+ "FAQ.html" in the port docs (%%DOCSDIR%%)
- It is not a bad idea to install mplayer. You will be able
to preview half-downloaded files (if you have the beginning).