aboutsummaryrefslogtreecommitdiff
path: root/net/kf5-kcalendarcore
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-21 14:21:55 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-22 07:25:14 +0000
commit3e5a910c9cef9017805b78fc0938c73fc59d87ba (patch)
tree572ea76a0cdafb3a32f6e098766dfc10e09cdb4c /net/kf5-kcalendarcore
parent8001be3c7b5f30ffbaeeb0f4cad65c40013a3966 (diff)
downloadports-3e5a910c9cef9017805b78fc0938c73fc59d87ba.tar.gz
ports-3e5a910c9cef9017805b78fc0938c73fc59d87ba.zip
KDE Frameworks: remove kdelibs4support dependencies
The PIM-related KDE Frameworks do not need kdelibs4support, so remove that dependency from their list. This lightens up the dependency tree for consumers -- only applications that acutally need kdelibs4 will get it.
Diffstat (limited to 'net/kf5-kcalendarcore')
-rw-r--r--net/kf5-kcalendarcore/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/kf5-kcalendarcore/Makefile b/net/kf5-kcalendarcore/Makefile
index 2b4f1a1988c0..1611cda8b1c2 100644
--- a/net/kf5-kcalendarcore/Makefile
+++ b/net/kf5-kcalendarcore/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kcalendarcore
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net kde kde-frameworks
@@ -11,7 +12,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libical.so:devel/libical
USES= bison cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
-USE_KDE= ecm emoticons init itemmodels itemviews kdelibs4support
+USE_KDE= ecm emoticons init itemmodels itemviews
USE_QT= core gui \
buildtools_build qmake_build
USE_LDCONFIG= yes