aboutsummaryrefslogtreecommitdiff
path: root/net/kf5-syndication
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2019-01-16 11:13:44 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2019-01-16 11:13:44 +0000
commit1bf487d3e73d83700f5a4aeb3a9ffbfc6e87856b (patch)
tree127ae6686665fd0ff97a7bd5f27449299929734e /net/kf5-syndication
parentd20d8aa75e51f61da14ac206199a1ebc244f940a (diff)
downloadports-1bf487d3e73d83700f5a4aeb3a9ffbfc6e87856b.tar.gz
ports-1bf487d3e73d83700f5a4aeb3a9ffbfc6e87856b.zip
Fix Qt5 symbol version scripts to put the catch-all clause first. When
a symbol matches multiple clauses the last one takes precedence. If the catch-all is last it captures everything. In the case of Qt5 libraries this caused all symbols to have a Qt_5 label while some should have Qt_5_PRIVATE_API. This only affects lld because GNU ld always gives the catch-all lowest priority. Older versions of Qt5Webengine exported some memory allocation symbols from the bundled Chromium. Version 5.9 stopped exporting these [1] but the symbols were kept as weak wrappers for the standard allocation functions to maintain binary compatibility. [2][3] The problem is that the call to the standard function in these weak wrappers is only resolved to the standard function if there's a call to this standard function in other parts of Qt5Webengine, because only then is there a non-weak symbol that takes precedence over the weak one. If there's no such non-weak symbol the call in the weak wrapper resolves to the weak wrapper itself creating an infinite call loop that overflows the stack and causes a crash. Some of the allocation functions are variants of C++ new and delete and it probably depends on the compiler whether these variants are used in other parts of Qt5Webengine. Remove the weak wrappers (make them Linux specific). This isn't binary compatible but we are already breaking that with the changes to the symbol versions. [1] https://github.com/qt/qtwebengine/commit/5c2cbfccf9aafb547b0b30914c4056abd25942a4 [2] https://github.com/qt/qtwebengine/commit/2ed5054e3a800fa97c2c9e920ba1e6ea4b6ef2a5 [3] https://github.com/qt/qtwebengine/commit/009f5ebb4bd6e50188671e0815a5dae6afe39db5 Bump all ports that depend on Qt5. PR: 234070 Exp-run by: antoine Approved by: kde (adridg)
Notes
Notes: svn path=/head/; revision=490472
Diffstat (limited to 'net/kf5-syndication')
-rw-r--r--net/kf5-syndication/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/net/kf5-syndication/Makefile b/net/kf5-syndication/Makefile
index e04231d92f65..774d22195137 100644
--- a/net/kf5-syndication/Makefile
+++ b/net/kf5-syndication/Makefile
@@ -2,6 +2,7 @@
PORTNAME= syndication
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net kde kde-frameworks